Bug 968 - nForce ALSA audio causes Badness in pci_find_subsys
nForce ALSA audio causes Badness in pci_find_subsys
Status: REJECTED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-20 05:10 UTC by Willem 3 de Bruijn
Modified: 2003-07-22 07:01 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.0-test1
Tree: Mainline
Regression: ---


Attachments

Description Willem 3 de Bruijn 2003-07-20 05:10:49 UTC
Distribution: gentoo (bare kernel install)
Hardware Environment: i386, Nvidia nForce, AMD XP1800+
Software Environment: using experimental NPTL glibc 2.3.2
Problem Description:

upon module dependency checking and loading the kernel gives an error
originating from drivers/pci/search.c:132. Full dmesg output follows below.

The only module that I am unable to load is the ALSA intel-snd8x0
device driver for my nForce onboard audio.

I'm currently trying to find out what's causing the WARN_ON(in_interrupt());
As I understand the expression (preempt_count() & (HARDIRQ_MASK | SOFTIRQ_MASK))
should be 0. I'll run a test to see which subexpression is
causing the problem and post an attachment ASAP.
----
full dmesg output :
Badness in pci_find_subsys at drivers/pci/search.c:133
Call Trace:
 [<c01cb177>] pci_find_subsys+0xe7/0xf0
 [<c01cb3f8>] pci_find_slot+0x38/0x60
 [<deadec70>] os_pci_init_handle+0x3a/0x67 [nvidia]
 [<deaf0d4f>] __nvsym00015+0x1f/0x24 [nvidia]
 [<debb7dab>] __nvsym03985+0x1f/0x24 [nvidia]
 [<deb94ca0>] __nvsym03792+0x208/0x1c38 [nvidia]
 [<c0165ae5>] send_sigio+0x125/0x2f0
 [<deafe63a>] __nvsym01479+0x3a/0x70 [nvidia]
 [<deafe63a>] __nvsym01479+0x3a/0x70 [nvidia]
 [<deb1bbe4>] __nvsym01474+0x28/0x34 [nvidia]
 [<deafe63a>] __nvsym01479+0x3a/0x70 [nvidia]
 [<c0127466>] send_signal+0x156/0x160
 [<c0123a81>] send_group_sig_info+0x31/0x60
 [<c0165ae5>] send_sigio+0x125/0x2f0
 [<deb1bcab>] __nvsym01359+0x2b/0x34 [nvidia]
 [<deafdfe4>] __nvsym01482+0x58/0x68 [nvidia]
 [<c0259838>] alloc_skb+0x48/0xf0
 [<c02575a6>] sock_alloc_send_pskb+0x1a6/0x2c0
 [<c011715a>] default_wake_function+0x2a/0x30
 [<deb97923>] __nvsym03801+0x1253/0x1260 [nvidia]
 [<deb949e6>] __nvsym03794+0x20e/0x2c0 [nvidia]
 [<deb99f8d>] __nvsym03839+0xc5/0x418 [nvidia]
 [<deb99e80>] __nvsym03823+0x68/0xb0 [nvidia]
 [<deb8fcdd>] __nvsym00553+0x85/0x944 [nvidia]
 [<c015003c>] do_sync_read+0x8c/0xc0
 [<debba78a>] __nvsym00630+0x9a/0x17c [nvidia]
 [<deaf3209>] __nvsym00746+0xd/0x1c [nvidia]
 [<deaf3e50>] rm_isr_bh+0xc/0x10 [nvidia]
 [<c011e296>] tasklet_action+0x46/0x70
 [<c011dfec>] do_softirq+0x9c/0xa0
 [<c010aeff>] do_IRQ+0x1af/0x240
 [<c0109284>] common_interrupt+0x18/0x20

this error occurs 9 times

Steps to reproduce:

build kerel
Comment 1 Willem 3 de Bruijn 2003-07-20 06:29:04 UTC
I've done a bit of debugging:

first of all I made a configuration error in my nForce ALSA settings leading to

preempt_count() == 258
=>
(preempt_count() & (HARDIRQ_MASK | SOFTIRQ_MASK))  == 256

after fixing this I received the following error

preempt_count() == 102
=>
(preempt_count() & (HARDIRQ_MASK | SOFTIRQ_MASK)) == 100

Unfortunately I have no idea what this means and whether it poses a problem.
What I do know is that xmms in oss emulation mode, xmms in pure ALSA output mode
and mplayer in both modes lock up immediately.

Since I haven't tried previous versions of the kernel with ALSA (I used OSS for
simplicity) I'm not quite sure this is a new bug, a previous one I didn't find
on the mailing lists or a configuration error. I'll try my previous kernel
(2.5.70) with ALSA to figure this out.
Comment 2 Greg Kroah-Hartman 2003-07-21 10:04:46 UTC
This driver is not in the 2.6.0-test1 kernel tree.
I can't find the os_pci_init_handle function anywhere...


Where does it come from?os_pci_init_handle
Comment 3 Willem 3 de Bruijn 2003-07-22 02:13:15 UTC
It might be part of the binary nvidia released video driver. I didn't know it could mess up the system, 
since the video did not cause any actual problems. Being a binary release I have no way to find out 
whether this is the codebase in which `os_pci_init_handle' resides.  
 
Anyway, searching through a couple of fora online I noticed a message saying that ALSA has problems 
working simultaneously with ACPI. Disabling this code did solve my problem. I'm afraid, therefore, 
that I posted this bugreport in the wrong category. My apologies for this. It seems I had two problems 
mixed up into a ball of errorreports and other symptoms. 
  
  
Comment 4 Greg Kroah-Hartman 2003-07-22 05:59:42 UTC

*** This bug has been marked as a duplicate of 10 ***
Comment 5 Greg Kroah-Hartman 2003-07-22 06:02:50 UTC
Please file a new bug, if you still have problems, without the nvidia driver.
Comment 6 Willem 3 de Bruijn 2003-07-22 07:01:40 UTC
It seems that this is not a kernel bug now, so I won't update it anymore. Thanks for your help. 

Note You need to log in before you can comment on or make changes to this bug.