Bug 9661 - Booting from nfsroot fails
Booting from nfsroot fails
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: IPV4
All Linux
: P1 blocking
Assigned To: Horms
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-29 11:54 UTC by Puzin, Dimitri
Modified: 2008-01-11 18:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc6-git4
Tree: Mainline
Regression: Yes


Attachments
Kernel patch. Fixes nfs boot problem. (1.47 KB, patch)
2007-12-29 11:56 UTC, Puzin, Dimitri
Details | Diff
My kernel config for reference (38.44 KB, text/plain)
2007-12-29 11:58 UTC, Puzin, Dimitri
Details

Description Puzin, Dimitri 2007-12-29 11:54:00 UTC
Most recent kernel where this bug did not occur: 2.6.24-rc6-git3
Distribution: Debian GNU Linux 4.0/Etch
Hardware Environment: Intel DG965SS, 4GB RAM, onboard e1000, no HDD
Software Environment: Debian GNU Linux 4.0r2 x86_64
Problem Description: Starting with -git4 release the System won't boot from network. Booting with root=/dev/nfs ip=dhcp for example ends in asking the user to insert a boot floppy. This is obviously not the expected result when booting from network. 

The cause seem to be the changeset a6c05c3d064dbb83be88cba3189beb5db9d2dfc3. Looking at the code I found that ic_enable doesn't get set as expected. This prevents the kernel from initializing the ip configuration. 

The patch & my LK conf (for reference) are attached. This may be not the ideal way of solving this, there are probably better ones. This one "Works For Me" :)
Comment 1 Puzin, Dimitri 2007-12-29 11:56:08 UTC
Created attachment 14224 [details]
Kernel patch. Fixes nfs boot problem.
Comment 2 Puzin, Dimitri 2007-12-29 11:58:08 UTC
Created attachment 14225 [details]
My kernel config for reference
Comment 3 Anonymous Emailer 2007-12-29 15:15:15 UTC
Reply-To: akpm@linux-foundation.org

On Sat, 29 Dec 2007 11:54:07 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=9661
> 
>            Summary: Booting from nfsroot fails
>            Product: Networking
>            Version: 2.5
>      KernelVersion: 2.6.24-rc6-git4
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: blocking
>           Priority: P1
>          Component: IPV4
>         AssignedTo: shemminger@linux-foundation.org
>         ReportedBy: bugs@psycast.de
> 
> 
> Most recent kernel where this bug did not occur: 2.6.24-rc6-git3
> Distribution: Debian GNU Linux 4.0/Etch
> Hardware Environment: Intel DG965SS, 4GB RAM, onboard e1000, no HDD
> Software Environment: Debian GNU Linux 4.0r2 x86_64
> Problem Description: Starting with -git4 release the System won't boot from
> network. Booting with root=/dev/nfs ip=dhcp for example ends in asking the user
> to insert a boot floppy. This is obviously not the expected result when booting
> from network. 
> 
> The cause seem to be the changeset a6c05c3d064dbb83be88cba3189beb5db9d2dfc3.
> Looking at the code I found that ic_enable doesn't get set as expected. This
> prevents the kernel from initializing the ip configuration. 
> 
> The patch & my LK conf (for reference) are attached. This may be not the ideal
> way of solving this, there are probably better ones. This one "Works For Me" :)

Thanks for the fix, but please send patches via email and not via bugzilla?

Suitable recipients for this one would be

netdev@vger.kernel.org
Simon Horman <horms@verge.net.au>
"David S. Miller" <davem@davemloft.net>

Comment 4 David S. Miller 2007-12-29 19:05:57 UTC
From: Andrew Morton <akpm@linux-foundation.org>
Date: Sat, 29 Dec 2007 15:14:01 -0800

> Thanks for the fix, but please send patches via email and not via bugzilla?
> 
> Suitable recipients for this one would be
> 
> netdev@vger.kernel.org
> Simon Horman <horms@verge.net.au>
> "David S. Miller" <davem@davemloft.net>

Simon already sent me a fix for this a few days ago, it's
in my tree and will be sent to Linus in due time.

Comment 5 Rafael J. Wysocki 2008-01-11 16:01:11 UTC
Can anyone provide the fixing commit name, please?
Comment 6 Andrew Morton 2008-01-11 17:58:32 UTC
Hopefully 9cecd07c3f7a818a5865daad8cb5be408508dc99 fixed this?
Comment 7 Horms 2008-01-11 18:58:57 UTC
There were actually two regressions here, and two fixes.
They probably need to be applied in this order:

commit 9cecd07c3f7a818a5865daad8cb5be408508dc99
Author: Simon Horman <horms@verge.net.au>
Date:   Thu Dec 27 21:19:10 2007 -0800

    [IPV4] Fix ip=dhcp regression


commit 92ffb85dd33d62ac1dad8b44da62365f2aad413d
Author: Amos Waterland <apw@us.ibm.com>
Date:   Sat Jan 5 23:23:06 2008 -0800

    [IPV4] ipconfig: Fix regression in ip command line processing

Note You need to log in before you can comment on or make changes to this bug.