Bug 9635 - Unaligned accesses in xfs_file_readdir
Unaligned accesses in xfs_file_readdir
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: XFS
All Linux
: P1 normal
Assigned To: XFS Guru
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-25 17:47 UTC by Dustin Marquess
Modified: 2008-01-11 12:32 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc6
Tree: Mainline
Regression: Yes


Attachments
partial revert of commit 041388b54 (757 bytes, patch)
2008-01-01 12:25 UTC, Ingo Molnar
Details | Diff
attempted XFS fix, take #2 (1016 bytes, patch)
2008-01-01 12:27 UTC, Ingo Molnar
Details | Diff
Christoph Hellwig's patch (1.59 KB, patch)
2008-01-01 14:04 UTC, Dustin Marquess
Details | Diff

Description Dustin Marquess 2007-12-25 17:47:27 UTC
Most recent kernel where this bug did not occur: 2.6.23
Distribution: Debian/lenny
Hardware Environment: API CS20D (2 x 833Mhz EV68AL Alpha CPUs)
Software Environment: 

Linux sky 2.6.24-rc6-mm1 #1 SMP Mon Dec 24 00:24:38 CST 2007 alpha GNU/Linux
 
Gnu C                  4.2.3
Gnu make               3.81
binutils               2.18.20071027
util-linux             2.13
mount                  2.13
module-init-tools      3.3-pre11
e2fsprogs              1.40.2
xfsprogs               2.9.4
Linux C Library        2.7
Dynamic linker (ldd)   2.7
Procps                 3.2.7
Net-tools              1.60
Console-tools          0.2.3
Sh-utils               5.97
udev                   114
Modules Loaded         xt_multiport xt_state ip6table_mangle ip6table_filter ip6_tables iptable_mangle iptable_filter adm9240 hwmon_vid loop i2c_ali1535 i2c_ali15x3 i2c_core sd_mod ide_cd_mod cdrom generic sym53c8xx e100 scsi_transport_spi alim15x3 mii scsi_mod ide_core

(Note: -mm1 compile, however bug was introduced in 2.6.24-rc6 patch, not -mm1)

Problem Description:

kernel unaligned acc    : 270990 (pc=fffffc00011855f4,va=fffffc007e39204b)

From System.map:

fffffc0001185480 t xfs_file_readdir
fffffc0001185650 t xfs_hack_filldir

Steps to reproduce:

Boot.  ls a directory on a XFS filesystem.

Seems to be caused by the major xfs_file.c changes in the 2.6.24-rc6 patch.
Comment 1 Ingo Molnar 2008-01-01 12:25:35 UTC
Created attachment 14248 [details]
partial revert of commit 041388b54

Does the attached patch make any difference? It's a partial revert of one of the XFS changes in -rc6. (NOTE: i'm not an XFS expert so this could easily be the wrong patch.)
Comment 2 Ingo Molnar 2008-01-01 12:27:42 UTC
Created attachment 14249 [details]
attempted XFS fix, take #2
Comment 3 Dustin Marquess 2008-01-01 14:03:58 UTC
I'll take a look at that.

Christoph Hellwig <hch@lst.de> posted a patch to the XFS list that seems to fix it.  I'll attach it here.  I definitely not an expert, so I'll let somebody else decide which fix is "better".
Comment 4 Dustin Marquess 2008-01-01 14:04:47 UTC
Created attachment 14255 [details]
Christoph Hellwig's patch
Comment 5 Ingo Molnar 2008-01-02 02:46:58 UTC
ah, ok - disregard my patch then.
Comment 6 Adrian Bunk 2008-01-11 12:32:24 UTC
Fix is now as commit aea6ad0ce5e215ce99fe9e3edd9268f696862d8f in Linus' tree.

Note You need to log in before you can comment on or make changes to this bug.