Bug 9634 - Loading w83627ehf hangs computer after reboot at bios on ASUS P5K SE
Loading w83627ehf hangs computer after reboot at bios on ASUS P5K SE
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Hardware Monitoring
All Linux
: P1 high
Assigned To: Jean Delvare
:
Depends on:
Blocks: 9056
  Show dependency treegraph
 
Reported: 2007-12-25 09:38 UTC by Adam Kułagowski
Modified: 2008-01-06 05:02 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.23.12
Tree: Mainline
Regression: Yes


Attachments
Be more careful when changing VID input level (2.27 KB, patch)
2007-12-25 12:37 UTC, Jean Delvare
Details | Diff
Be more careful when changing VID input level (v2) (2.53 KB, patch)
2007-12-26 06:56 UTC, Jean Delvare
Details | Diff

Description Adam Kułagowski 2007-12-25 09:38:52 UTC
Most recent kernel where this bug did not occur:
Distribution: Ubuntu kernel 2.6.22.15 or see below
Hardware Environment: ASUS P5K SE , 4x1GB memory 
Software Environment: Ubuntu/Debian sid
Problem Description:

I've bought recently new motherboard - ASUS P5K SE. It contains
W83627DHG sensor chip.

Everything was working fine using 2.6.22.15 kernel except IDE chip
(marvel). So I've upgraded to 2.6.23.12. And here the story begins.

After modprobed w83627ehf I received:
w83627ehf: Found W83627DHG chip at 0x290
w83627ehf w83627ehf.656: Setting VID input voltage to TTL
w83627ehf w83627ehf.656: VID pins in output mode, CPU VID not available

I was able to read voltage, fan temperature etc. However after I've
tried to reboot, at the end of reboot procedure the computer powered
itself off (fans stopped working), then 5 seconds later it powered
itself on but screen was blank. Only fans, disks were working.
Unplugging power cord,resetting,  didn't help.

After long (long) fight of switching hardware, clearing cmos etc I've
found shortest way to unbrick my computer:

After I've removed memory dimms from first and second slot, I was able
to boot, but computer was showing strange memory amount. It should show
2048MB but the test stopped at 1308MB (or other random number, lower
that total memory amount). After pushing the reset button the amount of
memory was finally correct and I was able to insert again memory in
first and second slot. Then the computer showed finally 4096MB of memory
and I was able to boot my system up.

The problem is 100% repeatable. I was able to pinpoint problem to patch
from 2007-07-19, added to kernel tree, titled:
hwmon/w83627ehf: Add support for the VID inputs.

http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.23.y.git;a=commitdiff;h=fc18d6c0479d5b6da281590a8caf166d60cc748b

The version of w83627ehf before this patch works fine (compiled on 2.6.23.12 kernel).

Steps to reproduce: 
1. Load newest w83627ehf on Asus P5k SE 
2. reboot
Comment 1 Jean Delvare 2007-12-25 12:34:48 UTC
Thanks Adam for the very good bug report. I'll attach a fix shortly.
Comment 2 Jean Delvare 2007-12-25 12:37:00 UTC
Created attachment 14184 [details]
Be more careful when changing VID input level
Comment 3 Jean Delvare 2007-12-25 12:38:01 UTC
Adam, please test the attached patch and report if it reliably fixes the bug.
Comment 4 Jean Delvare 2007-12-26 06:56:47 UTC
Created attachment 14190 [details]
Be more careful when changing VID input level (v2)

Updated patch, only touch the VID level on the W83627EHF/EHG. The W83627DHG is more complex in this respect and I don't want to risk to mess it up.
Comment 5 Adam Kułagowski 2007-12-26 07:45:19 UTC
Both patches works fine fine on clean 2.6.23.12. The problem is fixed. 

Thanks.
Comment 6 Jean Delvare 2007-12-26 09:28:10 UTC
Mark, this patch needs to go into 2.6.24 before final, and then into 2.6.23-stable.
Comment 7 Jean Delvare 2008-01-06 05:02:27 UTC
The patch made it into Linus' tree by now:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=58e6e78119da2bdade9f6f588155f0320072b76b

I'll submit it for 2.6.23-stable.

Note You need to log in before you can comment on or make changes to this bug.