Bug 96301 - Oops evaluating _HPP in Xen domU kernel (no ACPI present)
Summary: Oops evaluating _HPP in Xen domU kernel (no ACPI present)
Status: RESOLVED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_pci@kernel-bugs.osdl.org
URL: http://lkml.kernel.org/r/201503241528...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-07 20:05 UTC by Bjorn Helgaas
Modified: 2016-10-28 20:43 UTC (History)
0 users

See Also:
Kernel Version: v3.18
Tree: Mainline
Regression: Yes


Attachments

Description Bjorn Helgaas 2015-04-07 20:05:12 UTC
Michael D Labriola reported this oops:

On Tue, Mar 24, 2015 at 11:14:29AM -0400, Michael D Labriola wrote:
> I'm having problems booting a 3.18 or newer domU w/ PCI devices passed 
> through.  It only seems to be the domU kernel that's upset (i.e., Behavior 
> is identical whether I'm running 3.19 or 3.13 dom0).  I'm running a 32bit 
> dom0 (3.13.11) w/ 64bit 4.4.0 hypervisor and 32bit domU.  I get the 
> following Oops when trying to boot my domU with a couple PCI cards passed 
> through:
> 
> BUG: unable to handle kernel paging request at 0030303e
> IP: [<c06ed0e6>] acpi_ns_validate_handle+0x12/0x1a
> ...
> Call Trace:
>  [<c06eda4d>] ? acpi_evaluate_object+0x31/0x1fc
>  [<c096a21d>] ? resume_kernel+0x5/0x7
>  [<c06b78e1>] ? pci_get_hp_params+0x111/0x4e0
>  [<c0407bc7>] ? xen_force_evtchn_callback+0x17/0x30
>  [<c04085fb>] ? xen_restore_fl_direct_reloc+0x4/0x4
>  [<c0699d34>] ? pci_device_add+0x24/0x450
>  [<c06975ce>] ? pci_bus_read_config_word+0x6e/0x80
>  [<c069a66d>] ? pci_scan_single_device+0x8d/0xb0
>  [<c069a6cc>] ? pci_scan_slot+0x3c/0xf0
>  [<c069b1bc>] ? pci_scan_child_bus+0x1c/0x90
Comment 1 Bjorn Helgaas 2015-04-14 16:00:34 UTC
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=8647ca9ad5a0 will appear in v4.1-rc1, and it works around this issue.

But I think that fix is a band-aid, so I'd like to keep this bugzilla open for a while and see if we can figure out a better fix.
Comment 2 Bjorn Helgaas 2016-10-28 20:43:25 UTC
No new ideas seem forthcoming, so I'm closing this.

Note You need to log in before you can comment on or make changes to this bug.