Bug 9621 - Problems on booting
Problems on booting
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: io_scsi
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-22 14:29 UTC by Rafael J. Wysocki
Modified: 2009-03-23 09:15 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc5-git7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-12-22 14:29:30 UTC
Subject         : Problems on booting
Submitter       : "werner" <werner@copaya.yi.org>
References      : http://lkml.org/lkml/2007/12/22/110
Comment 1 Natalie Protasevich 2008-02-01 21:52:13 UTC
Werner's description:
There seems to have two regressions between the kernels from yesterday and before-yesterday
On the kernel -git7 what didnt happened on -git6

1) My hard disk is /dev/hda, but when I have an usb key sticked in /dev/sba, and run lilo then, then it dont boot but give L99 99 99 99 ... error.  When I remove the usb stick from /dev/sba , and run then #lilo ,  then the result boots.  This problem was not present at the -git6 kernel

2) The boot stops / hangs on hardware detection of SCSI.  I have an Initio INI-9X00U/UW. The last messages during boot are, that it's verifying i91u scsi2 , then the boot hangs.  When I put the pci=off kernel option, then the boot process continues (but with this, by other reasons, my computer works only half, so that this is unpracticable).      This problem also didnt happens with the -git6 kernel    This problem happens only on one of my two computers, because the other has no SCSI card inside, that computer boots normally.
Comment 2 Alan 2008-02-12 06:06:51 UTC
LILO is before Linux runs so that seems like a lilo bug  to file against your disto

The initio driver had bugs but should be fixed now (2.6.24)

Note You need to log in before you can comment on or make changes to this bug.