Bug 9568 - Regression: Wireshark sees no packets in 2.6.24-rc3
Regression: Wireshark sees no packets in 2.6.24-rc3
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Ray Lee
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-14 17:43 UTC by Rafael J. Wysocki
Modified: 2007-12-15 15:24 UTC (History)
0 users

See Also:
Kernel Version: 2.6.24-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-12-14 17:43:47 UTC
Subject         : Regression: Wireshark sees no packets in 2.6.24-rc3
Submitter       : "Ray Lee" <ray@madrabbit.org>
References      : http://lkml.org/lkml/2007/12/13/575
Comment 1 Stephen Hemminger 2007-12-14 17:55:36 UTC
You need to list the hardware because it is very likely a device driver issue.
Comment 2 Ray Lee 2007-12-14 23:04:01 UTC
Don't think it's a hardware issue, as I can't even get any packets printed on loopback (`tshark -i lo & ping 127.0.0.1 &` shows nothing).

Regardless: broadcom wireless (bcm43xx), tg3 wired, on x86-64.

Another person tried -rc5 is fine for them, so likely this is either something that's fixed already, or perhaps my make oldconfig disabled something necessary? No clue.

Will re-test current git head (-rc5) in the morning and report.

Thanks.
Comment 3 Ray Lee 2007-12-15 00:11:02 UTC
Okay, -rc5 works great. I have no idea what changed between -rc3 and -rc5, or whether it was a .config change (the diff doesn't show much interesting for .config between the two).

Really not sure why -rc3 isn't working for me, but I guess it really doesn't matter. Sorry for the false alarm.

Note You need to log in before you can comment on or make changes to this bug.