Bug 95591 - SBS driver very often stalls boot when built into the kernel, fine as a module however
Summary: SBS driver very often stalls boot when built into the kernel, fine as a modul...
Status: CLOSED DUPLICATE of bug 94651
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: acpi_power-battery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-25 18:54 UTC by Oliver
Modified: 2015-07-15 02:37 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.0.0-r5
Tree: Mainline
Regression: No


Attachments

Description Oliver 2015-03-25 18:54:21 UTC
When compiling the sbs modules into the kernel, the system very often stalls when booting.

[    0.632142] ACPI: AC Adapter [ADP1] (off-line)
[    0.632224] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[    0.632261] ACPI: Lid Switch [LID0]
[    0.632307] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
[    0.632336] ACPI: Power Button [PWRB]
[    0.632381] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
[    0.632410] ACPI: Sleep Button [SLPB]
[    0.632454] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[    0.632480] ACPI: Power Button [PWRF]
[    0.632785] ACPI: SBS HC: EC = 0xffff880265ba0e80, offset = 0x20, query_bit = 0x10
[    1.098896] random: nonblocking pool is initialized
[    1.603738] tsc: Refined TSC clocksource calibration: 2400.000 MHz
[    2.604593] Switched to clocksource tsc
[  529.576106] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[  529.576646] Non-volatile memory driver v1.3
[  529.578082] Linux agpgart interface v0.103

Very occasionally however (1-10 boots, completly random if cold boot or reboot) sbs boots normally.

[    0.631947] ACPI: AC Adapter [ADP1] (off-line)
[    0.632028] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[    0.632066] ACPI: Lid Switch [LID0]
[    0.632112] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
[    0.632142] ACPI: Power Button [PWRB]
[    0.632187] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
[    0.632216] ACPI: Sleep Button [SLPB]
[    0.632262] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[    0.632287] ACPI: Power Button [PWRF]
[    0.632593] ACPI: SBS HC: EC = 0xffff880265ba0e80, offset = 0x20, query_bit = 0x10
[    0.669114] ACPI: Smart Battery System [SBS0]: Battery Slot [BAT0] (battery present)
[    0.669227] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    0.669781] Non-volatile memory driver v1.3
[    0.669802] Linux agpgart interface v0.103

I've started to experience this when building 3.18, but I wouldn't be supprised if this bug is older then that; most/all distro kernels have this as a module.

All works fine with everything built into the kernel (except for sbs/sbshc.

I booted the kernel with the debug flag, but didn't get anything extra on this bit.
Comment 1 Aaron Lu 2015-04-21 02:29:05 UTC
Is this a Macbook?
Comment 2 Oliver 2015-04-21 06:08:49 UTC
I forgot to mention, but yes, yes it is.
Apple Inc. MacBookPro11,1/Mac-xxxx, BIOS MBP111.88Z.0138.B14.1501071216 01/07/201
Comment 3 Aaron Lu 2015-04-21 06:16:14 UTC

*** This bug has been marked as a duplicate of bug 94651 ***

Note You need to log in before you can comment on or make changes to this bug.