Bug 9557 - Could not set non-blocking flag with 2.6.24-rc5
Could not set non-blocking flag with 2.6.24-rc5
Status: CLOSED UNREPRODUCIBLE
Product: File System
Classification: Unclassified
Component: VFS
All Linux
: P1 normal
Assigned To: fs_vfs
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-13 16:27 UTC by Rafael J. Wysocki
Modified: 2008-01-13 13:22 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24-rc5
Tree: Mainline
Regression: Yes


Attachments
working run with 2.6.23.8 in a chroot (208.11 KB, text/plain)
2007-12-17 23:43 UTC, Tino Keitel
Details
broken run with 2.6.24-rc5 in a chroot (192.68 KB, text/plain)
2007-12-17 23:44 UTC, Tino Keitel
Details
working run with 2.6.23.8 outside a chroot (567.22 KB, text/plain)
2007-12-17 23:45 UTC, Tino Keitel
Details
working run with 2.6.24-rc5 outside a chroot (549.43 KB, text/plain)
2007-12-17 23:45 UTC, Tino Keitel
Details

Description Rafael J. Wysocki 2007-12-13 16:27:26 UTC
Subject         : Could not set non-blocking flag with 2.6.24-rc5
Submitter       : Tino Keitel <tino.keitel@gmx.de>
References      : http://lkml.org/lkml/2007/12/13/392
Comment 1 Trond Myklebust 2007-12-13 16:52:45 UTC
>  [pid  5988] fcntl64(-1, F_GETFL)        = -1 EBADF (Bad file descriptor)

Err... '-1' has always been an illegal value for a file descriptor. POSIX
tells you explicitly that if open() or creat() return -1, then that is a
sign of an error. I'm surprised that aptitude isn't checking for that.

That said, could you show the part from the strace that actually contains the
open() that failed?
Comment 2 Tino Keitel 2007-12-17 23:43:51 UTC
Created attachment 14098 [details]
working run with 2.6.23.8 in a chroot
Comment 3 Tino Keitel 2007-12-17 23:44:30 UTC
Created attachment 14099 [details]
broken run with 2.6.24-rc5 in a chroot
Comment 4 Tino Keitel 2007-12-17 23:45:01 UTC
Created attachment 14100 [details]
working run with 2.6.23.8 outside a chroot
Comment 5 Tino Keitel 2007-12-17 23:45:28 UTC
Created attachment 14101 [details]
working run with 2.6.24-rc5 outside a chroot
Comment 6 Tino Keitel 2007-12-17 23:46:36 UTC
I attached some complete strace outputs of the working and the broken condision. I hope that helps.
Comment 7 Linus Torvalds 2008-01-01 14:07:41 UTC
At least for the chroot case, you're getting

   open("/dev/null", O_RDWR) = -1 ENXIO (No such device or address)

which to me implies that you have a broken /dev, possibly due to some
odd udev issue or just your chroot environment getting broken by
something.
Comment 8 Tino Keitel 2008-01-06 03:13:25 UTC
The chroot is extracted from the same .tar.gz in each of the above cases. I'll check if I can see what's wrong with /dev/null in the error case.
Comment 9 Adrian Bunk 2008-01-11 12:37:47 UTC
Tino, any updates?
Comment 10 Tino Keitel 2008-01-13 10:20:50 UTC
I can not reproduce it anymore with 2.6.24-rc4.
Comment 11 Rafael J. Wysocki 2008-01-13 13:12:09 UTC
Closing as unreproducible.  Please reopen if it reappears.
Comment 12 Tino Keitel 2008-01-13 13:22:47 UTC
Err, I meant 2.6.24-rc7 (I was told that this was a XFS issue that is fixed in 2.6.24-rc7).

Note You need to log in before you can comment on or make changes to this bug.