Bug 95461 - [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Summary: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO unde...
Status: RESOLVED DUPLICATE of bug 79261
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P3 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-24 21:05 UTC by Cristian Aravena Romero
Modified: 2016-06-09 12:02 UTC (History)
11 users (show)

See Also:
Kernel Version: 4.0-rc5
Tree: Mainline
Regression: No


Attachments
dmesg_4.0.0-040000rc5-generic.txt (68.92 KB, text/plain)
2015-03-24 21:05 UTC, Cristian Aravena Romero
Details
lspci -vvnn (8.63 KB, text/plain)
2015-03-24 21:05 UTC, Cristian Aravena Romero
Details
Complete dmesg file. (74.96 KB, text/plain)
2015-03-26 14:15 UTC, Alan Bartlett
Details
dmesg_4.0.0-040000rc6-generic.txt (60.93 KB, text/plain)
2015-03-30 12:06 UTC, Cristian Aravena Romero
Details
Complete dmesg file. (59.84 KB, text/plain)
2015-03-30 19:41 UTC, Alan Bartlett
Details
Complete dmesg file. (60.03 KB, text/plain)
2015-04-08 15:18 UTC, Alan Bartlett
Details
dmesg_4.0.0-040000-generic.txt (62.61 KB, text/plain)
2015-04-18 00:44 UTC, Cristian Aravena Romero
Details
dmesg_4.1.0-040000rc4-generic.txt (61.68 KB, text/plain)
2015-05-23 17:42 UTC, Cristian Aravena Romero
Details
Dmesg file, normal boot. (77.86 KB, text/plain)
2015-05-26 17:53 UTC, Alan Bartlett
Details
Dmesg file, booted with drm.debug=0x1e appended to kernel command line. (140.71 KB, text/plain)
2015-05-26 17:54 UTC, Alan Bartlett
Details
Full dmesg file for kernel 4.1-rc8 (77.72 KB, text/plain)
2015-06-19 12:41 UTC, Alan Bartlett
Details
Full dmesg file, kernel booted with drm.debug=0x1e (156.48 KB, text/plain)
2015-06-20 18:00 UTC, Alan Bartlett
Details
full dmesg for my machine (119.17 KB, application/octet-stream)
2016-06-09 11:58 UTC, Cruz Fernandez
Details

Description Cristian Aravena Romero 2015-03-24 21:05:03 UTC
Created attachment 172081 [details]
dmesg_4.0.0-040000rc5-generic.txt

Hello,

My report:
[    1.734792] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    1.735468] [drm:cpt_set_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[    1.735500] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment 1 Cristian Aravena Romero 2015-03-24 21:05:26 UTC
Created attachment 172091 [details]
lspci -vvnn
Comment 2 Alan Bartlett 2015-03-25 14:25:34 UTC
Confirming the above when using linux-4.0-rc5

Extracted from the dmesg file:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Defining the hardware (relevant lines from the output of an lspci -nnv command):

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Dell Device [1028:0263]
	Flags: bus master, fast devsel, latency 0, IRQ 28
	Memory at f6c00000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at efe8 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915
Comment 3 Cristian Aravena Romero 2015-03-26 07:05:31 UTC
Hi Alan,

You ouput of dmesg please.

Thanks,
--
Cristian
Comment 4 Alan Bartlett 2015-03-26 14:15:34 UTC
Created attachment 172451 [details]
Complete dmesg file.

The complete dmesg file, as requested.
Comment 5 Cristian Aravena Romero 2015-03-27 06:07:58 UTC
Oummm, thanks Alan.

One problem, I'see not message of bug similar(?) to:

"[    1.734792] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    1.735468] [drm:cpt_set_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[    1.735500] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun"

Please set drm.debug=14 module parameter and attach dmesg all the way from boot
to the problem. Thanks.

Many thanks for you time.
--
Cristian
Comment 6 Cristian Aravena Romero 2015-03-27 06:12:57 UTC
Hello Jani Nikula,

I'm adding for you information. Duplicated of https://bugzilla.kernel.org/show_bug.cgi?id=85951? I'm completed secure.

Thanks for you work,
--
Cristian
Comment 7 Cristian Aravena Romero 2015-03-27 06:14:19 UTC
* I'm not completed secure.
Comment 8 Jani Nikula 2015-03-27 06:52:52 UTC
I'm fairly confident the bug as reported in comment #0 is fixed in current Linus' master (not tagged as v4.0-rc6 yet, but it's there in the tree). Please reopen if the problem persists with that.
Comment 9 Jani Nikula 2015-03-27 06:54:01 UTC
Hmm, well, at least the WARNING backtraces should be gone. Not so confident about the underruns. :(
Comment 10 Alan Bartlett 2015-03-27 14:26:41 UTC
(In reply to Jani Nikula from comment #8)
> I'm fairly confident the bug as reported in comment #0 is fixed in current
> Linus' master (not tagged as v4.0-rc6 yet, but it's there in the tree).
> Please reopen if the problem persists with that.

I will wait for linux-4.0-rc6 and then re-check.
Comment 11 Cristian Aravena Romero 2015-03-28 11:05:04 UTC
Hello Alan,

Testing kernel ThE sunday.  Information The monday :)

Many thank for you work,
..
Cristian
Comment 12 Cristian Aravena Romero 2015-03-30 12:06:49 UTC
Created attachment 172671 [details]
dmesg_4.0.0-040000rc6-generic.txt

dmesg output in kernel 4.0-rc6 D: idem problem....

[    1.748191] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    1.748324] usb 4-1: New USB device found, idVendor=8087, idProduct=0024
[    1.748327] usb 4-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    1.748729] hub 4-1:1.0: USB hub found
[    1.748986] hub 4-1:1.0: 6 ports detected
[    1.750471] [drm:cpt_set_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[    1.750515] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment 13 Alan Bartlett 2015-03-30 19:40:17 UTC
Tested with linux-4.0-rc6 (on a RHEL6 system).

Still seeing the following error message in the dmesg file --

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Comment 14 Alan Bartlett 2015-03-30 19:41:15 UTC
Created attachment 172721 [details]
Complete dmesg file.
Comment 15 Cristian Aravena Romero 2015-03-30 22:53:41 UTC
Hello fengguang.wu developer,

We detail here, you could support us?

Thanks for you work,
--
Cristian
Comment 16 Alan Bartlett 2015-04-08 15:18:00 UTC
A kernel using the linux-4.0-rc7 sources was built --

Linux Duo2 4.0.0-0.rc7.el6.elrepo.x86_64 #1 SMP Mon Apr 6 21:27:18 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux

Upon boot the error CPU pipe A FIFO underrun message is still seen --

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

The complete dmesg file is attached.

This bug is NOT resolved with a code fix.
Comment 17 Alan Bartlett 2015-04-08 15:18:49 UTC
Created attachment 173561 [details]
Complete dmesg file.
Comment 18 Jani Nikula 2015-04-08 16:02:01 UTC
(In reply to Alan Bartlett from comment #16)
> This bug is NOT resolved with a code fix.

REOPEN.
Comment 19 Cristian Aravena Romero 2015-04-18 00:44:12 UTC
Created attachment 174321 [details]
dmesg_4.0.0-040000-generic.txt

[    1.746621] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    1.746713] ata2.00: ATA-9: SanDisk SSD i100 24GB, 11.50.04, max UDMA/133
[    1.746717] ata2.00: 46905264 sectors, multi 1: LBA48 NCQ (depth 31/32)
[    1.746784] hub 4-1:1.0: USB hub found
[    1.746857] hub 4-1:1.0: 6 ports detected
[    1.747037] ata1.00: ATA-8: Hitachi HTS545050A7E380, GG2OA6C0, max UDMA/133
[    1.747040] ata1.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    1.747093] [drm:cpt_set_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[    1.747125] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment 20 Cristian Aravena Romero 2015-05-23 17:42:31 UTC
Created attachment 177611 [details]
dmesg_4.1.0-040000rc4-generic.txt

Thanks for you work.
--
Cristian
Comment 21 Cristian Aravena Romero 2015-05-23 17:44:34 UTC
^^ -> [    1.720741] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[    1.721505] [drm:cpt_set_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[    1.721539] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
Comment 22 Ander Conselvan de Oliveira 2015-05-25 05:55:28 UTC
Please add drm.debug=0x1e to your kernel command line and upload dmesg again.
Comment 23 Alan Bartlett 2015-05-26 17:52:36 UTC
A kernel was built from the linux-4.1-rc5 sources.

A normal boot results in seeing --

[quote]
[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[/quote]

The attached dmesg-1.txt file originates from that boot.

Rebooted with drm.debug=0x1e appended to the kernel command line. The above error message was not then seen.

The attached dmesg-2.txt file originates from that boot.
Comment 24 Alan Bartlett 2015-05-26 17:53:42 UTC
Created attachment 177971 [details]
Dmesg file, normal boot.
Comment 25 Alan Bartlett 2015-05-26 17:54:44 UTC
Created attachment 177981 [details]
Dmesg file, booted with drm.debug=0x1e appended to kernel command line.
Comment 26 Alan Bartlett 2015-06-19 12:40:36 UTC
Kernel --

4.1-rc8

Error message still present --

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Comment 27 Alan Bartlett 2015-06-19 12:41:36 UTC
Created attachment 180411 [details]
Full dmesg file for kernel 4.1-rc8
Comment 28 Alan Bartlett 2015-06-20 18:00:20 UTC
Created attachment 180451 [details]
Full dmesg file, kernel booted with drm.debug=0x1e
Comment 29 Paul Menzel 2015-09-26 17:21:32 UTC
I am able to reproduce this with Lenovo T60.

```
$ sudo lspci -v -s 0:02
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
	Subsystem: Lenovo ThinkPad R60/T60/X60 series
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at e4300000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at 50a0 [size=8]
	Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Memory at e4400000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Kernel driver in use: i915

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
	Subsystem: Lenovo ThinkPad R60/T60/X60 series
	Flags: bus master, fast devsel, latency 0
	Memory at e4380000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: [d0] Power Management version 2

```

```
Sep 26 19:12:12 my-t60 kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
Sep 26 19:12:12 my-t60 kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
```
Comment 30 Paul Menzel 2015-09-26 17:22:45 UTC
Linux 4.2 is used.
Comment 31 Paul Menzel 2015-09-27 12:23:40 UTC
I am unable to reproduce this with a Lenovo X60 (Intel IGD) laptop.
Comment 32 Jani Nikula 2015-10-07 13:45:40 UTC

*** This bug has been marked as a duplicate of bug 79261 ***
Comment 33 Cruz Fernandez 2016-06-09 11:55:21 UTC
I've reproduced this error with kernel 4.5

sudo lspci -v -s 0:02
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller
	Flags: bus master, fast devsel, latency 0, IRQ 31
	Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at b0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 4000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915
	Kernel modules: i915

last part of dmesg:

[ +32,012300] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[  +0,001882] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[  +0,000025] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[  +0,029961] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
[  +0,056379] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder B
[  +0,031279] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun
[  +0,032886] [drm:intel_check_pch_fifo_underruns [i915]] *ERROR* pch fifo underrun on pch transcoder B

uname -a
Linux mymachine-XPS-L412Z 4.5.0-040500rc6-generic #201602281230 SMP Sun Feb 28 17:33:02 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Comment 34 Cruz Fernandez 2016-06-09 11:58:23 UTC
Created attachment 219381 [details]
full dmesg for my machine

Dmesg from my machine full
Comment 35 Jani Nikula 2016-06-09 12:02:51 UTC
(In reply to Cruz Fernandez from comment #33)
> I've reproduced this error with kernel 4.5

All drm/i915 bug tracking happens at http://bugs.freedesktop.org/ now.

Note You need to log in before you can comment on or make changes to this bug.