Bug 9525 - soft lockup - CPU#1 stuck for 15s! [swapper:0]
soft lockup - CPU#1 stuck for 15s! [swapper:0]
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Processor
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 9056
  Show dependency treegraph
 
Reported: 2007-12-07 18:14 UTC by Rafael J. Wysocki
Modified: 2008-06-13 21:43 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.24-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-12-07 18:14:04 UTC
Subject         : soft lockup - CPU#1 stuck for 15s! [swapper:0]
Submitter       : "Parag Warudkar" <parag.warudkar@gmail.com>
References      : http://lkml.org/lkml/2007/12/7/299
Handled-By      : "Pallipadi, Venkatesh" <venkatesh.pallipadi@intel.com>
Comment 1 Rafael J. Wysocki 2008-01-06 04:51:43 UTC
Not a regression, since it only appears with CPU_IDLE which is new in 2.6.24 (ref. http://lkml.org/lkml/2008/1/6/22).
Comment 2 Rafael J. Wysocki 2008-01-06 14:39:07 UTC
Parag says it is a regression after all, as CPU_IDLE is not necessary for reproducing it (ref. http://lkml.org/lkml/2008/1/6/153).
Comment 3 Rafael J. Wysocki 2008-01-07 16:58:38 UTC
This is a regression from 2.6.22 rather than from 2.6.23 (ref. http://lkml.org/lkml/2008/1/7/335).
Comment 4 Mike Hommey 2008-01-24 22:39:47 UTC
FWIW, I'm seeing this issue too.
Comment 5 Mike Hommey 2008-01-24 22:44:50 UTC
And if it matters, i'm seeing this on x86_64
Comment 6 Natalie Protasevich 2008-02-02 00:05:23 UTC
From Parag:
Got this on today's git (2.6.24-rc4) while compiling  stuff - Looks
like it is related to CpuIdle stuff.
I chose CONFIG_CPU_IDLE for the first time so I don't know when this
was introduced.

This is on x86_32, SMP.

BUG: soft lockup - CPU#1 stuck for 15s! [swapper:0]

Pid: 0, comm: swapper Not tainted (2.6.24-rc4 #3)
EIP: 0060:[<c0603e22>] EFLAGS: 00000202 CPU: 1
EIP is at _spin_lock_irqsave+0x16/0x27
EAX: c06b4110 EBX: 00000001 ECX: f7873808 EDX: 00000293
ESI: 00000005 EDI: f7873808 EBP: 00000000 ESP: f7829f10
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
CR0: 8005003b CR2: 004f5960 CR3: 372c5000 CR4: 000006d0
DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
DR6: ffff0ff0 DR7: 00000400
 [<c0438233>] tick_broadcast_oneshot_control+0x10/0xda
 [<c0437c82>] tick_notify+0x1d4/0x2eb
 [<c04281b4>] get_next_timer_interrupt+0x143/0x1b4
 [<c0605819>] notifier_call_chain+0x2a/0x47
 [<c04345a0>] raw_notifier_call_chain+0x17/0x1a
 [<c04378b7>] clockevents_notify+0x19/0x4f
 [<c0533cc3>] acpi_idle_enter_simple+0x183/0x1d0
 [<c058cea3>] cpuidle_idle_call+0x53/0x78
 [<c058ce50>] cpuidle_idle_call+0x0/0x78
 [<c0402575>] cpu_idle+0x97/0xb8
Comment 7 Natalie Protasevich 2008-02-02 00:18:31 UTC
Doesn't happen with latest git http://lkml.org/lkml/2008/1/10/481
(The cause was not identified)

Note You need to log in before you can comment on or make changes to this bug.