Bug 9504 - binfmt_misc file system is empty
binfmt_misc file system is empty
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
: 9523 (view as bug list)
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-05 02:35 UTC by Marcus Better
Modified: 2007-12-11 16:21 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc4
Tree: Mainline
Regression: Yes


Attachments
kernel config (53.29 KB, text/plain)
2007-12-05 02:36 UTC, Marcus Better
Details
diff-proc-shadow-lookup (1.81 KB, patch)
2007-12-05 14:22 UTC, Denis V. Lunev
Details | Diff

Description Marcus Better 2007-12-05 02:35:42 UTC
Most recent kernel where this bug did not occur: 2.6.24-rc3 (probably)
Distribution: Debian
Hardware Environment: Two laptops, i386 and x86_64
Software Environment: Debian testing/unstable
Problem Description:

The /proc/sys/fs/binfmt_misc/ directory is empty. The "register" and "status" files seem to have disappeared.

~$ ls /proc/sys/fs/binfmt_misc/
~$ mount | grep binfmt_misc
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
~$
Comment 1 Marcus Better 2007-12-05 02:36:49 UTC
Created attachment 13859 [details]
kernel config

Maybe I messed up the kernel config? But it seems ok to me.
Comment 2 Anonymous Emailer 2007-12-05 04:03:06 UTC
Reply-To: akpm@linux-foundation.org

thanks, I bisected it down to 2b1e300a9dfc3196ccddf6f1d74b91b7af55e416

Comment 3 Denis V. Lunev 2007-12-05 14:22:46 UTC
Created attachment 13876 [details]
diff-proc-shadow-lookup
Comment 4 Rafael J. Wysocki 2007-12-05 16:23:21 UTC
Marcus, please mark the bug as a regression, thanks.
Comment 5 Rafael J. Wysocki 2007-12-07 11:27:51 UTC
Commit 2b1e300a9dfc3196ccddf6f1d74b91b7af55e416 also causes other problems that aren't fixed by the patch from Comment #3 (http://lkml.org/lkml/2007/12/6/409).
Comment 6 Rafael J. Wysocki 2007-12-07 12:12:23 UTC
*** Bug 9523 has been marked as a duplicate of this bug. ***
Comment 7 Rafael J. Wysocki 2007-12-08 14:21:13 UTC
Patch is available: http://lkml.org/lkml/2007/12/7/364
Comment 8 Rafael J. Wysocki 2007-12-11 16:21:23 UTC
Fixed by:

commit 3790ee4bd86396558eedd86faac1052cb782e4e1
Author: Eric W. Biederman <ebiederm@xmission.com>
Date:   Mon Dec 10 15:49:36 2007 -0800

    proc: remove/Fix proc generic d_revalidate

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=3790ee4bd86396558eedd86faac1052cb782e4e1

Note You need to log in before you can comment on or make changes to this bug.