Bug 9499 - PS3: trouble with SPARSEMEM_VMEMMAP and kexec
PS3: trouble with SPARSEMEM_VMEMMAP and kexec
Status: CLOSED UNREPRODUCIBLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PS3
All Linux
: P1 normal
Assigned To: Geoff Levand
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-03 14:12 UTC by Rafael J. Wysocki
Modified: 2007-12-21 14:18 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-12-03 14:12:55 UTC
Subject         : PS3: trouble with SPARSEMEM_VMEMMAP and kexec
Submitter       : Geoff Levand <geoffrey.levand@am.sony.com>
References      : http://lkml.org/lkml/2007/12/3/137
Handled-By      : Milton Miller <miltonm@bga.com>

Probably caused by:

commit d29eff7bca60c9ee401d691d4562a4abca8de543 ppc64: SPARSEMEM_VMEMMAP support
commit 8f6aac419bd590f535fb110875a51f7db2b62b5b Generic Virtual Memmap support for SPARSEMEM
Comment 1 Rafael J. Wysocki 2007-12-11 16:18:06 UTC
Patch is available at http://lkml.org/lkml/2007/12/5/73 .
Comment 2 Rafael J. Wysocki 2007-12-21 05:22:48 UTC
The bug is not reproducible any more.
Comment 3 Rafael J. Wysocki 2007-12-21 14:18:51 UTC
Fix included in:


commit bbd0682596f7a434467ee551fee18d5f0b818539
Author: WANG Cong <xiyou.wangcong@gmail.com>
Date:   Mon Dec 17 16:19:59 2007 -0800

    mm/sparse.c: improve the error handling for sparse_add_one_section()

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=bbd0682596f7a434467ee551fee18d5f0b818539


Note You need to log in before you can comment on or make changes to this bug.