Bug 9496 - kobject ->k_name memory leak
kobject ->k_name memory leak
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-03 13:42 UTC by Rafael J. Wysocki
Modified: 2008-01-07 07:56 UTC (History)
2 users (show)

See Also:
Kernel Version: commit ce2c9cb0259acd2aed184499ebe41ab00da13b25
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-12-03 13:42:02 UTC
Subject         : kobject ->k_name memory leak
Submitter       : Alexey Dobriyan <adobriyan@sw.ru>
References      : http://lkml.org/lkml/2007/12/3/20
Handled-By      : Greg KH <gregkh@suse.de>

Caused by:

commit ce2c9cb0259acd2aed184499ebe41ab00da13b25
Author: Greg Kroah-Hartman <gregkh@suse.de>
Date:   Wed Sep 12 15:06:57 2007 -0700

    kobject: remove the static array for the name

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=ce2c9cb0259acd2aed184499ebe41ab00da13b25
Comment 1 Rafael J. Wysocki 2007-12-11 16:13:00 UTC
Any progress here?
Comment 2 Greg Kroah-Hartman 2007-12-14 13:52:21 UTC
On Tue, Dec 11, 2007 at 04:13:00PM -0800, bugme-daemon@bugzilla.kernel.org wrote:
> Any progress here?

This isn't going to be a "simple" fix at all, and is something for
2.6.25.  I suggest that we just accept the tiny memory leak for module
unload for 2.6.24, unless people really object.

thanks,

greg k-h

Comment 3 Greg Kroah-Hartman 2008-01-01 23:03:55 UTC
Now fixed in Linus's tree, turned out to be easier than anticipated....
Comment 4 Greg Kroah-Hartman 2008-01-01 23:08:33 UTC
now fixed.
Comment 5 Rafael J. Wysocki 2008-01-02 04:30:28 UTC
Can you provide the commit name, please?
Comment 6 Greg Kroah-Hartman 2008-01-07 07:56:21 UTC
d172f4ef31bec924c6ebcb242c9d7d290811e1e5 fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.