Bug 9495 - [2.6.24 BUG] 100% iowait on host while UML is running
[2.6.24 BUG] 100% iowait on host while UML is running
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: UML
All Linux
: P1 normal
Assigned To: Jeff Dike
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-12-03 13:25 UTC by Rafael J. Wysocki
Modified: 2007-12-07 17:51 UTC (History)
0 users

See Also:
Kernel Version: 2.6.24-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-12-03 13:25:51 UTC
Subject         : [2.6.24 BUG] 100% iowait on host while UML is running
Submitter       : Miklos Szeredi <miklos@szeredi.hu>
References      : http://lkml.org/lkml/2007/12/3/119
Handled-By      : Jeff Moyer <jmoyer@redhat.com>
Patch           : http://lkml.org/lkml/2007/12/3/192
Comment 1 Rafael J. Wysocki 2007-12-03 13:27:04 UTC
Caused by:

commit 41d10da3717409de33d5441f2f6d8f072ab3fbb6
Author: Jeff Moyer <jmoyer@redhat.com>
Date:   Tue Oct 16 23:27:20 2007 -0700

    aio: account I/O wait time properly

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=41d10da3717409de33d5441f2f6d8f072ab3fbb6
Comment 2 Rafael J. Wysocki 2007-12-07 17:51:45 UTC
Fixed by:

commit e00ba3dae077f54cfd2af42e939a618caa7a3bca
Author: Jeff Moyer <jmoyer@redhat.com>
Date:   Tue Dec 4 23:45:02 2007 -0800

    aio: only account I/O wait time in read_events if there are active requests

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=e00ba3dae077f54cfd2af42e939a618caa7a3bca

Note You need to log in before you can comment on or make changes to this bug.