Bug 9466 - uhci_hcd XXX: FGR not stopped yet!
uhci_hcd XXX: FGR not stopped yet!
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 low
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-11-28 07:38 UTC by Torsten Krah
Modified: 2008-09-23 09:22 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.22.9
Tree: Mainline
Regression: ---


Attachments

Description Torsten Krah 2007-11-28 07:38:57 UTC
Most recent kernel where this bug did not occur: Did not know exactly, but i guess it might be 2.6.21.
Distribution: Gentoo 2007.0
Hardware Environment: Samsung P35 XVM 1600 III 
Software Environment: 
Problem Description:

After booting and working with the laptop - all works fine so far i can see - looking at dmesg it gets spammed with messages like this:

uhci_hcd 0000:00:1d.1: FGR not stopped yet!
uhci_hcd 0000:00:1d.1: FGR not stopped yet!
uhci_hcd 0000:00:1d.2: FGR not stopped yet!
uhci_hcd 0000:00:1d.1: FGR not stopped yet!
uhci_hcd 0000:00:1d.1: FGR not stopped yet!


Steps to reproduce:

Booting and wait - sometimes it happens and sometimes not, i can't tell which cause this, but i can tell seometimes its there although i didn't change hardware or kernel version.

Some more infos.

The one and only usb device which is connected is:

Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Bus 001 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 002 Device 002: ID 05e3:1205 Genesys Logic, Inc. Afilias Optical Mouse H3003

Any hints or thought, can i safely ignore this messages, can i do something to prevent them oder fix them, whats wrong?

thx 

Torsten
Comment 1 Greg Kroah-Hartman 2007-11-28 09:23:57 UTC
On Wed, Nov 28, 2007 at 07:38:58AM -0800, bugme-daemon@bugzilla.kernel.org wrote:
> Any hints or thought, can i safely ignore this messages, can i do something to
> prevent them oder fix them, whats wrong?

Do the USB devices still work properly when this message occurs?

Comment 2 Torsten Krah 2007-11-29 02:16:13 UTC
Yes - but its only a usb mouse, maybe it does not work in the moment when this message occurs - i dont know how to test this, but it works when i want to use the mouse.
From my working perspective i would say it does work fine, because log is full with this messages but i am still using the mouse and it works.

Sometimes additionally to this message the hangcheck timer tells sometimes that the value pasts its margin, so it things the kernel looses too much time (if i understand this message correctly).
Don't know if these 2 messages are related to each other or not, maybe this info helps.
Comment 3 Alan 2008-09-23 07:36:54 UTC
Can I close this now ?
Comment 4 Torsten Krah 2008-09-23 08:01:44 UTC
I did not see this message again yet in .24, .25 or .26, so i'll would say the cause is gone, although i don't know why it was happening or what was causing this.
From my perspective yes, it can be closed since i am not facing this problem anymore (yet).
Comment 5 Alan 2008-09-23 09:22:49 UTC
Reopen it if you do...

Note You need to log in before you can comment on or make changes to this bug.