Bug 9447 - xfrm_state_lock: possible circular locking dependency detected
xfrm_state_lock: possible circular locking dependency detected
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Herbert Xu
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-24 03:24 UTC by Rafael J. Wysocki
Modified: 2007-12-01 13:36 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-11-24 03:24:37 UTC
Subject         : xfrm_state_lock: possible circular locking dependency detected
Submitter       : Ingo Molnar <mingo@elte.hu>
References      : http://lkml.org/lkml/2007/11/23/103
Handled-By      : Herbert Xu <herbert@gondor.apana.org.au>
Comment 1 Rafael J. Wysocki 2007-11-24 03:26:02 UTC
Caused by:

commit 050f009e16f908932070313c1745d09dc69fd62b
Author: Herbert Xu <herbert@gondor.apana.org.au>
Date:   Tue Oct 9 13:31:47 2007 -0700

    [IPSEC]: Lock state when copying non-atomic fields to user-space

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=050f009e16f908932070313c1745d09dc69fd62b
Comment 2 Rafael J. Wysocki 2007-11-29 08:03:17 UTC
Please provide the commit ID and subject when the fix is merged.

Thanks!
Comment 3 Ingo Molnar 2007-11-29 08:11:32 UTC
> Please provide the commit ID and subject when the fix is merged.

Author: Herbert Xu <herbert@gondor.apana.org.au>
Date:   Mon Nov 26 19:07:34 2007 +0800

    [IPSEC]: Temporarily remove locks around copying of non-atomic fields

    The change 050f009e16f908932070313c1745d09dc69fd62b

        [IPSEC]: Lock state when copying non-atomic fields to user-space

    caused a regression.

Comment 4 Herbert Xu 2007-11-29 16:07:45 UTC
And the commit ID is 8053fc3de720e1027d690f892ff7d7c1737fdd9d.

Note You need to log in before you can comment on or make changes to this bug.