Bug 9431 - ARM PXA Ethernet Gadget broken
ARM PXA Ethernet Gadget broken
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-11-22 01:14 UTC by Sergey Smirnov
Modified: 2008-09-26 07:16 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Sergey Smirnov 2007-11-22 01:14:26 UTC
Most recent kernel where this bug did not occur: 2.6.22
Distribution: Debian Armel
Hardware Environment: XScale PXA255 Zaurus C750
Software Environment: Debian Armel
Problem Description:

Normal messages on PDA side

On PC(usbnet) side (kernel 2.6.23):
[170563.539380] usb 3-2: new full speed USB device using uhci_hcd and address 23
[170563.659518] usb 3-2: device descriptor read/64, error -71
[170563.891412] usb 3-2: device descriptor read/64, error -71

The same configuration works with 2.6.22

With 2.6.23 kernel USB Gadget sometimes hangs:
NETDEV WATCHDOG: usb0: transmit timed out

Steps to reproduce:
Comment 1 Anonymous Emailer 2007-11-22 16:08:09 UTC
Reply-To: akpm@linux-foundation.org

On Thu, 22 Nov 2007 01:14:27 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=9431
> 
>            Summary: ARM PXA Ethernet  Gadget broken
>            Product: Drivers
>            Version: 2.5
>      KernelVersion: 2.6.24-rc3
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: USB
>         AssignedTo: greg@kroah.com
>         ReportedBy: svs1957@gmail.com
>                 CC: svs1957@gmail.com
> 
> 
> Most recent kernel where this bug did not occur: 2.6.22
> Distribution: Debian Armel
> Hardware Environment: XScale PXA255 Zaurus C750
> Software Environment: Debian Armel
> Problem Description:
> 
> Normal messages on PDA side
> 
> On PC(usbnet) side (kernel 2.6.23):
> [170563.539380] usb 3-2: new full speed USB device using uhci_hcd and address
> 23
> [170563.659518] usb 3-2: device descriptor read/64, error -71
> [170563.891412] usb 3-2: device descriptor read/64, error -71
> 
> The same configuration works with 2.6.22
> 
> With 2.6.23 kernel USB Gadget sometimes hangs:
> NETDEV WATCHDOG: usb0: transmit timed out
> 
> Steps to reproduce:
> 
> 
> -- 
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.

Comment 2 Anonymous Emailer 2007-11-22 19:50:13 UTC
Reply-To: david-b@pacbell.net

On Thursday 22 November 2007, Andrew Morton wrote:
> > [170563.539380] usb 3-2: new full speed USB device using uhci_hcd and address
> > 23
> > [170563.659518] usb 3-2: device descriptor read/64, error -71
> > [170563.891412] usb 3-2: device descriptor read/64, error -71

What evidence is there that the problem is the gadget
instead of the host?  That looks most like a host side
issue...

Comment 3 Sergey Smirnov 2007-11-25 23:28:05 UTC
The same PC  works correct with the same PDA  kernel 2.6.22.
If I flash 2.6.24-rc3 on PDA got error on host side.
2.6.23 on PDA hangs usbnet some times.
Comment 4 Alan 2008-09-26 07:16:18 UTC
Closing out stale bugs

Note You need to log in before you can comment on or make changes to this bug.