Bug 94231 - kernel 3.14.? - i915 - screen LVDS1 turns black early at boot
Summary: kernel 3.14.? - i915 - screen LVDS1 turns black early at boot
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-04 10:15 UTC by charles17
Modified: 2015-03-04 11:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.14
Tree: Mainline
Regression: No


Attachments
lspci -vvv -s 00_02.0 (1.02 KB, text/plain)
2015-03-04 10:15 UTC, charles17
Details
dmesg without VGA plugged (86.73 KB, text/plain)
2015-03-04 10:19 UTC, charles17
Details
reverse git bisect (3.43 KB, text/plain)
2015-03-04 10:20 UTC, charles17
Details
Kernel configuration (77.37 KB, text/plain)
2015-03-04 10:22 UTC, charles17
Details

Description charles17 2015-03-04 10:15:28 UTC
Created attachment 168861 [details]
lspci -vvv -s 00_02.0

Screen LVDS1 turns black early at boot with kernel 3.14

The computer is a laptop and  has been used with an external screen plugged (VGA) for several months.

After unplugging the VGA from the laptop I was getting a black screen at boot. Grub2 screen is ok but in the very early stage at boot just after showing the first few kernel lines the built-in screen turns black.  

CTRL-ALT-F1 + CTRL-ALT--F7 does not help.  Built-in screen stays black until a VGA is plugged.  

With the VGA plugged (even when it's power is off) the boot is normal with all the boot messages visible on the built-in screen. This behaviour is reproducible:

  VGA plugged: Screen is ok
  VGA unplugged: Screen tuns black at boot

The problem seems to be fixed later in kernel v3.15
Comment 1 charles17 2015-03-04 10:19:02 UTC
Created attachment 168871 [details]
dmesg without VGA plugged
Comment 2 charles17 2015-03-04 10:20:41 UTC
Created attachment 168881 [details]
reverse git bisect

I did a reverse git bisect leading to 484b41dd70a9fbea894632d8926bbb93f05021c7 

$ git branch --contains 484b41dd70a9fbea894632d8926bbb93f05021c7
master

$ git tag --contains 484b41dd70a9fbea894632d8926bbb93f05021c7
v3.15
v3.15-rc1
v3.15-rc2
v3.15-rc3
v3.15-rc4
... until ...
v3.19-rc6
v3.19-rc7

Checked out v.3.15 for testing and was ok.
Comment 3 charles17 2015-03-04 10:22:20 UTC
Created attachment 168891 [details]
Kernel configuration
Comment 4 Jani Nikula 2015-03-04 11:13:39 UTC
Thanks for the reverse bisect, however the commit is too big to be backported to stable kernels. Please upgrade to v3.15 or later. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.