Bug 9377 - 2.6.24-rc2 XFS nfsd hang
2.6.24-rc2 XFS nfsd hang
Status: RESOLVED DUPLICATE of bug 9400
Product: File System
Classification: Unclassified
Component: XFS
All Linux
: P1 normal
Assigned To: XFS Guru
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-14 04:20 UTC by Rafael J. Wysocki
Modified: 2007-11-18 06:49 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-11-14 04:20:28 UTC
Subject         : 2.6.24-rc2 XFS nfsd hang
Submitter       : Chris Wedgwood <cw@f00f.org>
References      : http://lkml.org/lkml/2007/11/14/42
Comment 1 Rafael J. Wysocki 2007-11-14 04:22:42 UTC
Caused by:

commit 051e7cd44ab8f0f7c2958371485b4a1ff64a8d1b
Author: Christoph Hellwig <hch@infradead.org>
Date:   Tue Aug 28 13:58:24 2007 +1000

    [XFS] use filldir internally

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=051e7cd44ab8f0f7c2958371485b4a1ff64a8d1b
Comment 2 Chris Wedgwood 2007-11-15 16:36:30 UTC
This is the result of filldir calling back into the file system for v3 clients using readdirplus (which is the default these days for Linux):

Workarounds for now:

  mount -o vers=2 ...

or

  mount -o vers=3,nordirplus ...
Comment 3 Rafael J. Wysocki 2007-11-18 06:49:33 UTC

*** This bug has been marked as a duplicate of bug 9400 ***

Note You need to log in before you can comment on or make changes to this bug.