Bug 9360 - Major mke2fs slowdown (reproducable, bisected)
Major mke2fs slowdown (reproducable, bisected)
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-12 12:46 UTC by Rafael J. Wysocki
Modified: 2007-11-13 03:19 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-11-12 12:46:55 UTC
Subject         : Major mke2fs slowdown (reproducable, bisected)
Submitter       : Alexey Dobriyan <adobriyan@gmail.com>
References      : http://lkml.org/lkml/2007/11/12/154
Handled-By      : Linus Torvalds <torvalds@linux-foundation.org>
Comment 1 Rafael J. Wysocki 2007-11-12 12:49:35 UTC
Caused by:

commit 5adc5be7cd1bcef6bb64f5255d2a33f20a3cf5be
Author: Mel Gorman <mel@csn.ul.ie>
Date:   Tue Oct 16 01:25:54 2007 -0700

    Bias the placement of kernel pages at lower PFNs

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=5adc5be7cd1bcef6bb64f5255d2a33f20a3cf5be
Comment 2 Adrian Bunk 2007-11-13 03:19:03 UTC
Commit was reverted in Linus' tree.

Note You need to log in before you can comment on or make changes to this bug.