Bug 9358 - boot hang unless acpi=off ide=nodma noapic - i965
Summary: boot hang unless acpi=off ide=nodma noapic - i965
Status: REJECTED INSUFFICIENT_DATA
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: ykzhao
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-12 11:09 UTC by Jonathan Kempa
Modified: 2008-07-03 20:35 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.23.1
Tree: Mainline
Regression: ---


Attachments
dmesg (68.52 KB, text/plain)
2007-11-12 11:15 UTC, Jonathan Kempa
Details
dmidecode (9.91 KB, text/plain)
2007-11-12 11:15 UTC, Jonathan Kempa
Details
lspci (20.80 KB, text/plain)
2007-11-12 11:16 UTC, Jonathan Kempa
Details
pci=nommconf (sorry for bad quality) (345.52 KB, image/jpeg)
2007-11-15 12:48 UTC, Jonathan Kempa
Details
pci=nommconf + acpi_osi=Linux (350.33 KB, image/jpeg)
2007-11-15 12:55 UTC, Jonathan Kempa
Details
pci=nommconf + pci=nodma (371.99 KB, image/jpeg)
2007-11-15 12:58 UTC, Jonathan Kempa
Details
without any boot options (339.56 KB, image/jpeg)
2007-11-15 13:15 UTC, Jonathan Kempa
Details
acpidump (108.95 KB, application/octet-stream)
2007-11-18 10:28 UTC, Martin Jürgens
Details
lspci -vvxxx output (39.00 KB, text/plain)
2007-11-19 11:52 UTC, Martin Jürgens
Details
dmesg of acpi=ht irqpoll ide=nodma (24.07 KB, text/plain)
2007-11-21 12:47 UTC, Jonathan Kempa
Details
kernel .config (76.24 KB, text/plain)
2007-11-21 14:13 UTC, Martin Jürgens
Details
dmesg with 2.6.24 rcx (29.26 KB, text/plain)
2008-01-18 10:39 UTC, Jonathan Kempa
Details
try the custom DSDT (209.50 KB, text/x-dsl)
2008-03-05 17:54 UTC, ykzhao
Details
use the attached tool to dump BIOS PRT/MPS table (79.30 KB, application/x-gzip)
2008-03-05 22:55 UTC, ykzhao
Details
result of pirq (6.39 KB, application/octet-stream)
2008-03-07 09:23 UTC, Jonathan Kempa
Details

Description Jonathan Kempa 2007-11-12 11:09:07 UTC
Most recent kernel where this bug did not occur: none
Distribution: Fedora 8
Hardware Environment: One Notebook C6500 Series. lshal says VESTEL ARES
Software Environment: Fedora 8
Problem Description:

I can not boot the system without the boot parameters 

acpi=off ide=nodma noapic

this also applies for other Linux distributions.

cat /proc/cpuinfo only shows CPU0, although I have a Intel Core 2 Duo. Windows shows both cores. Problem also appears without a tainted kernel.

I will attach three screenshots.

The first is without any special boot options, the second one is without acpi=off and with irqpoll and the third one is with acpi_osi=Linux
Comment 1 Jonathan Kempa 2007-11-12 11:15:17 UTC
Created attachment 13515 [details]
dmesg
Comment 2 Jonathan Kempa 2007-11-12 11:15:40 UTC
Created attachment 13516 [details]
dmidecode
Comment 3 Jonathan Kempa 2007-11-12 11:16:01 UTC
Created attachment 13517 [details]
lspci
Comment 4 Jonathan Kempa 2007-11-12 11:32:28 UTC
I currently have some problems getting the pictures from my camera to my pc (not caused by Linux ;)). Will post them soon.
Comment 5 ykzhao 2007-11-12 17:04:26 UTC
Will you please try it with boot option of pci=nommconf ?
If the system can be booted successfully, please upload the info of acpidump.
Thanks.
Comment 6 ykzhao 2007-11-13 19:10:58 UTC
It would be great that the acpidump info is attached.
Thanks.
Comment 7 Martin Jürgens 2007-11-13 23:13:43 UTC
I am trying to fix the laptop with Jonathan, which means that I sometimes visit him and we do debug procedures ;) Sadly, we had not have time yesterday but we hope that we can try today. Thanks for your help!
Comment 8 Jonathan Kempa 2007-11-15 12:32:20 UTC
Sorry for the delay.

Booting using pci=nommconf does not work. I will attach the regarding photos.
Comment 9 Jonathan Kempa 2007-11-15 12:48:59 UTC
Created attachment 13568 [details]
pci=nommconf (sorry for bad quality)
Comment 10 Jonathan Kempa 2007-11-15 12:55:40 UTC
Created attachment 13569 [details]
pci=nommconf + acpi_osi=Linux
Comment 11 Jonathan Kempa 2007-11-15 12:58:15 UTC
Created attachment 13570 [details]
pci=nommconf  + pci=nodma
Comment 12 Jonathan Kempa 2007-11-15 13:15:56 UTC
Created attachment 13571 [details]
without any boot options
Comment 13 Martin Jürgens 2007-11-15 13:35:33 UTC
AFAIK, acpidump would only have worked with acpi=on, wouldn't it?
Comment 14 ykzhao 2007-11-16 00:19:34 UTC
Thanks.
Anyway, Please boot the system with acpi=off noapic and then attach the info of acpidump.
Comment 15 Martin Jürgens 2007-11-18 10:28:51 UTC
Created attachment 13601 [details]
acpidump

Acpidump attached.
Comment 16 ykzhao 2007-11-18 18:07:57 UTC
Hi, Jonatha && Martin
the boot option should be "pci=nommconf" (not "pci=mmconf"). Will you please try it again?
Thanks.

It will be greate if you can attach the dmesg using serial-port and pci info (lspci -vvxxx).
Comment 17 Martin Jürgens 2007-11-19 02:37:37 UTC
How can one create a dmesg using a serial port? ( I even do not know if the laptop has one )
Comment 18 Martin Jürgens 2007-11-19 11:46:54 UTC
We did use pci=nommconf, but we have described the attachments wrongly. Though, we retried using pci=nommconf and it still did not work.
Comment 19 Martin Jürgens 2007-11-19 11:52:26 UTC
Created attachment 13626 [details]
lspci -vvxxx output
Comment 20 ykzhao 2007-11-19 20:38:22 UTC
Thanks for the info.
From the comment #1 there is no MPS table and it means that APIC table doesn't exist in acpi=off . So /proc/cpuinfo only shows one cpu.

Will you please enable the debug of PCI and ACPI in kernel configuration and boot the system with the option of acpi=noirq ?
If the system can be booted, please attach the dmesg.
Thanks.
Comment 21 Len Brown 2007-11-21 00:08:55 UTC
Lets go fishing:-)

Please report if any of the following cmdline params make it boot:

nohz=off
nolapic
maxcpus=1
hpet=disable
acpi=ht
pci=noacpi

if any boot, please attach the resulting dmesg -s64000 output.

> acpi=off ide=nodma noapic
Also, are all three of these necessary, or does the system boot
when using just acpi=off?
Comment 22 Martin Jürgens 2007-11-21 03:39:57 UTC
> Also, are all three of these necessary, or does the system boot when using
> just acpi=off?

All three are necessary.
Comment 23 Len Brown 2007-11-21 08:59:28 UTC
>> are all three of these necessary?
> All three are necessary.

that is odd, on laptops, "noapic" is usually redundant with "acpi=off"
because the IOAPIC support is generally in ACPI and not available in MPS.

ie. I would expect the following to give the same results:
acpi=off ide=nodma noapic
acpi=off ide_nodma
Comment 24 Martin Jürgens 2007-11-21 10:15:22 UTC
Let's see, maybe we have mixed up something. We will meet this evening and try the boot options that you and Yakui have written down.
Comment 25 Jonathan Kempa 2007-11-21 12:47:46 UTC
Created attachment 13677 [details]
dmesg of acpi=ht irqpoll ide=nodma

We had some success using acpi=ht irqpoll ide=nodma. The system booted fine after some delays.
Comment 26 Jonathan Kempa 2007-11-21 12:58:51 UTC
When using the "acpi=ht irqpoll ide=nodma", then the system freezes when using the touchpad. USB devices (e.g. mouse) do not work.
Comment 27 Jonathan Kempa 2007-11-21 12:59:20 UTC
When you need pictures of the other boot options, then please pleave a note.
Comment 28 Len Brown 2007-11-21 13:52:50 UTC
> Intel MultiProcessor Specification v1.4
>    Virtual Wire compatibility mode.

okay, that explains why "noapic" makes a difference even when "acpi=off".

however, if 
acpi=ht irqpoll ide=nodma

booted, then so should acpi=off irqpoll ide=nodma
except you'll have just 1 processor instead of two.

if you boot with the additional parameter "debug" on the cmdline,
do you see anything more on the screen upon the boot hang?

please attach the failing .config
Comment 29 Martin Jürgens 2007-11-21 14:13:09 UTC
Created attachment 13680 [details]
kernel .config

it's just the plain fedora 8 debug kernel, but i have attached the .config, though.

the "hangs" happened after the kernel was booted, so we already saw "welcome to fedora". Then we had some delay and pressed ENTER multiple times. Something failed, then the system went ahead. 

We'll try with debug one of the next days and we will also take some nice photos :) Well numbered, like the first three pictures before (but I doubt that we have some paper from the M-company left) ;)
Comment 30 Len Brown 2007-11-23 21:07:51 UTC
> we already saw "welcome to fedora"

okay, so we got to init -- but the modules load after that point.

does it get that far even w/o any kernel boot parameters?

If you boot the fedora CDROM into "Memory test", does it survive overnight?
Comment 31 Martin Jürgens 2007-11-24 01:40:44 UTC
> does it get that far even w/o any kernel boot parameters?
No, it does not. See attachment 13571 [details] for a screenshot w/o any bootoptions.

We will try "Memory test" and "debug" as soon as we can, but the laptop also goes to RMA soon, which is a little problematic so it can take some time.

Another finding is the following: 

We tried out Backtrack (http://www.remote-exploit.org/backtrack.html) and it worked w/o any boot parameters. It also did not freeze or have a delay at the startup and it showed how long the battery would last. BUT: It also only showed up one CPU.

The normal "main stream" distributions all fail to boot, which is weird. And afaik, the Fedora kernel does not contain any third party patches.
Comment 32 Jonathan Kempa 2007-12-07 12:49:15 UTC
we retried acpi=ht irqpoll ide=nodma with kernel 2.6.23.8 and it did not result in anything. it says something like:

I/O error dev sda
READ capacy failed
hostbyte=DID_BAD_TARGET
select() to /dev/rtc to wait for clock tick timed out

if it helps you to have SSH access, please tell us
Comment 33 Len Brown 2008-01-06 21:49:02 UTC
re: backtrack works
i don't know what kernel they use, but it might have "acpi=off"
built in, say via CONFIG_ACPI=n.  Can you get the dmesg
off that configuration?

Have you tried anyting older than FC8, say FC7 or earlier?
It is possible that some of the recent timer changes are involved.

re: comment #32
so this worked before (comment #25) but now it doesn't work?
What changed?  Where were the delays reported in comment #25?
(you can enable printk timestamps if you build a kernel
 with CONFIG_PRINTK_TIME=y)
Comment 34 Jonathan Kempa 2008-01-18 10:38:18 UTC
hi again, sorry for the delays, you should expect some more in answering. also note that we do not have the time to rebuild kernels often, but leave a note when you think that it is important in order to fix the bug.

we'd like to wait for 2.6.24 to hit us via updates first, as there seem to be lots of acpi fixed. we just installed 2.6.24-rc8 to just quick and dirty try if there are any improvements, but booting without anything or noapic irqpoll did not work, but it works using acpi=off ide=nodma noapic irqpoll as always. We'll attach dmesg output, but currently can not test anything with that new kernel. We'd like to wait for the official 2.6.24 release. Maybe you can get anything out of this dmesg?
Comment 35 Jonathan Kempa 2008-01-18 10:39:22 UTC
Created attachment 14499 [details]
dmesg with 2.6.24 rcx
Comment 36 ykzhao 2008-03-05 17:54:05 UTC
Created attachment 15158 [details]
try the custom DSDT

Will you please try the custom DSDT and see whether the system still fails in acpi mode?
How to use custom DSDT can be found in the following website:
http://www.lesswatts.org/projects/acpi/faq.php.
Thanks.
Comment 37 ykzhao 2008-03-05 22:55:33 UTC
Created attachment 15159 [details]
use the attached tool to dump BIOS PRT/MPS table

Will you please use the attached tool to dump BIOS PRT/MPS table?
Comment 38 Jonathan Kempa 2008-03-07 09:23:48 UTC
Created attachment 15173 [details]
result of pirq
Comment 39 Jonathan Kempa 2008-03-07 09:43:27 UTC
So, I tried it with 2.6.25-0.90.rc3.git5. So far, I noticed that the kernel detects 2 CPUs, which is good:

Brought up 2 CPUs
PCI: Usinconfiguration type 1
Setting up standrd PCI ressources

Then it hangs

When I boot with acpi=off it hangs with the following / or it boots very slow ( I stopped after two minutes ):

Unlink after NO-Irq
Comment 40 ykzhao 2008-03-10 00:14:10 UTC
Will you please add the boot option of "pci=nommconf" and see whether it still hangs?
Comment 41 ykzhao 2008-03-10 00:33:08 UTC
It will be great if you can boot the system with the option of "pci=nommconf pci=noacpi" and attach the output of dmesg.

Thanks.
Comment 42 Jonathan Kempa 2008-03-10 12:27:39 UTC
It says the following:

Simple boot flag value 05 read from cmos ram was invalid
Simple boot flag at 0x44 set to 0x1
Comment 43 Martin Jürgens 2008-03-10 14:44:53 UTC
Correction:

It says the following :

ACPI: DSDT override uses original SSDTs unless .... xxxxx Namespace lookup failure, AE_NOT_FOUND
lockdep fixing up alternatives
CPU 1 irqstacks hard xxxxxxxxxxxx

Second startup

Trying to set up timer as Virtual Wire IRQ APIC error on CPU0: 80 works
Comment 44 ykzhao 2008-05-26 19:03:13 UTC
Hi, Jonathan
    Will you please try the latest kernel and see whether it still hangs?
    Will you please try the boot option of "pci=noacpi"?
    If the system still hangs, please capture the screen and attach it.
    
    In the comment #43 there exists the following message:
    >xxxxx Namespace lookup failure, AE_NOT_FOUND
    Will you please give the real name of "xxxxx"?
    Thanks.
Comment 45 Martin Jürgens 2008-06-08 12:37:14 UTC
>     Will you please try the latest kernel and see whether it still hangs?

yum, which means the kernel that ships with the fedora 9 installer.

>     Will you please try the boot option of "pci=noacpi"?

attached, as the one without any options

>    Will you please give the real name of "xxxxx"?

sorry, i do not have that kernel anymore :(
Comment 46 Martin Jürgens 2008-06-08 12:58:59 UTC
camera not working, i ll provide it later.. sorry
Comment 47 ykzhao 2008-07-03 20:35:24 UTC
As there is no response from bug reportor for more than one month, the bug will be rejected. If the problem still exists, please reopen it.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.