Bug 9357 - dvb driver reboot system
Summary: dvb driver reboot system
Status: CLOSED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: dvb-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-12 10:02 UTC by Dieter Ferdinand
Modified: 2012-05-17 15:05 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.21.5
Tree: Mainline
Regression: No


Attachments

Description Dieter Ferdinand 2007-11-12 10:02:36 UTC
Most recent kernel where this bug did not occur:
Distribution: none
Hardware Environment: asus p2bs with p3-450 256 mb sdram, 3 x technotrend dvb's
Software Environment:
Problem Description: system reboot without shutdown

Steps to reproduce:
most time, i start the system, it goes up and load vdr
after loading vdr, the system reboot
after some reboot, somtime with hardware-reset, it works.

i try to get the reason for this reboot, but without success.

i find only one situation in which the system reboot direct, after i change the tv-channel, the system reboot. i test it 2 ode 3 times and every time, the system reboot.
at this time, i have this effect only, if i change the channel to pro 7.

the system reboot one time, a recording from pro 7 is active.

i don't know, why the system reboot and will try to make some tests to get more information, but i can't say, how much time i need for this.

for information:
i don't use this system for some weeks and i have no problems with it in the past, but after reaktivation, i have this problem.
i try to solve it and update kernel vom 2.4.32 to 2.6.21.5, but this don't help.
some other systems works fine (with one ore 2 dvb's-cards) and kernel 2.4.32.

and now i have no more ideas what i can do, to solve the problem.

i think, it is no hardware-problem, but i will check all possibilities i find in the next time.

goodby
Comment 1 Natalie Protasevich 2007-11-12 11:40:10 UTC
Dieter,
Can you please confirm if this is still a problem with 2.6.23+
Thanks.
Comment 2 Mauro Carvalho Chehab 2007-11-12 17:27:32 UTC
Since your system used to work, i suspect it is not software related. There were several changes from 2.4 to 2.6 at DVB subsystem.

This kind of trouble may be related to a hardware problem, like high temperatures at memory, chipset or CPU. I saw similar issues in the past, related to some troubles at the power supply, especially on machines with lots of daughter boards.

I recommend you to do a review at the hardware, check the cooling system, check the values on your power supply and run an exhaustive test your ram (for example, using memtest86).

If all ok, you may try to reinstall Linux on that box. Be sure to use a Linux distribution that is compatible with Kernel 2.6.

If the problem still persists, we will need some additional info, like the output of "dmesg" command, with the latest 2.6 kernel.
Comment 3 Dieter Ferdinand 2007-11-13 01:30:19 UTC
hello,
after the first problems with this system, i make some memory test (memtest86) and let run it with high cpu-load (test gzip-archive), without problems.

it can't be a problem with high temperature because the system reboot to fast after power on, so the components can't have a high temperature.

i don't think, that the problem comes from power suplay, but i will check it to be sure.

i will test some other kernels in the next time to see, if there are some difference.

goodby
Comment 4 Beat Wolf 2007-11-14 12:11:59 UTC
There are two bugs in ubuntu that could be the same. Both are system freezes, but the rest sounds the same. I'm no kernel expert, but a system freeze and a unexpected reboot aren't that different.

https://bugs.launchpad.net/ubuntu/+source/mplayer/+bug/137903
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/81110
Comment 5 Dieter Ferdinand 2007-11-15 15:23:34 UTC
hello,
i test it with some other kernel:
2.6.23-rc9
2.6.23
2.6.24-rc2

first test, it looks good, but then the same problem, after start of vdr, the system reboot with all kernels.

it is crazy, some times, i power on the system and it works, other time, it won't work. every time, i start vdr, the system reboot.

at the moment, i have connected the system to an other powersuply to make sure, that the problem comes not from the power suply.

i will see, what happens in the next days.

goodby
Comment 6 Dieter Ferdinand 2007-11-21 11:17:32 UTC
hello,
i have updated an other system to kernel 2.6.22.x, to see how it works.

i have not power off the system since some days an today, the second dvbs-card hangs. i can't change to rtl2 to record the movie.

after reboot, it works again. i see the same problem, with my last installation with kernel 2.4.32 where i reload only the drives with a script.

i will test the driver reload after the update of my script and the next hang of on card.

i think, here is alredy a bug in the driver which make this problem.

goodby

Note You need to log in before you can comment on or make changes to this bug.