Bug 9356 - xipImage is built so that uBoot cant run it
Summary: xipImage is built so that uBoot cant run it
Status: REJECTED INVALID
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: ARM (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Russell King
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-12 06:05 UTC by Alexandre Rusev
Modified: 2007-11-13 11:00 UTC (History)
0 users

See Also:
Kernel Version: 2.6.21
Tree: Mainline
Regression: ---


Attachments

Description Alexandre Rusev 2007-11-12 06:05:46 UTC
If building XIP image for using with uBoot (example OMAP2430 board)
then uBoot can't execute is, while uImage is running normally from RAM.
The cause of it is that uBoot needs 64 byte header to be added by mkimage
(along with correction of CONFIG_XIP_PHYS_ADDR for the same length).

In case of xipImage this header is added normally, while xipImage misses it
because xipImage is not aware of uBoot specifics.

Likely additional target xipuImage  is needed, or may be additional config
such as CONFIG_UBOOT_ADD_HEADER.
Comment 1 Alexandre Rusev 2007-11-12 06:11:18 UTC
Archive thread on this issue:
http://lists.arm.linux.org.uk/pipermail/linux-arm-kernel/2004-December/025674.html
Comment 2 Russell King 2007-11-13 11:00:34 UTC
It's a shame that uboot people don't come to their senses and teach everyone
how to use their 'mkimage' command to put their special header for their boot
loader into the image.

In any case, this is *not* a bug.  If anything, it's a missing feature, and its
something that I question.  It needs discussing on the ARM mailing list and not
in bugzilla.

Ergo, rejecting "missing feature".

Note You need to log in before you can comment on or make changes to this bug.