Bug 9350 - 2.6.24-rc2: Network commit causes SLUB performance regression with tbench
Summary: 2.6.24-rc2: Network commit causes SLUB performance regression with tbench
Status: CLOSED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Herbert Xu
URL:
Keywords:
Depends on:
Blocks: 9243
  Show dependency tree
 
Reported: 2007-11-11 11:12 UTC by Rafael J. Wysocki
Modified: 2007-11-16 15:22 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-11-11 11:12:19 UTC
Subject         : 2.6.24-rc2: Network commit causes SLUB performance regression
with tbench
Submitter       : Christoph Lameter <clameter@sgi.com>
References      : http://lkml.org/lkml/2007/11/9/246
Handled-By      : Nick Piggin <nickpiggin@yahoo.com.au>
Comment 1 Rafael J. Wysocki 2007-11-11 11:14:59 UTC
Caused by:

commit deea84b0ae3d26b41502ae0a39fe7fe134e703d0
Author: Herbert Xu <herbert@gondor.apana.org.au>
Date:   Sun Oct 21 16:27:46 2007 -0700

    [NET]: Fix SKB_WITH_OVERHEAD calculation
Comment 2 Herbert Xu 2007-11-14 22:07:42 UTC
Fixed by:

commit fb93134dfc2a6e6fbedc7c270a31da03fce88db9
Author: Herbert Xu <herbert@gondor.apana.org.au>
Date:   Wed Nov 14 15:45:21 2007 -0800

    [TCP]: Fix size calculation in sk_stream_alloc_pskb

Note You need to log in before you can comment on or make changes to this bug.