Bug 93471 - iwlmvm: 7260 disconnects
Summary: iwlmvm: 7260 disconnects
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-19 03:02 UTC by Kai Hendry
Modified: 2015-02-20 15:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.18.6
Tree: Mainline
Regression: No


Attachments

Description Kai Hendry 2015-02-19 03:02:21 UTC
Seems related to https://bugzilla.kernel.org/show_bug.cgi?id=48921

modinfo: http://ix.io/gpT
lspci: http://ix.io/gpU
journalctl: http://ix.io/gpV

My X1 Carbon Gen 3 is a new machine and it's worked fine on a various Wireless APs, but at my mother in laws, her TP-LINK is throwing me off every so often.

Firmware Version:	
3.13.13 Build 120605 Rel.38634n
Hardware Version:	
WR1043ND v1 00000000

Other wireless devices are fine.


Many thanks,
Comment 1 Emmanuel Grumbach 2015-02-19 17:01:02 UTC
Please try the latest version of the firmware:
https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/plain/iwlwifi-7260-10.ucode
Comment 2 Kai Hendry 2015-02-20 03:19:46 UTC
I installed it. http://ix.io/grr How do make sure it's running? What do I grep for and where?

Here is another log when I'm unable to join the TP-LINK at all with "No association and the time event is over already..."
http://ix.io/gru

Btw, I am pretty sure this is the AP's fault, since when I reboot it, things are much better. However since other devices are stable on this AP, this is still very much an issue for Intel. ;)
Comment 3 Emmanuel Grumbach 2015-02-20 05:06:18 UTC
oh you are running 3.18 so that won't work.
You must have 3.19 for -12.ucode.

But now that you are saying that rebooting the AP helps, yeah - it must be the firmware dropping the beacon of the AP because it is botched.

Not much I can do for that.
Please try to check for a better / newer firmware.
You can try openWRT maybe.
Comment 4 Kai Hendry 2015-02-20 15:21:30 UTC
Er, how come every other device on this AP is OK except my new Intel hardware?

So I need to tell folks Intel software is not as robust as anything else? :/

http://en.wikipedia.org/wiki/Robustness_principle

Note You need to log in before you can comment on or make changes to this bug.