Bug 9339 - boot pause at "ACPI: PCI Root Bridge [PCI0] (0000:00)" unless "pci=nommconf" - Samsung R20
Summary: boot pause at "ACPI: PCI Root Bridge [PCI0] (0000:00)" unless "pci=nommconf" ...
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-09 09:39 UTC by Sahid Ferdjaoui
Modified: 2008-04-03 03:19 UTC (History)
12 users (show)

See Also:
Kernel Version: 2.6.22-2-686
Tree: Mainline
Regression: Yes


Attachments
dmesg with Linux 2.6.24-rc2-686 (19.10 KB, text/message)
2007-11-10 08:40 UTC, Sahid Ferdjaoui
Details
dmesg - with HPET enabled (38.40 KB, application/octet-stream)
2007-12-10 02:56 UTC, Ryan Young
Details
dmesg - with HPET disable (25.02 KB, application/octet-stream)
2007-12-10 02:58 UTC, Ryan Young
Details
dmesg - with acpi=off (20.95 KB, application/octet-stream)
2007-12-10 02:58 UTC, Ryan Young
Details
dmesg for 2.6.24 hang (35.15 KB, application/octet-stream)
2007-12-27 12:27 UTC, Jaen Saul
Details
dmesg for 2.6.24 pci=nommconf (34.97 KB, application/octet-stream)
2007-12-27 12:31 UTC, Jaen Saul
Details
lspci output (6.35 KB, text/plain)
2007-12-27 14:09 UTC, Jaen Saul
Details
try the debug patch (2.93 KB, patch)
2008-01-04 01:50 UTC, ykzhao
Details | Diff
acpidump with pci_debug patch (133.54 KB, text/plain)
2008-03-31 16:21 UTC, Manuel Schneider
Details
dmesg with pci_debug patch (28.96 KB, text/plain)
2008-03-31 16:21 UTC, Manuel Schneider
Details
lspci with pci_debug patch (15.40 KB, text/plain)
2008-03-31 16:21 UTC, Manuel Schneider
Details

Description Sahid Ferdjaoui 2007-11-09 09:39:46 UTC
Most recent kernel where this bug did not occur:
Distribution: Debian lenny
Hardware Environment: ATI on laptop samsung r20 http://www.samsungpc.com/gb/support/r20/specs/r20spec.pdf
Software Environment:
Problem Description: ACPI: PCI Root Bridge [PCI0] (0000:00)

Steps to reproduce: Boot time


dmesg :
Linux version 2.6.22-2-686 (Debian 2.6.22-4) (waldi@debian.org) (gcc version 4.1.3 20070812 (prerelease) (Debian 4.1.2-15)) #1 SMP Fri Aug 31 00:24:01 UTC 2007
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009dc00 (usable)
 BIOS-e820: 000000000009dc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000ce000 - 00000000000d0000 (reserved)
 BIOS-e820: 00000000000dc000 - 00000000000e0000 (reserved)
 BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000037e90000 (usable)
 BIOS-e820: 0000000037e90000 - 0000000037e9d000 (ACPI data)
 BIOS-e820: 0000000037e9d000 - 0000000037e9e000 (ACPI NVS)
 BIOS-e820: 0000000037e9e000 - 0000000038000000 (reserved)
 BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
894MB LOWMEM available.
found SMP MP-table at 000f7d50
Entering add_active_range(0, 0, 229008) 0 entries of 256 used
Zone PFN ranges:
  DMA             0 ->     4096
  Normal       4096 ->   229008
  HighMem    229008 ->   229008
early_node_map[1] active PFN ranges
    0:        0 ->   229008
On node 0 totalpages: 229008
  DMA zone: 32 pages used for memmap
  DMA zone: 0 pages reserved
  DMA zone: 4064 pages, LIFO batch:0
  Normal zone: 1757 pages used for memmap
  Normal zone: 223155 pages, LIFO batch:31
  HighMem zone: 0 pages used for memmap
DMI present.
ACPI: RSDP 000F7D20, 0014 (r0 PTLTD )
ACPI: RSDT 37E94649, 0044 (r1 SECCSD LH43STAR  6040000  LTP        0)
ACPI: FACP 37E9CD5C, 0074 (r1 SEC    HAINANII  6040000 SEC     F4240)
ACPI: DSDT 37E96390, 69CC (r1    ATI    SB600  6040000 INTL 20050228)
ACPI: FACS 37E9DFC0, 0040
ACPI: APIC 37E9CDD0, 0046 (r1 PTLTD  	 APIC    6040000  LTP        0)
ACPI: MCFG 37E9CE16, 003C (r1 PTLTD    MCFG    6040000  LTP        0)
ACPI: HPET 37E9CE52, 0038 (r1 PTLTD  HPETTBL   6040000  LTP        1)
ACPI: SLIC 37E9CE8A, 0176 (r1 SECCSD LH43STAR  6040000  LTP        0)
ACPI: SSDT 37E95CF1, 069F (r1  PmRef  Cpu0Cst     3001 INTL 20050228)
ACPI: SSDT 37E95A92, 025F (r1  PmRef  Cpu0Tst     3000 INTL 20050228)
ACPI: SSDT 37E9468D, 1405 (r1  PmRef    CpuPm     3000 INTL 20050228)
ATI board detected. Disabling timer routing over 8254.
ACPI: PM-Timer IO Port: 0x8008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 6:15 APIC version 20
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 1, version 33, address 0xfec00000, GSI 0-23
ACPI: IRQ9 used by override.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
ACPI: HPET id: 0x43538310 base: 0xfed00000
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 40000000 (gap: 38000000:a8000000)
Built 1 zonelists.  Total pages: 227219
Kernel command line: BOOT_IMAGE=(hd0,1)/boot/vmlinuz-2.6.22-2-686 root=/dev/sda1 ro
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 16384 bytes)
Detected 1666.803 MHz processor.
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 898688k/916032k available (1688k kernel code, 16668k reserved, 653k data, 244k init, 0k highmem)
virtual kernel memory layout:
    fixmap  : 0xfff4e000 - 0xfffff000   ( 708 kB)
    pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
    vmalloc : 0xf8800000 - 0xff7fe000   ( 111 MB)
    lowmem  : 0xc0000000 - 0xf7e90000   ( 894 MB)
      .init : 0xc034f000 - 0xc038c000   ( 244 kB)
      .data : 0xc02a62bf - 0xc03497e4   ( 653 kB)
      .text : 0xc0100000 - 0xc02a62bf   (1688 kB)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0, 0
hpet0: 4 32-bit timers, 14318180 Hz
Calibrating delay using timer specific routine.. 3336.97 BogoMIPS (lpj=6673945)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: afebfbff 20100000 00000000 00000000 0000e3bd 00000000 00000001
monitor/mwait feature present.
using mwait in idle threads.
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 2048K
CPU: After all inits, caps: afebfbff 20100000 00000000 00003940 0000e3bd 00000000 00000001
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 11k freed
ACPI: Core revision 20070126
CPU0: Intel(R) Core(TM)2 CPU         T5500  @ 1.66GHz stepping 02
Total of 1 processors activated (3336.97 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=0 apic2=-1 pin2=-1
..MP-BIOS bug: 8254 timer not connected to IO-APIC
...trying to set up timer (IRQ0) through the 8259A ...  failed.
...trying to set up timer as Virtual Wire IRQ... works.
Brought up 1 CPUs
Booting paravirtualized kernel on bare hardware
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: Using MMCONFIG
Setting up standard PCI resources
ACPI: System BIOS is requesting _OSI(Linux)
ACPI: Please test with "acpi_osi=!Linux"
Please send dmidecode to linux-acpi@vger.kernel.org
ACPI: Interpreter enabled
ACPI: (supports S0 S3 S4 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Device 0000:02:00.0 not responding
PCI: Transparent bridge - 0000:00:14.4
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PB5_._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PB6_._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P2P_._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 11) *0, disabled.
ACPI: PCI Interrupt Link [LNKB] (IRQs 10) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 5) *0, disabled.
ACPI: PCI Interrupt Link [LNKD] (IRQs 5) *0, disabled.
ACPI: PCI Interrupt Link [LNKE] (IRQs 11) *0, disabled.
ACPI: PCI Interrupt Link [LNKF] (IRQs 10) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 5) *0, disabled.
ACPI: PCI Interrupt Link [LNKH] (IRQs 5) *0, disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 11 devices
ACPI: ACPI bus type pnp unregistered
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI: Cannot allocate resource region 7 of bridge 0000:00:05.0
PCI: Cannot allocate resource region 8 of bridge 0000:00:05.0
NET: Registered protocol family 8
NET: Registered protocol family 20
pnp: 00:01: iomem range 0xe0000000-0xefffffff could not be reserved
pnp: 00:08: ioport range 0x220-0x22f has been reserved
pnp: 00:08: ioport range 0x40b-0x40b has been reserved
pnp: 00:09: iomem range 0xe0000-0xfffff could not be reserved
pnp: 00:09: iomem range 0xfff00000-0xffffffff could not be reserved
pnp: 00:09: iomem range 0x0-0xfff could not be reserved
Time: tsc clocksource has been installed.
Switched to high resolution mode on CPU 0
PCI: Bridge: 0000:00:01.0
  IO window: 9000-9fff
  MEM window: d0100000-d01fffff
  PREFETCH window: d8000000-dfffffff
PCI: Bridge: 0000:00:05.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:06.0
  IO window: disabled.
  MEM window: d0200000-d02fffff
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:14.4
  IO window: a000-afff
  MEM window: d0300000-d03fffff
  PREFETCH window: disabled.
PCI: Setting latency timer of device 0000:00:05.0 to 64
PCI: Setting latency timer of device 0000:00:06.0 to 64
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1572864 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
checking if image is initramfs... it is
Freeing initrd memory: 5718k freed
audit: initializing netlink socket (disabled)
audit(1194546919.299:1): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
Boot video device is 0000:01:05.0
PCI: Setting latency timer of device 0000:00:05.0 to 64
assign_interrupt_mode Found MSI capability
Allocate Port Service[0000:00:05.0:pcie00]
Allocate Port Service[0000:00:05.0:pcie03]
PCI: Setting latency timer of device 0000:00:06.0 to 64
assign_interrupt_mode Found MSI capability
Allocate Port Service[0000:00:06.0:pcie00]
Allocate Port Service[0000:00:06.0:pcie03]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
hpet_resources: 0xfed00000 is busy
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
PNP: PS/2 Controller [PNP0303:KBC0,PNP0f13:MSE0] at 0x60,0x64 irq 1,12
i8042.c: Detected active multiplexing controller, rev 1.1.
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX0 port at 0x60,0x64 irq 12
serio: i8042 AUX1 port at 0x60,0x64 irq 12
serio: i8042 AUX2 port at 0x60,0x64 irq 12
serio: i8042 AUX3 port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI No-Shortcut mode
Freeing unused kernel memory: 244k freed
input: AT Translated Set 2 keyboard as /class/input/input0
Monitor-Mwait will be used to enter C-1 state
Monitor-Mwait will be used to enter C-2 state
ACPI: CPU0 (power states: C1[C1] C2[C2])
ACPI Exception (processor_core-0781): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (processor_core-0781): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (processor_core-0781): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (processor_core-0781): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (processor_core-0781): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (processor_core-0781): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (processor_core-0781): AE_NOT_FOUND, Processor Device is not present [20070126]
ACPI Exception (thermal-0400): AE_NOT_FOUND, Invalid active threshold [0] [20070126]
ACPI: Thermal Zone [TZ00] (25 C)
ACPI: Thermal Zone [TZ01] (27 C)
SCSI subsystem initialized
libata version 2.21 loaded.
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ahci 0000:00:12.0: version 2.2
ACPI: PCI Interrupt 0000:00:12.0[A] -> GSI 22 (level, low) -> IRQ 16
ahci 0000:00:12.0: controller can't do 64bit DMA, forcing 32bit
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22, 2004)
Marking TSC unstable due to: possible TSC halt in C2.
Time: hpet clocksource has been installed.
ahci 0000:00:12.0: AHCI 0001.0100 32 slots 4 ports 3 Gbps 0xf impl SATA mode
ahci 0000:00:12.0: flags: ncq ilck pm led clo pmp pio slum part 
scsi0 : ahci
scsi1 : ahci
scsi2 : ahci
scsi3 : ahci
ata1: SATA max UDMA/133 cmd 0xf884c100 ctl 0x00000000 bmdma 0x00000000 irq 16
ata2: SATA max UDMA/133 cmd 0xf884c180 ctl 0x00000000 bmdma 0x00000000 irq 16
ata3: SATA max UDMA/133 cmd 0xf884c200 ctl 0x00000000 bmdma 0x00000000 irq 16
ata4: SATA max UDMA/133 cmd 0xf884c280 ctl 0x00000000 bmdma 0x00000000 irq 16
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: ATA-7: SAMSUNG HM120JI, YF100-13, max UDMA7
ata1.00: 234441648 sectors, multi 16: LBA48 NCQ (depth 31/32)
ata1.00: configured for UDMA/133
ata2: SATA link down (SStatus 0 SControl 300)
ata3: SATA link down (SStatus 0 SControl 300)
ata4: SATA link down (SStatus 0 SControl 300)
scsi 0:0:0:0: Direct-Access     ATA      SAMSUNG HM120JI  YF10 PQ: 0 ANSI: 5
ACPI: PCI Interrupt 0000:00:13.0[A] -> GSI 16 (level, low) -> IRQ 17
ohci_hcd 0000:00:13.0: OHCI Host Controller
ohci_hcd 0000:00:13.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:13.0: irq 17, io mem 0xd0005000
sd 0:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda:<6>usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:13.1[B] -> GSI 17 (level, low) -> IRQ 18
ohci_hcd 0000:00:13.1: OHCI Host Controller
ohci_hcd 0000:00:13.1: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:13.1: irq 18, io mem 0xd0006000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:13.2[C] -> GSI 18 (level, low) -> IRQ 19
ohci_hcd 0000:00:13.2: OHCI Host Controller
ohci_hcd 0000:00:13.2: new USB bus registered, assigned bus number 3
ohci_hcd 0000:00:13.2: irq 19, io mem 0xd0007000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:13.3[B] -> GSI 17 (level, low) -> IRQ 18
ohci_hcd 0000:00:13.3: OHCI Host Controller
ohci_hcd 0000:00:13.3: new USB bus registered, assigned bus number 4
ohci_hcd 0000:00:13.3: irq 18, io mem 0xd0008000
 sda1 sda2 < sda5 sda6 > sda3 sda4
sd 0:0:0:0: [sda] Attached SCSI disk
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:13.4[C] -> GSI 18 (level, low) -> IRQ 19
ohci_hcd 0000:00:13.4: OHCI Host Controller
ohci_hcd 0000:00:13.4: new USB bus registered, assigned bus number 5
ohci_hcd 0000:00:13.4: irq 19, io mem 0xd0009000
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:13.5[D] -> GSI 19 (level, low) -> IRQ 20
ehci_hcd 0000:00:13.5: EHCI Host Controller
ehci_hcd 0000:00:13.5: new USB bus registered, assigned bus number 6
ehci_hcd 0000:00:13.5: debug port 1
ehci_hcd 0000:00:13.5: irq 20, io mem 0xd0004400
ehci_hcd 0000:00:13.5: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb6: configuration #1 chosen from 1 choice
hub 6-0:1.0: USB hub found
hub 6-0:1.0: 10 ports detected
SB600_PATA: IDE controller at PCI slot 0000:00:14.1
ACPI: PCI Interrupt 0000:00:14.1[A] -> GSI 16 (level, low) -> IRQ 17
SB600_PATA: chipset revision 0
SB600_PATA: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x8420-0x8427, BIOS settings: hda:DMA, hdb:pio
Probing IDE interface ide0...
usb 6-6: new high speed USB device using ehci_hcd and address 2
usb 6-6: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
hda: DV-W28EC, ATAPI CD/DVD-ROM drive
hda: selected mode 0x42
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
8139cp 0000:08:05.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp 0000:08:05.0: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.28
ACPI: PCI Interrupt 0000:08:05.0[A] -> GSI 22 (level, low) -> IRQ 16
eth0: RealTek RTL8139 at 0xa000, 00:13:77:48:e8:3e, IRQ 16
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
hda: ATAPI 24X DVD-ROM DVD-R-RAM CD-R/RW drive, 2000kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
Attempting manual resume
swsusp: Basic memory bitmaps created
swsusp: Basic memory bitmaps freed
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Linux agpgart interface v0.102 (c) Dave Jones
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
piix4_smbus 0000:00:14.0: Found 0000:00:14.0 device
input: PC Speaker as /class/input/input1
Real Time Clock Driver v1.12ac
ACPI: PCI Interrupt 0000:00:14.2[A] -> GSI 16 (level, low) -> IRQ 17
usb-storage: device scan complete
scsi 4:0:0:0: Direct-Access     Multi    Flash Reader     1.00 PQ: 0 ANSI: 0
sd 4:0:0:0: [sdb] Attached SCSI removable disk
Synaptics Touchpad, model: 1, fw: 6.2, id: 0x25a0b1, caps: 0xa04713/0x200000
input: SynPS/2 Synaptics TouchPad as /class/input/input2
hda_codec: Unknown model for ALC262, trying auto-probe from BIOS...
Adding 979924k swap on /dev/sda5.  Priority:-1 extents:1 across:979924k
EXT3 FS on sda1, internal journal
loop: module loaded
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
kjournald starting.  Commit interval 5 seconds
EXT3 FS on sda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
eth0: link down
ACPI: Battery Slot [BAT1] (battery present)
ACPI: AC Adapter [ADP1] (off-line)
input: Power Button (FF) as /class/input/input3
ACPI: Power Button (FF) [PWRF]
input: Power Button (CM) as /class/input/input4
ACPI: Power Button (CM) [PWRB]
input: Lid Switch as /class/input/input5
ACPI: Lid Switch [LID0]
input: Sleep Button (CM) as /class/input/input6
ACPI: Sleep Button (CM) [SLPB]
lp: driver loaded but no devices found
ppdev: user-space parallel port driver
Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 803 MBytes.
[fglrx] module loaded - fglrx 8.38.6 [Jun 22 2007] on minor 0
ACPI: PCI Interrupt 0000:01:05.0[A] -> GSI 18 (level, low) -> IRQ 19
[fglrx] total      GART = 130023424
[fglrx] free       GART = 114032640
[fglrx] max single GART = 114032640
[fglrx] total      LFB  = 133955584
[fglrx] free       LFB  = 119566336
[fglrx] max single LFB  = 119566336
[fglrx] total      Inv  = 0
[fglrx] free       Inv  = 0
[fglrx] max single Inv  = 0
[fglrx] total      TIM  = 0



lspic
sahid@laptop-deb:~/tmp/kernel.err$ lspci 
00:00.0 Host bridge: ATI Technologies Inc Unknown device 7930
00:01.0 PCI bridge: ATI Technologies Inc Unknown device 7932
00:05.0 PCI bridge: ATI Technologies Inc Unknown device 7935
00:06.0 PCI bridge: ATI Technologies Inc Unknown device 7936
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SB600 SMBus (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SB600 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SB600 PCI to PCI Bridge
01:05.0 VGA compatible controller: ATI Technologies Inc Unknown device 7942
05:00.0 Ethernet controller: Unknown device 0001:001c (rev 01)
08:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Comment 1 Anonymous Emailer 2007-11-09 09:48:11 UTC
Reply-To: akpm@linux-foundation.org

umm, what's the bug?  Does the kernel boot and run OK?  What
exactly is wrong?

2.6.22 is getting a bit old.  If you can test <whatever it is> on 2.6.23 or
2.6.24-rc2 that would be good.
Comment 2 Sahid Ferdjaoui 2007-11-09 12:08:37 UTC
oh sorry,

the boot is very long

the is 
..MP-BIOS bug: 8254 timer not connected to IO-APIC

but the boot stop at :
ACPI: PCI Root Bridge [PCI0] (0000:00)
(during 3 minutes, and boot continue)


i have tested with noapic nolapic :
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0 [4294668.777000]PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0 



i have tested with kernel 2.6.23 but i doesn't work.
i will test with kernel 2.6.24-RC2 now
Comment 3 Andrew Morton 2007-11-09 12:47:22 UTC
(various people cc'ed)

Guys, could we please have a routing decision on this one?  I'm assuming
acpi?
Comment 4 Sahid Ferdjaoui 2007-11-10 08:40:05 UTC
Created attachment 13494 [details]
dmesg with Linux 2.6.24-rc2-686

i have tested with Linux 2.6.24-rc2-686 but doesn't work
Comment 5 Natalie Protasevich 2007-11-12 11:58:45 UTC
Sahid, can you please try with acpi=off?
Anso, when you use "noapic nolapic" does the system come up?
Thanks.
Comment 6 Thomas Gleixner 2007-11-13 06:50:54 UTC
Does it still stop for 3 minutes at:
ACPI: PCI Root Bridge [PCI0] (0000:00)
???

Can you please turn on: CONFIG_PRINTK_TIME ?

Also your dmesg says:

ACPI: System BIOS is requesting _OSI(Linux)
ACPI: If "acpi_osi=Linux" works better, ....

Can you please try acpi_osi=Linux on the kernel command line ?

Thanks
      tglx
Comment 7 Ryan Young 2007-12-10 02:56:37 UTC
Created attachment 13939 [details]
dmesg - with HPET enabled
Comment 8 Ryan Young 2007-12-10 02:57:48 UTC
Hi

I appear to have the same bug on my Samsung R20. I am running Ubuntu 7.10.

Firstly, some history:

There was no problem with kernel 2.6.20.

With Kernel 2.6.22, the boot process would temporarily freeze. This could be fixed with either by disabling acpi, or by turning off the HPET timer in the kernel config.

Kernel 2.6.24-rc4: If the HPET timer is enabled, the computer is very unstable. dmesg shows that the CPU soft locks regularly.
If the HPET timer is disabled, then this does not occur, but the boot process pauses for about a minute after "ACPI: PCI Root Bridge [PCI0] (0000:00)" - as above.

noapic nolapic and acpi_osi=Linux do not appear to make any difference.

If I use the acpi=off option, the problems all go away.

I have added a few dmesg attachments to detail all of this. I hope they are self explanatory.

Cheers

Ryan
Comment 9 Ryan Young 2007-12-10 02:58:20 UTC
Created attachment 13940 [details]
dmesg - with HPET disable
Comment 10 Ryan Young 2007-12-10 02:58:48 UTC
Created attachment 13941 [details]
dmesg - with acpi=off
Comment 11 Natalie Protasevich 2007-12-11 21:57:41 UTC
I would recommend trying pci=routeirq, just to completeness.
It appears ioapic is failing to register (looking into full trace from #4)...And Andrew is right - the bug needs to be routed to ACPI. 
Comment 12 Jaen Saul 2007-12-26 17:59:21 UTC
On 2.6.20.21, the hang does not occur if pci=nommconf is specified. Going to test soon with other kernels.
Comment 13 Antoine Pairet 2007-12-27 09:33:58 UTC
Hi,
On Ubuntu Gutsy Gibbon, kernel 2.6.22-14, I noticed the following two things:

1. with fglrx installed, the boot time is very long. Actually, it is catalyst driver 7.12 installed using Envy.

2. removing fglrx and using radeonhd driver resolves the problem (radeonhd from git)

If I can test anything for you, please feel free to ask!
Comment 14 Jaen Saul 2007-12-27 11:01:05 UTC
On 2.6.24-rc6, the hpet bug seems to be no more (no soft lockups when HPET is enabled). It still hangs after ACPI: PCI Root Bridge [PCI0] (0000:00). Adding pci=nommconf to the kernel command line fixes that.
Comment 15 Jaen Saul 2007-12-27 12:27:36 UTC
Created attachment 14206 [details]
dmesg for 2.6.24 hang

Useful part:

[   25.143976] PCI: Scanning behind PCI bridge 0000:00:05.0, config 040200, pass 0
[   25.144009] PCI: Scanning bus 0000:02
[   90.623704] Device 0000:02:00.0 not responding
[   90.623808] PCI: Fixups for bus 0000:02
[   90.623815] PCI: Bus scan for 0000:02 returning with max=02
Comment 16 Jaen Saul 2007-12-27 12:31:27 UTC
Created attachment 14207 [details]
dmesg for 2.6.24 pci=nommconf

Concise diff from previous dmesg:

-- dmesg-2.6.24-rc6.plain      2007-12-27 22:20:01.000000000 +0200
+++ dmesg-nommconf-2.6.24-rc6.plain     2007-12-27 22:19:53.000000000 +0200
@@ -73 +73 @@
-Kernel command line: root=/dev/sda3 ro single
+Kernel command line: root=/dev/sda3 ro pci=nommconf single
@@ -149 +149,2 @@
-PCI: Using MMCONFIG
+PCI: PCI BIOS revision 3.00 entry at 0xfddf6, last bus=10
+PCI: Using configuration type 1
@@ -194 +194,0 @@
-Device 0000:02:00.0 not responding
@@ -240,2 +239,0 @@
-Switched to high resolution mode on CPU 0
-Switched to high resolution mode on CPU 1
@@ -289,0 +288,2 @@
+Switched to high resolution mode on CPU 1
+Switched to high resolution mode on CPU 0
@@ -357 +356,0 @@
-Allocate Port Service[0000:00:05.0:pcie03]
@@ -361 +359,0 @@
-Allocate Port Service[0000:00:06.0:pcie03]
@@ -385 +383 @@
-Table [SSDT](id 00ED) - 6 Objects with 0 Devices 4 Methods 0 Regions
+Table [SSDT](id 00EA) - 6 Objects with 0 Devices 4 Methods 0 Regions
@@ -388 +386 @@
-Table [SSDT](id 00EE) - 14 Objects with 0 Devices 1 Methods 0 Regions
+Table [SSDT](id 00EB) - 14 Objects with 0 Devices 1 Methods 0 Regions
@@ -393 +391 @@
-Table [SSDT](id 00F7) - 4 Objects with 0 Devices 4 Methods 0 Regions
+Table [SSDT](id 00F4) - 4 Objects with 0 Devices 4 Methods 0 Regions
@@ -396 +394 @@
-Table [SSDT](id 00F8) - 1 Objects with 0 Devices 1 Methods 0 Regions
+Table [SSDT](id 00F5) - 1 Objects with 0 Devices 1 Methods 0 Regions
Comment 17 Jaen Saul 2007-12-27 14:09:28 UTC
Created attachment 14210 [details]
lspci output

(do not know if this is useful or not)
Comment 18 ykzhao 2008-01-04 01:50:20 UTC
Created attachment 14277 [details]
try the debug patch

Will you please use the attached patch and attach the output of acpidump , dmesg, lspci -vvxxx?
Thanks.
Comment 19 Manuel Schneider 2008-03-31 16:21:04 UTC
Created attachment 15543 [details]
acpidump with pci_debug patch
Comment 20 Manuel Schneider 2008-03-31 16:21:26 UTC
Created attachment 15544 [details]
dmesg with pci_debug patch
Comment 21 Manuel Schneider 2008-03-31 16:21:49 UTC
Created attachment 15545 [details]
lspci with pci_debug patch
Comment 22 Manuel Schneider 2008-03-31 16:29:23 UTC
hi,
same problem here with a samsung r60+.

The attachments above are the requested dmesg, lscpi and acpidump outputs with the pci_debug patch from ykzhao without hpet.

I'll stand by if you need further informations.
Comment 23 Natalie Protasevich 2008-03-31 16:44:52 UTC
Re-assigning to ACPI now, to make sense out of it hopefully.
Since this is marked as regression, can you please re-confirm which kernel was working.
Comment 24 Shaohua 2008-03-31 22:37:40 UTC
Could you please test latest git tree, I guess below commit already fixed the issue.

commit ad7edfe0490877864dc0312e5f3315ea37fc4b3a
Author: Linus Torvalds <torvalds@woody.linux-foundation.org>
Date:   Thu Dec 27 21:21:36 2007 -0800

    [PCI] Do not enable CRS Software Visibility by default
Comment 25 ykzhao 2008-03-31 23:49:20 UTC
Hi, Jaen & Ruan
    The main issue in the laptop is the boot hang (Device 0000:02:00.0 not responding).
     As David in comment #24 mentioned, this issue can be fixed by the commit.
     
     At the same time this issue is also related with "pci=mmcfg".  And 
the following commit also can fix this issue. It means that OS will always use conf1/conf2 to access the config space below 256bytes.

commit a0ca9909609470ad779b9b9cc68ce96e975afff7
Author: Ivan Kokshaysky <ink@jurassic.park.msu.ru>
date:   Mon Jan 14 17:31:09 2008 -0500
    
    PCI x86: always use conf1 to access config space below 256 bytes
     
  
Comment 26 Manuel Schneider 2008-04-01 16:57:16 UTC
The boot hang works since 2.6.24. 
I thought this was the same issue because I had the same MP-BIOS bug and some soft lockups.
I tried 2.6.25rc7 today and up to now it runs fine.

I'm sorry for the confusion.
Comment 27 andrew g. 2008-04-03 03:19:01 UTC
so...what kernel is the most stable for this laptop?

Note You need to log in before you can comment on or make changes to this bug.