Bug 9321 - net: skge breakage on 2.6.24-rc1
net: skge breakage on 2.6.24-rc1
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Stephen Hemminger
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-07 14:27 UTC by Rafael J. Wysocki
Modified: 2007-11-16 14:58 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24-rc1
Tree: Mainline
Regression: Yes


Attachments
lspci of the skge machine (1.79 KB, application/octet-stream)
2007-11-07 15:08 UTC, Heikki Orsila
Details
ver_linux output on the skge machine (807 bytes, application/octet-stream)
2007-11-07 15:08 UTC, Heikki Orsila
Details
kernel config of the skge machine (41.87 KB, application/octet-stream)
2007-11-07 15:09 UTC, Heikki Orsila
Details

Description Rafael J. Wysocki 2007-11-07 14:27:33 UTC
Subject         : net: skge breakage on 2.6.24-rc1
Submitter       : Heikki Orsila <shdl@zakalwe.fi>
References      : http://lkml.org/lkml/2007/11/7/281
Comment 1 Rafael J. Wysocki 2007-11-07 14:30:54 UTC
Caused by:

commit 7fb7ac241162dc51ec0f7644d4a97b2855213c32
Author: Stephen Hemminger <shemminger@linux-foundation.org>
Commit: Jeff Garzik <jeff@garzik.org>

    skge: fix ram buffer size calculation

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=7fb7ac241162dc51ec0f7644d4a97b2855213c32
Comment 2 Heikki Orsila 2007-11-07 15:08:25 UTC
Created attachment 13447 [details]
lspci of the skge machine
Comment 3 Heikki Orsila 2007-11-07 15:08:45 UTC
Created attachment 13448 [details]
ver_linux output on the skge machine
Comment 4 Heikki Orsila 2007-11-07 15:09:06 UTC
Created attachment 13449 [details]
kernel config of the skge machine
Comment 5 Heikki Orsila 2007-11-07 15:10:19 UTC
And this documents how to reproduce the bug, and the hack which seems to fix the problem, although I have absolutely NO IDEA what happens there..

http://lkml.org/lkml/2007/11/7/284

Note You need to log in before you can comment on or make changes to this bug.