Bug 93131 - iwlwifi: when I use bluetooth speakers for audio output Wi-Fi stops working
Summary: iwlwifi: when I use bluetooth speakers for audio output Wi-Fi stops working
Status: CLOSED DOCUMENTED
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-12 17:03 UTC by Stefan Nagy
Modified: 2015-02-19 09:27 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.19.0
Tree: Mainline
Regression: No


Attachments
dmesg output (52.08 KB, text/plain)
2015-02-12 17:03 UTC, Stefan Nagy
Details
lspci output (9.10 KB, text/plain)
2015-02-12 17:04 UTC, Stefan Nagy
Details

Description Stefan Nagy 2015-02-12 17:03:40 UTC
Created attachment 166601 [details]
dmesg output

Often when I use my bluetooth speakers for audio output, my Wi-Fi connection becomes unusable slow. When I stop the playback and wait a few seconds I can use Wi-Fi again.

The Wi-Fi connection never breaks completely, I stay connected but I can't even send or receive e-mails.

I'm affected by this bug on an HP Folio 13-2000 notebook with an Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] [8086:008b] adapter. Since I can't reproduce it with another notebook using the same WLAN and the same bluetooth speakers I guess it's hardware related.

I am affected by this bug on Debian Jessie (kernel v3.16): https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777759

Since I wanted to know if it's an upstream bug I tested this with vanilla kernel 3.19 now. Please tell me if I can provide any more useful information.
Comment 1 Stefan Nagy 2015-02-12 17:04:08 UTC
Created attachment 166611 [details]
lspci output
Comment 2 Emmanuel Grumbach 2015-02-14 17:47:29 UTC
please try to disable bt_coex:

module parameter bt_coex_active=0 to iwlwifil
Comment 3 Stefan Nagy 2015-02-16 09:45:23 UTC
Thanks! It seems to help to disable bt_coex but I'll test this for some days and get back to you then.
Comment 4 Stefan Nagy 2015-02-17 17:43:12 UTC
OK, I don't need to test this for several days – it just works. I created a file /etc/modprobe.d/iwlwifi.conf with the following content:

options iwlwifi bt_coex_active=0

Since I did that and rebootet I can't reproduce this bug anymore.


BTW, this option has an unexpected side effect: It seems to have a very positiv effect on another bluetooth issue I first reported against pulseaudio and which was reassigned to bluez, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776632

How should I proceed in this case? Sould I file another (vanilla) kernel bug report?
Comment 5 Stefan Nagy 2015-02-17 22:09:08 UTC
This bug was closed 'documented' – I guess this means that option bt_coex_active is documented somewhere [1].

I don't write bug reports because I want to find a solution that works _for me_ (for that purpose I'd use a forum or a mailing list). As ordinary user I'd expect my Wi-Fi adapter to just work, even if I dare to use bluetooth speakers for audio output. So I'll reopen this bug.



[1] Where? I couldn't find any useful information about the module option at the "main source of Documentation for the Linux wireless (IEEE-802.11) subsystem" (https://wireless.wiki.kernel.org/).
Comment 7 Stefan Nagy 2015-02-18 17:06:10 UTC
Thanks for adding the info about module option bt_coex_active to the official Linux Wireless wiki.

I'm sorry for beeing a pain in the neck, but why would you close this bug report? I really just don't understand this decision.
Comment 8 Emmanuel Grumbach 2015-02-18 17:16:16 UTC
because there's no way I can find the time to actually fix that.
Comment 9 Stefan Nagy 2015-02-19 09:27:28 UTC
I see, thanks!

Note You need to log in before you can comment on or make changes to this bug.