Bug 9310 - No text consoles with FB_VIRTUAL compiled in
No text consoles with FB_VIRTUAL compiled in
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
: 10632 (view as bug list)
Depends on:
Blocks: 9056
  Show dependency treegraph
 
Reported: 2007-11-05 14:13 UTC by Frans Pop
Modified: 2008-06-03 14:09 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.23
Tree: Mainline
Regression: Yes


Attachments

Description Frans Pop 2007-11-05 14:13:16 UTC
Most recent kernel where this bug did not occur: 2.6.22
Distribution: Debian
Hardware Environment: x86_64; Pentium D; Intel 82945G/GZ on-board graphics
Software Environment: Debian Unstable; self-compiled kernels from mainline git

Problem Description:
After initial boot messages all output to console stops. The last visible
messages are:
checking if image is initramfs...<6>Switched to high resolution mode on CPU 1
Switched to high resolution mode on CPU 0

After that, nothing until XOrg starts up and graphical login/desktop on VT7
are displayed normal.
Switching back to VT1-VT5 gives nothing: no login prompts, just nothing.

I could solve this issue in two ways:
- boot with VGA=791 parameter (initial boot was without VGA= parameter)
- compile kernel without FRAMEBUFFER_CONSOLE_DETECT_PRIMARY set (I also
  unset FB_VIRTUAL, but without its boot param that should be a no-op)

Earlier reported on kernel list (initial message not archived) and acknowledged by Antonino A. Daplas:
http://lkml.org/lkml/2007/10/14/25

Steps to reproduce:
Boot with kernel with FRAMEBUFFER_CONSOLE_DETECT_PRIMARY set and without VGA= boot parameter.
Issue is still present in 2.6.24-rc1.
Comment 1 Frans Pop 2007-12-23 20:08:59 UTC
On Sunday 14 October 2007, Antonino A. Daplas wrote:
> On Sat, 2007-10-13 at 20:13 +0200, Frans Pop wrote:
> > After initial boot messages all output to console stops. The last
> > visible messages are:
> > checking if image is initramfs...<6>Switched to high resolution mode on
> > CPU 1 Switched to high resolution mode on CPU 0
> >
> > After that, nothing until XOrg starts up and graphical login/desktop on
> > VT7 are displayed normal.
> > Switching back to VT1-VT5 gives nothing: no login prompts, just nothing.
>
> After looking at vfb.c again, it seems the default is for vfb to be
> enabled and you have to actively disable vfb either with
>
> video=vfb:disable or video=vfb:off
>
> I have to change this behavior.

Just a reminder that this issue is still present in 2.6.24-rc6.

Am I wrong in classifying the loss of all consoles as a serious issue?

Or are distros not expected to activate this option for i386/amd64 kernels? 
I just see that at least Debian has not done so in its config for 2.6.23 
for amd64.

Cheers,
Frans Pop

Comment 2 Frans Pop 2008-05-04 23:42:56 UTC
I've just verified that this issue still exists with 2.6.26-rc1.

Cheers,
FJP
Comment 3 Frans Pop 2008-05-05 10:29:43 UTC
> I've just verified that this issue still exists with 2.6.26-rc1.

Or maybe not...
The symptoms are the same; the difference is that it also happens with FRAMEBUFFER_CONSOLE_DETECT_PRIMARY unset. It does happen at roughly the same point though: now 5 lines in dmesg before the initrd is loaded.

The same is that:
- console output is fine when I boot with vga=791
- console output freezes when I boot without vga=791
- console output is fine when I boot with video=vfb:off

I'll report this new (?) issue on lkml and update this report when there's additional info.
Comment 4 Frans Pop 2008-06-01 05:42:40 UTC
*** Bug 10632 has been marked as a duplicate of this bug. ***
Comment 5 Frans Pop 2008-06-01 08:52:50 UTC
Turns out that FRAMEBUFFER_CONSOLE_DETECT_PRIMARY has nothing to do with this issue. The cause is that the vfb driver gets activated even though its Kconfig help text says it won't be.

Antonino had actually already traced that, but my brain failed to correctly process his comments.

Patch available at:
http://lkml.org/lkml/2008/6/1/68
Comment 6 Andrew Morton 2008-06-03 14:09:10 UTC
I merged vfb-only-enable-if-explicitly-requested-when-compiled-in.patch into
-mm.  Closed.

Note You need to log in before you can comment on or make changes to this bug.