Bug 9307 - oops on removing or plug in of battery
oops on removing or plug in of battery
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-05 03:01 UTC by Michael Brandstetter
Modified: 2007-11-07 15:32 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24-rc1-git12
Tree: Mainline
Regression: ---


Attachments

Description Michael Brandstetter 2007-11-05 03:01:48 UTC
Most recent kernel where this bug did not occur: 2.6.23.1
Distribution: LFS
Hardware Environment: Toshiba Portege 3110CT
Software Environment: 2.6.24-rc1-git12
Problem Description: Un/plug battery will cause kernel oops and kill haldaemon.

Steps to reproduce: Plug in or out the battery

[ 6080.515926] BUG: unable to handle kernel NULL pointer dereference at virtual address 0000000c
[ 6080.516127] printing eip: c0324021 *pde = 00000000 
[ 6080.516309] Oops: 0000 [#1] PREEMPT 
[ 6080.516476] Modules linked in: prism54 i2c_piix4 adm1021
[ 6080.516736] 
[ 6080.516815] Pid: 53, comm: kacpi_notify Not tainted (2.6.24-rc1-git10 #3)
[ 6080.518664] EIP: 0060:[<c0324021>] EFLAGS: 00010286 CPU: 0
[ 6080.518787] EIP is at klist_del+0x6/0x49
[ 6080.518878] EAX: 00000000 EBX: c179ce00 ECX: c14a6000 EDX: 00000000
[ 6080.518984] ESI: c179ce10 EDI: c14a7e70 EBP: c143a20c ESP: c14a7df4
[ 6080.519089]  DS: 007b ES: 007b FS: 0000 GS: 0000 SS: 0068
[ 6080.519192] Process kacpi_notify (pid: 53, ti=c14a6000 task=c14a0d70 task.ti=c14a6000)
[ 6080.519302] Stack: c179ce00 c14d9000 c022a7e9 c179ce00 c14d9000 c14a7e70 c179ce00 c022a9ef 
[ 6080.519806]        c14d9000 c01fc600 c01c458f c03e3d24 00000000 00000000 00000001 00000747 
[ 6080.520306]        c21e613d c14d9000 00000002 c14a7e70 c01fcc3b c14d900c 00000028 00000002 
[ 6080.520806] Call Trace:
[ 6080.520943]  [<c022a7e9>] device_del+0x15/0x213
[ 6080.521088]  [<c022a9ef>] device_unregister+0x8/0x10
[ 6080.521231]  [<c01fc600>] acpi_battery_update+0x3c/0x25c
[ 6080.521399]  [<c01c458f>] vsnprintf+0x2af/0x47e
[ 6080.521556]  [<c01fcc3b>] acpi_battery_get_property+0x14a/0x155
[ 6080.521748]  [<c0279c5d>] power_supply_show_property+0x32/0xf4
[ 6080.521940]  [<c01c1625>] add_uevent_var+0x5d/0xd3
[ 6080.522089]  [<c0279f27>] power_supply_uevent+0xf9/0x182
[ 6080.522238]  [<c022b124>] dev_uevent+0x17e/0x1a3
[ 6080.522379]  [<c022afa6>] dev_uevent+0x0/0x1a3
[ 6080.522517]  [<c01c17f8>] kobject_uevent_env+0x15d/0x38f
[ 6080.522666]  [<c018cd51>] release_sysfs_dirent+0x7d/0x94
[ 6080.522816]  [<c022a9bf>] device_del+0x1eb/0x213
[ 6080.522956]  [<c01e23fa>] acpi_os_execute_notify+0x0/0x2b
[ 6080.523109]  [<c022a9ef>] device_unregister+0x8/0x10
[ 6080.523250]  [<c01fc600>] acpi_battery_update+0x3c/0x25c
[ 6080.523399]  [<c01e23fa>] acpi_os_execute_notify+0x0/0x2b
[ 6080.523544]  [<c01f976a>] acpi_bus_get_status+0x32/0x89
[ 6080.523690]  [<c01f04e6>] acpi_get_data+0x4a/0x58
[ 6080.523846]  [<c01fcd2b>] acpi_battery_notify+0x1b/0x73
[ 6080.523993]  [<c01f9894>] acpi_bus_notify+0x42/0x46
[ 6080.524136]  [<c01e78cf>] acpi_ev_notify_dispatch+0x49/0x52
[ 6080.524297]  [<c01e241c>] acpi_os_execute_notify+0x22/0x2b
[ 6080.524444]  [<c0128fa2>] run_workqueue+0x93/0x136
[ 6080.524594]  [<c012961f>] worker_thread+0x0/0xbd
[ 6080.524737]  [<c01296d1>] worker_thread+0xb2/0xbd
[ 6080.524878]  [<c012c213>] autoremove_wake_function+0x0/0x35
[ 6080.525034]  [<c012c15c>] kthread+0x36/0x5a
[ 6080.525173]  [<c012c126>] kthread+0x0/0x5a
[ 6080.525346]  [<c01048c7>] kernel_thread_helper+0x7/0x10
[ 6080.525499]  =======================
[ 6080.525583] Code: 04 89 42 04 89 10 8d 43 04 c7 43 f8 00 01 10 00 c7 41 04 00 02 20 00 e8 4e 51 df ff c7 43 f4 00 00 00 00 5b c3 56 89 c6 53 8b 00 <8b> 58 0c b8 01 00 00 00 e8 a2 3d df ff 89 f0 e8 a9 ff ff ff 85 
[ 6080.528510] EIP: [<c0324021>] klist_del+0x6/0x49 SS:ESP 0068:c14a7df4
[ 6106.917332] BUG: unable to handle kernel NULL pointer dereference at virtual address 0000000c
[ 6106.917533] printing eip: c0324021 *pde = 00000000 
[ 6106.917714] Oops: 0000 [#2] PREEMPT 
[ 6106.917880] Modules linked in: prism54 i2c_piix4 adm1021
[ 6106.918141] 
[ 6106.918220] Pid: 2132, comm: hald Tainted: G      D (2.6.24-rc1-git10 #3)
[ 6106.918330] EIP: 0060:[<c0324021>] EFLAGS: 00010286 CPU: 0
[ 6106.918443] EIP is at klist_del+0x6/0x49
[ 6106.918534] EAX: 00000000 EBX: c179ce00 ECX: c222e000 EDX: 00000000
[ 6106.918639] ESI: c179ce10 EDI: 00000001 EBP: c143a20c ESP: c222fec4
[ 6106.918744]  DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 0068
[ 6106.918846] Process hald (pid: 2132, ti=c222e000 task=c1506030 task.ti=c222e000)
[ 6106.918953] Stack: c179ce00 c14d9000 c022a7e9 c179ce00 c14d9000 00000001 00000400 c022a9ef 
[ 6106.919513]        c210dda0 c01fc600 c014c9ad 000b7ef4 00000000 00000046 00000022 00100073 
[ 6106.920015]        00000022 c210dda0 00000001 00000001 c01fc84e c14e8ea0 c210dda0 c01702d9 
[ 6106.920517] Call Trace:
[ 6106.920653]  [<c022a7e9>] device_del+0x15/0x213
[ 6106.920797]  [<c022a9ef>] device_unregister+0x8/0x10
[ 6106.920939]  [<c01fc600>] acpi_battery_update+0x3c/0x25c
[ 6106.921102]  [<c014c9ad>] vma_merge+0x168/0x178
[ 6106.921249]  [<c01fc84e>] acpi_battery_read+0xe/0x1c
[ 6106.921394]  [<c01702d9>] seq_read+0xeb/0x27e
[ 6106.921543]  [<c01701ee>] seq_read+0x0/0x27e
[ 6106.921682]  [<c01838fd>] proc_reg_read+0x8e/0xa1
[ 6106.921827]  [<c018386f>] proc_reg_read+0x0/0xa1
[ 6106.921967]  [<c015991e>] vfs_read+0x9f/0x115
[ 6106.922110]  [<c0159c87>] sys_read+0x41/0x67
[ 6106.922249]  [<c0103d36>] sysenter_past_esp+0x5f/0x85
[ 6106.922397]  =======================
[ 6106.922481] Code: 04 89 42 04 89 10 8d 43 04 c7 43 f8 00 01 10 00 c7 41 04 00 02 20 00 e8 4e 51 df ff c7 43 f4 00 00 00 00 5b c3 56 89 c6 53 8b 00 <8b> 58 0c b8 01 00 00 00 e8 a2 3d df ff 89 f0 e8 a9 ff ff ff 85 
[ 6106.925428] EIP: [<c0324021>] klist_del+0x6/0x49 SS:ESP 0068:c222fec4
Comment 1 Rafael J. Wysocki 2007-11-05 14:59:44 UTC
Alex, is this a duplicate of Bug #9283?
Comment 2 Alexey Starikovskiy 2007-11-05 15:22:37 UTC
Can't say... Michael, could you please check if patch from #9283 mentioned above helps? 
Comment 3 Michael Brandstetter 2007-11-05 16:25:32 UTC
(In reply to comment #2)
> Can't say... Michael, could you please check if patch from #9283 mentioned
> above helps? 
> 
No i applied the patch from #9283 and the bug remains. On a Dell Latitude 610C the bug went away after i applied the patch. But on the portege it's still there. Checked that yesterday several times.
Comment 4 Michael Brandstetter 2007-11-07 15:32:24 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Can't say... Michael, could you please check if patch from #9283 mentioned
> > above helps? 
> > 
> No i applied the patch from #9283 and the bug remains. On a Dell Latitude 610C
> the bug went away after i applied the patch. But on the portege it's still
> there. Checked that yesterday several times.
> 
Patch #9283 resolvs the bug, sorry but my mistake. Little typo.

Note You need to log in before you can comment on or make changes to this bug.