Bug 9300 - via-rhine driver stalls with: PHY status 786d, resetting...
Summary: via-rhine driver stalls with: PHY status 786d, resetting...
Status: REJECTED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jeff Garzik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-03 11:28 UTC by Martin J. Bligh
Modified: 2007-11-20 13:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.23
Tree: Mainline
Regression: ---


Attachments

Description Martin J. Bligh 2007-11-03 11:28:03 UTC
Most recent kernel where this bug did not occur:
Distribution: Ubuntu dapper
Hardware Environment: PC, ECS motherboard, via chipset

Under any sort of traffic load (recursive scp from another box of a bunch of mp3s, for instance), I get continuous stalls. Recovers every time, but is dog slow.

NETDEV WATCHDOG: eth2: transmit timed out
eth2: Transmit timed out, status 0000, PHY status 786d, resetting...
eth2: link up, 100Mbps, full-duplex, lpa 0xCDE1

driver is via-rhine.

Google search indicates this has been a problem since at least 2.4.19 and 2002 ... can we not fix this somehow? I have an e1000 card in this box too, but that has similar issues ;-(
Comment 1 Roger Luethi 2007-11-14 11:56:45 UTC
Stalling and watchdog timeouts are common symptoms for various errors (depending on the exact chip set used, duplex settings, etc.). In the past few years, I fixed several problems that resulted in bug reports just like this one.

By now, the driver seems to work fine for most people. The remaining problems are hard for me to reproduce. I can push a steady 10 MB/s through my test gear.

I'm not saying the driver is anywhere near perfect, but if an e1000 card on the very same box has similar issues, what makes you think via-rhine is the culprit? Maybe the machine's interrupt delivery is flaky!?
Comment 2 Martin J. Bligh 2007-11-15 08:30:35 UTC
Yup, maybe this motherboard is just crap. After wasting a few more days on experiments, I've got the e1000 to work fine in another box.

I guess I'll just scrap this motherboard ;-( Sorry. 
Comment 3 Bert Koelewijn 2007-11-20 13:40:58 UTC
Exact same problem here with e1000 and via rhine (6106H) on a Dell PowerEdge sc1420 with Redhat EL 4.5. 

Besides that, the card is dropping ip packet fragments.
try: ping -s 1750 xxx.xxx.xxx.xxx on a via rhine card.

Could this be related, or should I open a new bug report for this?
Comment 4 Bert Koelewijn 2007-11-20 13:44:24 UTC
Redhat kernel version: 2.6.9-55.0.12

Note You need to log in before you can comment on or make changes to this bug.