Bug 9297 - v2.6.24-rc1-497-gb1d08ac: kde battery icon gone
Summary: v2.6.24-rc1-497-gb1d08ac: kde battery icon gone
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Zhang Rui
URL:
Keywords:
: 9183 (view as bug list)
Depends on:
Blocks: 9243
  Show dependency tree
 
Reported: 2007-11-03 10:48 UTC by Rafael J. Wysocki
Modified: 2007-11-16 14:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24-rc1-497-gb1d08ac
Tree: Mainline
Regression: Yes


Attachments
set CONFIG_ACPI_PROCFS by default (719 bytes, patch)
2007-11-07 21:22 UTC, Zhang Rui
Details | Diff

Description Rafael J. Wysocki 2007-11-03 10:48:05 UTC
Subject         : [regression] v2.6.24-rc1-497-gb1d08ac: kde battery icon gone
Submitter       : Thomas Meyer <thomas@m3y3r.de>
References      : http://lkml.org/lkml/2007/11/2/165
Handled-By      : Andrey Borzenkov <arvidjaar@mail.ru>
                  Ingo Molnar <mingo@elte.hu>
Note            : goes away if ACPI_PROCFS is set
Comment 1 Fu Michael 2007-11-07 00:53:16 UTC
Rui to enable ACPI_PROCFS as default y...
Comment 2 Zhang Rui 2007-11-07 21:22:46 UTC
Created attachment 13451 [details]
set CONFIG_ACPI_PROCFS by default
Comment 3 Rafael J. Wysocki 2007-11-08 07:04:05 UTC
When it fix the mainline, please provide the commit ID and subject.

Thanks!
Comment 4 Zhang Rui 2007-11-13 01:23:25 UTC
*** Bug 9183 has been marked as a duplicate of this bug. ***
Comment 5 Rafael J. Wysocki 2007-11-16 14:45:19 UTC
Fixed by:

commit cbff2fbf55c21f50298b1aef1263b11bf510e35f
Author: Andrew Morton <akpm@linux-foundation.org>
Date:   Wed Nov 14 16:59:21 2007 -0800

    acpi: make ACPI_PROCFS default to y

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=cbff2fbf55c21f50298b1aef1263b11bf510e35f

Note You need to log in before you can comment on or make changes to this bug.