Bug 9296 - 2.6.24-rc1-54866f032307063776b4eff7eadb131d47f9f9b4 fails to boot: kernel BUG at include/linux/scatterlist.h:49!
2.6.24-rc1-54866f032307063776b4eff7eadb131d47f9f9b4 fails to boot: kernel BUG...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: IEEE1394
All Linux
: P1 normal
Assigned To: Stefan Richter
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-03 03:33 UTC by Rafael J. Wysocki
Modified: 2007-11-05 11:17 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24-rc1-54866f032307063776b4eff7eadb131d47f9f9b4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-11-03 03:33:55 UTC
Subject         : 2.6.24-rc1-54866f032307063776b4eff7eadb131d47f9f9b4 fails to boot: kernel BUG at include/linux/scatterlist.h:49!
Submitter       : "Torsten Kaiser" <just.for.lkml@googlemail.com>
References      : http://lkml.org/lkml/2007/11/2/240
Handled-By      : Jens Axboe <jens.axboe@oracle.com>
                  Stefan Richter <stefanr@s5r6.in-berlin.de>
Comment 1 Rafael J. Wysocki 2007-11-04 05:17:15 UTC
Two patches are available:

http://lkml.org/lkml/2007/11/4/32
http://lkml.org/lkml/2007/11/4/37
Comment 2 Stefan Richter 2007-11-04 05:24:18 UTC
Patch http://lkml.org/lkml/2007/11/4/37 is unrelated to the bug and not yet necessary (since sbp2 doesn't activate chained s/g lists in its scsi_host_template).

I will push patch http://lkml.org/lkml/2007/11/4/32 to Linus soon.
Comment 3 Torsten Kaiser 2007-11-05 09:42:51 UTC
Fixed by:

commit 9e66269d40229cd9823024120910a43af57a9d72
Author: Jens Axboe <jens.axboe@oracle.com>
Commit: Stefan Richter <stefanr@s5r6.in-berlin.de>

     ieee1394: iso and async streams: s/g list fix

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=9e66269d40229cd9823024120910a43af57a9d72

Note You need to log in before you can comment on or make changes to this bug.