Bug 9287 - (ata link pm) Suspend to ram regression (2.6.24-rc1-git)
(ata link pm) Suspend to ram regression (2.6.24-rc1-git)
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Kristen
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-02 09:23 UTC by Rafael J. Wysocki
Modified: 2007-11-07 16:25 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24-rc1-git
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-11-02 09:23:44 UTC
Subject         : Suspend to ram regression (2.6.24-rc1-git)
Submitter       : Jens Axboe <jens.axboe@oracle.com>
References      : http://lkml.org/lkml/2007/10/31/328
Handled-By      : Jens Axboe <jens.axboe@oracle.com>
                  Jeff Garzik <jeff@garzik.org>
                  Kristen Carlson Accardi <kristen.c.accardi@intel.com>
Patch           : http://lkml.org/lkml/2007/11/1/60
Comment 1 Rafael J. Wysocki 2007-11-02 09:25:04 UTC
Caused by:

commit 31556594f913fa81d008cecfe46d7211c919a853
Author: Kristen Carlson Accardi <kristen.c.accardi@intel.com>
Date:   Thu Oct 25 01:33:26 2007 -0400

    [libata] AHCI: add hw link power management support

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=31556594f913fa81d008cecfe46d7211c919a853
Comment 2 Kristen 2007-11-02 09:42:12 UTC
I've duplicated the problem, and narrowed it down to ata_dev_set_dipm() during
the suspend.  Working on a fix.
Comment 3 Kristen 2007-11-05 09:26:43 UTC
This patch appears to fix the problem:

http://lkml.org/lkml/2007/11/2/256
Comment 4 Rafael J. Wysocki 2007-11-07 16:25:15 UTC
Fixed by:

commit f5456b63ec9fdad37b680fc9fe6fe8222d2c1839
Author: Kristen Carlson Accardi <kristen.c.accardi@intel.com>
Date:   Fri Nov 2 16:37:08 2007 -0700

    libata: Don't disable dipm with SET FEATURES

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=f5456b63ec9fdad37b680fc9fe6fe8222d2c1839

Note You need to log in before you can comment on or make changes to this bug.