Bug 9286 - 2.6.24-rc1 eat my photo SD card :-(
Summary: 2.6.24-rc1 eat my photo SD card :-(
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: MMC/SD (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Pierre Ossman
URL:
Keywords:
Depends on:
Blocks: 9243
  Show dependency tree
 
Reported: 2007-11-02 09:15 UTC by Rafael J. Wysocki
Modified: 2007-11-16 14:39 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24-rc1
Tree: Mainline
Regression: Yes


Attachments
Proposed patch to fix sg helper mistake (815 bytes, patch)
2007-11-07 16:42 UTC, Roland Dreier
Details | Diff

Description Rafael J. Wysocki 2007-11-02 09:15:45 UTC
Subject         : 2.6.24-rc1 eat my photo SD card :-(
Submitter       : Romano Giannetti <romanol@upcomillas.es>
References      : http://lkml.org/lkml/2007/11/1/99
Handled-By      : Nick Piggin <nickpiggin@yahoo.com.au>
Comment 1 Rafael J. Wysocki 2007-11-07 16:33:37 UTC
Handled-By      : Pierre Ossman <drzeus-mmc@drzeus.cx>
                : Willy Tarreau <w@1wt.eu>
Comment 2 Roland Dreier 2007-11-07 16:42:40 UTC
Created attachment 13450 [details]
Proposed patch to fix sg helper mistake

Please try the attached patch, which fixes a mistake in the sg helper conversion of drivers/mmc/card/queue.c.  I will test when I have an SD card handy...
Comment 3 Jens Axboe 2007-11-07 23:42:17 UTC
Good work Roland, that would definitely explain data corruption. The patch is queued up here, going upstream later today.
Comment 4 Romano Giannetti 2007-11-08 01:12:32 UTC
Tested. It works for me. (I am the original reporter).
Comment 5 Pierre Ossman 2007-11-10 02:34:52 UTC
Patch applied upstream by Jens, so closing bug.
Comment 6 Rafael J. Wysocki 2007-11-16 14:39:37 UTC
Fixed by:

commit 8578007065bd27ec077a74b5814f0fe4df040180
Author: Roland Dreier <roland@digitalvampire.org>
Date:   Thu Nov 8 13:50:58 2007 +0100

    mmc: Fix sg helper copy-and-paste error

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=8578007065bd27ec077a74b5814f0fe4df040180

Note You need to log in before you can comment on or make changes to this bug.