Bug 9279 - [SUPERH / PATA / SCSI] Unable to do start userland after kernel boot
[SUPERH / PATA / SCSI] Unable to do start userland after kernel boot
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Paul Mundt
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-11-02 08:08 UTC by Rafael J. Wysocki
Modified: 2007-11-04 00:00 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.23-gbc53c3a1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-11-02 08:08:42 UTC
Subject         : [SUPERH / PATA / SCSI] Unable to do start userland after kernel boot
Submitter       : Kristoffer Ericson <kristoffer.ericson@gmail.com>
References      : http://lkml.org/lkml/2007/10/25/337
Handled-By      : Paul Mundt <lethal@linux-sh.org>
Comment 1 Rafael J. Wysocki 2007-11-02 08:10:34 UTC
Caused by:

commit 023ef184fff6ac2e7cba345708f35536a2a419cb
Author: Stuart Menefy <stuart.menefy@st.com>
Commit: Paul Mundt <lethal@linux-sh.org>

    sh: __copy_user() optimizations for small copies.

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=023ef184fff6ac2e7cba345708f35536a2a419cb
Comment 2 Paul Mundt 2007-11-04 00:00:16 UTC
Fix already merged in mainline:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=0e670685e4925930000a678c74eb1cbf23b415fa;hp=c81134b58c0857122cce23b29d41788e02a5024d

More information in this thread:

http://marc.info/?t=119391358700001&r=1&w=2

Confirmed fixed by Kristoffer in the same thread.

Note You need to log in before you can comment on or make changes to this bug.