Bug 9265 - DVD-RAM umount and disk free bug
Summary: DVD-RAM umount and disk free bug
Status: RESOLVED INVALID
Alias: None
Product: File System
Classification: Unclassified
Component: UDF (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jan Kara
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-31 03:01 UTC by Mario
Modified: 2009-11-04 20:37 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.15
Tree: Mainline
Regression: No


Attachments

Description Mario 2007-10-31 03:01:22 UTC
Most recent kernel where this bug did not occur: 2.6.15-26-server (dapper)
Distribution: Ubuntu
Hardware Environment: i386
Software Environment: Ubuntu Dapper LTS
Problem Description: When umounting a DVD-RAM media (umount /tmp/mnt for example) it takes some time. This is normal i guess. But if you use the "df -h" command, it shows that the currently umounting media has 32GB capacy!

Steps to reproduce: 
----------------------------------------------------
mkudffs --spartable=2 --media-type=dvdram /dev/hdc
mount /dev/hdc /tmp/mnt
<copy 300-400MB to /tmp/mnt>
umount /tmp/mnt &
df -h
Comment 1 Natalie Protasevich 2007-11-12 17:56:56 UTC
Mario,
Can you try this with the current kernel (2.6.23+) and confirm if the bug is still there.
Thanks.
Comment 2 Jan Kara 2009-11-04 20:36:58 UTC
This is a race in df(1) itself. During unmounting, statfs already returns a result for the parent filesystem because the filesystem is already removed from the directory tree (i.e. your /tmp filesystem has 32 GB capacity ;).

Note You need to log in before you can comment on or make changes to this bug.