Bug 9250 - [BUG] panic after umount (biscted)
[BUG] panic after umount (biscted)
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: Jens Axboe
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-10-28 14:07 UTC by Rafael J. Wysocki
Modified: 2007-11-07 23:38 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-10-28 14:07:27 UTC
Subject         : [BUG] panic after umount (biscted)
Submitter       : Sebastian Siewior <lkml@ml.breakpoint.cc>
References      : http://marc.info/?l=linux-kernel&m=119338387030335&w=2
Handled-By      : Jens Axboe <jens.axboe@oracle.com>
Patch           : http://marc.info/?l=linux-kernel&m=119348520210349&w=2
Comment 1 Rafael J. Wysocki 2007-10-28 14:08:30 UTC
Caused by:

commit fd5d806266935179deda1502101624832eacd01f
Author: Jens Axboe <jens.axboe@oracle.com>
Date:   Tue Oct 16 11:05:02 2007 +0200

    block: convert blkdev_issue_flush() to use empty barriers
    
    Then we can get rid of ->issue_flush_fn() and all the driver private
    implementations of that.
Comment 2 Rafael J. Wysocki 2007-11-07 15:59:10 UTC
Jens, has the patch been merged already?
Comment 3 Jens Axboe 2007-11-07 23:38:43 UTC
Yes, it was merged, the commit id is 51fd77bd9f512ab6cc9df0733ba1caaab89eb957. I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.