Bug 9249 - irq 21: nobody cared 2.6.24-rc1
irq 21: nobody cared 2.6.24-rc1
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-10-28 13:51 UTC by Rafael J. Wysocki
Modified: 2007-11-21 05:05 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-10-28 13:51:53 UTC
Subject         : irq 21: nobody cared 2.6.24-rc1
Submitter       : Bongani Hlope <bonganilinux@mweb.co.za>
References      : http://lkml.org/lkml/2007/10/25/90
Comment 1 Bongani Hlope 2007-11-13 00:39:57 UTC
I finally convinced my girlfriend to loan me her iPod. I've been trying to bisect the patch that causes this problem. What I found out was that this seems to be a hardware + timing problem, not software. These are the events that leads to the irq 21: nobody cared

1. You have to connect an iPod before you boot you computer
2. With the 2.6.23 and less kernels this will boot fine and allocate the irq 21 to:
 21: IO-APIC-fasteoi   ehci_hcd:usb1, uhci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb4
but when you boot 2.6.24-rcX kernel, you get the irq 21: nobody care message. After getting that message and try to boot to 2.4.23 or less kernels you will get that message again.

The timing part that I'm talking about is that when I was busy dissecting, some kernel's seem to work fine until I started to boot them the second time. On the boot sequence that seems to work fine, the iPod's screen only switches on when the boot sequence is at starting udev.

The boot sequences that seem to have problems is when the iPod's screen switches on while the kernel is still in it's early boot stages (before it starts userspace).

I would like to close this bug report, until at least Ted finds time to see if the symptoms he sees are the same as mine or there is an easier way to reproduce this.
Comment 2 Rafael J. Wysocki 2007-11-16 14:11:18 UTC
OK
Comment 3 Theodore Tso 2007-11-21 05:05:45 UTC
My "irq 21: nobody cared" problem is the same as the one described in bug #8853, and is related to the bluetooth adapter on the Lenovo X61s laptop.  So I'm afraid I can't add much to this bug report.  My apologies for any confusion, but the original writeup in LKML:  http://lkml.org/lkml/2007/10/25/90 didn't mention anything about an ipod as part of the reproduction.

Note You need to log in before you can comment on or make changes to this bug.