Bug 9246 - On 2.6.24-rc1-gc9927c2b BUG: unable to handle kernel paging request at virtual address 3d15b925
On 2.6.24-rc1-gc9927c2b BUG: unable to handle kernel paging request at virtua...
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: SysFS
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2007-10-28 13:27 UTC by Rafael J. Wysocki
Modified: 2007-12-05 05:26 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc1-gc9927c2b
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-10-28 13:27:27 UTC
Subject         : On 2.6.24-rc1-gc9927c2b BUG: unable to handle kernel paging request at virtual address 3d15b925
Submitter       : Giacomo Catenazzi <cate@cateee.net>
References      : http://lkml.org/lkml/2007/10/24/487
Comment 1 Ingo Molnar 2007-11-30 07:19:29 UTC
hm, FUSE seems loaded (and is active?) and the backtrace suggests a truncate related race:

 [<c017c362>] inode_setattr+0x53/0x152
 [<c017c53a>] notify_change+0xd9/0x2a3
 [<c0169b51>] do_truncate+0x5e/0x75
 [<c0169130>] get_unused_fd_flags+0x52/0xc1

could this be related to FUSE? There were a couple of FUSE fixes merged recently - could you check whether upstream kernel version e1cca7e8d484390169777 or later fixes this problem?
Comment 2 Miklos Szeredi 2007-11-30 07:53:33 UTC
It's unlikely to be fuse related, because fuse doesn't call inode_setattr().
Comment 3 Ingo Molnar 2007-12-04 02:08:55 UTC
hi,

* Giacomo Catenazzi <cate@cateee.net> wrote:

> On 2.6.24-rc1-gc9927c2b BUG: unable to handle kernel paging request at 
> virtual address 3d15b925
> 
> In last git, I see the following BUGs in various programs.  It seems 
> reproducible, but sometime I've hard lookup on poweroff.

do you still get this with more recent kernels? We had a number of fixes 
for memory corruptors since -rc1 - perhaps one of them took care of your 
problem as well.

	Ingo

Comment 4 Anonymous Emailer 2007-12-04 08:48:12 UTC
Reply-To: cate@cateee.net

Ingo Molnar wrote:
> hi,
> 
> * Giacomo Catenazzi <cate@cateee.net> wrote:
> 
>> On 2.6.24-rc1-gc9927c2b BUG: unable to handle kernel paging request at 
>> virtual address 3d15b925
>>
>> In last git, I see the following BUGs in various programs.  It seems 
>> reproducible, but sometime I've hard lookup on poweroff.
> 
> do you still get this with more recent kernels? We had a number of fixes 
> for memory corruptors since -rc1 - perhaps one of them took care of your 
> problem as well.

No, the problem was solved few days after the report.

Thanks,
	cate

Comment 5 Rafael J. Wysocki 2007-12-04 11:49:41 UTC
On Tuesday, 4 of December 2007, Giacomo A. Catenazzi wrote:
> Ingo Molnar wrote:
> > hi,
> > 
> > * Giacomo Catenazzi <cate@cateee.net> wrote:
> > 
> >> On 2.6.24-rc1-gc9927c2b BUG: unable to handle kernel paging request at 
> >> virtual address 3d15b925
> >>
> >> In last git, I see the following BUGs in various programs.  It seems 
> >> reproducible, but sometime I've hard lookup on poweroff.
> > 
> > do you still get this with more recent kernels? We had a number of fixes 
> > for memory corruptors since -rc1 - perhaps one of them took care of your 
> > problem as well.
> 
> No, the problem was solved few days after the report.

Can you point me to the fix, please?

Rafael

Comment 6 Ingo Molnar 2007-12-04 13:16:12 UTC
Perhaps you followed -git and the problem went away after a few days?

Or is there a specific fix that you know solved this particular issue?
Comment 7 Anonymous Emailer 2007-12-05 01:27:10 UTC
Reply-To: cate@cateee.net

Rafael J. Wysocki wrote:
> On Tuesday, 4 of December 2007, Giacomo A. Catenazzi wrote:
>> Ingo Molnar wrote:
>>> hi,
>>>
>>> * Giacomo Catenazzi <cate@cateee.net> wrote:
>>>
>>>> On 2.6.24-rc1-gc9927c2b BUG: unable to handle kernel paging request at 
>>>> virtual address 3d15b925
>>>>
>>>> In last git, I see the following BUGs in various programs.  It seems 
>>>> reproducible, but sometime I've hard lookup on poweroff.
>>> do you still get this with more recent kernels? We had a number of fixes 
>>> for memory corruptors since -rc1 - perhaps one of them took care of your 
>>> problem as well.
>> No, the problem was solved few days after the report.
> 
> Can you point me to the fix, please?

Unfortunately no. To much chaos in that period:
I think I incurred into two or three different kernel bugs
(and a Debian keyboard bug) in one or two days. Usually
I find such important bugs only few times per year,
and never together).

I tried also git-bisect, but too much runs, to many non-compiling
commits, bad environment (the Debian bug) and the quick fix of the
kernel bug ;-) stopped me in further searching.

ciao
	cate

Comment 8 Rafael J. Wysocki 2007-12-05 10:51:36 UTC
On Wednesday, 5 of December 2007, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=9246
> 
> ------- Comment #7 from anonymous@kernel-bugs.osdl.org  2007-12-05 01:27 -------
> Reply-To: cate@cateee.net
> 
> Rafael J. Wysocki wrote:
> > On Tuesday, 4 of December 2007, Giacomo A. Catenazzi wrote:
> >> Ingo Molnar wrote:
> >>> * Giacomo Catenazzi <cate@cateee.net> wrote:
[--snip--].
> >> No, the problem was solved few days after the report.
> > 
> > Can you point me to the fix, please?
> 
> Unfortunately no. To much chaos in that period:
> I think I incurred into two or three different kernel bugs
> (and a Debian keyboard bug) in one or two days. Usually
> I find such important bugs only few times per year,
> and never together).
> 
> I tried also git-bisect, but too much runs, to many non-compiling
> commits, bad environment (the Debian bug) and the quick fix of the
> kernel bug ;-) stopped me in further searching.

I see.

Then, please tell me what the first fixed kernel (ie. the first post
2.6.24-rc1-gc9927c2b kernel in which you didn't see the bug) was. :-)


Note You need to log in before you can comment on or make changes to this bug.