Bug 92171 - [i915gm] vblank not available on crtc
Summary: [i915gm] vblank not available on crtc
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P3 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
: 92561 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-27 19:04 UTC by tosiara
Modified: 2015-10-07 10:16 UTC (History)
10 users (show)

See Also:
Kernel Version: 3.19
Tree: Mainline
Regression: No


Attachments
full dmesg (112.26 KB, text/x-log)
2015-01-27 19:19 UTC, tosiara
Details
Another dmesg on 965GM (81.23 KB, text/plain)
2015-03-22 10:29 UTC, Andrey Vihrov
Details
dmesg on i915 (70.73 KB, text/plain)
2015-03-25 22:10 UTC, Edgardo Rossetto
Details
acpidump (273.78 KB, text/plain)
2015-04-23 09:54 UTC, Christian Hartmann
Details
dmesg.txt (64.90 KB, text/plain)
2015-04-23 09:55 UTC, Christian Hartmann
Details
dmidecode (10.61 KB, text/plain)
2015-04-23 09:57 UTC, Christian Hartmann
Details
lspci (2.56 KB, text/plain)
2015-04-23 09:58 UTC, Christian Hartmann
Details

Description tosiara 2015-01-27 19:04:18 UTC
Compiled 3.19 and started seeing this exception in dmesg (lots of them):

[    3.788611] ------------[ cut here ]------------
[    3.788652] WARNING: CPU: 0 PID: 39 at drivers/gpu/drm/drm_irq.c:1121 drm_wait_one_vblank+0x127/0x160 [drm]()
[    3.788655] vblank not available on crtc 0, ret=-22
[    3.788658] Modules linked in: ata_piix ahci libahci uhci_hcd libata i915 ehci_hcd usbcore usb_common drm_kms_helper rtc_cmos drm i2c_algo_b
it video thermal i2c_core processor button thermal_sys hwmon scsi_dh_alua scsi_dh_emc scsi_dh_hp_sw scsi_dh_rdac scsi_dh
[    3.788687] CPU: 0 PID: 39 Comm: kworker/u4:1 Not tainted 3.19.0-rc6-1.40-default+ #1
[    3.788690] Hardware name: QCI             00000000000000000               /EF6                             , BIOS Q3B81 10/11/2005
[    3.788699] Workqueue: events_unbound async_run_entry_fn
[    3.788702]  00000000 00000000 c144bacc c071c711 00000000 c144bafc c0246609 f81ec02c
[    3.788709]  c144bb28 00000027 f81ea8cd 00000461 f81c7c47 f81c7c47 f408d400 f408d5fc
[    3.788717]  00000000 c144bb14 c02466be 00000009 c144bb0c f81ec02c c144bb28 c144bb58
[    3.788724] Call Trace:
[    3.788735]  [<c071c711>] dump_stack+0x41/0x52
[    3.788740]  [<c0246609>] warn_slowpath_common+0x89/0xc0
[    3.788762]  [<f81c7c47>] ? drm_wait_one_vblank+0x127/0x160 [drm]
[    3.788781]  [<f81c7c47>] ? drm_wait_one_vblank+0x127/0x160 [drm]
[    3.788786]  [<c02466be>] warn_slowpath_fmt+0x2e/0x30
[    3.788806]  [<f81c7c47>] drm_wait_one_vblank+0x127/0x160 [drm]
[    3.788888]  [<f93f27a1>] intel_enable_tv+0x21/0x60 [i915]
[    3.788946]  [<f93c2f35>] i9xx_crtc_enable+0x365/0x420 [i915]
[    3.789006]  [<f93c1905>] __intel_set_mode+0x855/0xa40 [i915]
[    3.789032]  [<f81cfc89>] ? drm_mode_object_get+0x59/0x80 [drm]
[    3.789091]  [<f93c6a9b>] intel_set_mode+0x6b/0x90 [i915]
[    3.789150]  [<f93c6dbc>] intel_get_load_detect_pipe+0x1fc/0x490 [i915]
[    3.789215]  [<f93f30d6>] intel_tv_detect+0xe6/0x5a0 [i915]
[    3.789273]  [<f93b898c>] ? intel_user_framebuffer_destroy+0x4c/0x80 [i915]
[    3.789330]  [<f93b898c>] ? intel_user_framebuffer_destroy+0x4c/0x80 [i915]
[    3.789355]  [<f81ce001>] ? drm_framebuffer_free+0x41/0x60 [drm]
[    3.789370]  [<f8134688>] drm_helper_probe_single_connector_modes_merge_bits+0x2c8/0x3c0 [drm_kms_helper]
[    3.789381]  [<f81347b2>] drm_helper_probe_single_connector_modes+0x12/0x20 [drm_kms_helper]
[    3.789393]  [<f813ca39>] drm_fb_helper_probe_connector_modes.isra.3+0x39/0x60 [drm_kms_helper]
[    3.789406]  [<f813dc58>] drm_fb_helper_initial_config+0x38/0x360 [drm_kms_helper]
[    3.789411]  [<c0265171>] ? dequeue_task+0x91/0xa0
[    3.789417]  [<c071ef5b>] ? __schedule+0x41b/0x750
[    3.789476]  [<f93d3494>] intel_fbdev_initial_config+0x14/0x20 [i915]
[    3.789481]  [<c025fafa>] async_run_entry_fn+0x4a/0x170
[    3.789487]  [<c02590ec>] ? pwq_dec_nr_in_flight+0x3c/0x90
[    3.789492]  [<c0259252>] process_one_work+0x112/0x340
[    3.789497]  [<c025959d>] worker_thread+0xed/0x3a0
[    3.789502]  [<c0279d0a>] ? __wake_up_locked+0x1a/0x20
[    3.789507]  [<c02594b0>] ? process_scheduled_works+0x30/0x30
[    3.789512]  [<c025dbb6>] kthread+0x96/0xb0
[    3.789518]  [<c07222c1>] ret_from_kernel_thread+0x21/0x30
[    3.789522]  [<c025db20>] ? kthread_worker_fn+0x110/0x110
[    3.789525] ---[ end trace 89788b5610c976c6 ]---
Comment 1 tosiara 2015-01-27 19:06:38 UTC
Hardware:

00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
Comment 2 tosiara 2015-01-27 19:19:32 UTC
Created attachment 164961 [details]
full dmesg

full dmesg
Comment 3 Jani Nikula 2015-01-29 09:56:31 UTC
Please try drm-intel-nightly branch of http://cgit.freedesktop.org/drm-intel.
Comment 4 Jani Nikula 2015-02-09 18:59:23 UTC
*** Bug 92561 has been marked as a duplicate of this bug. ***
Comment 5 Alan Bartlett 2015-02-14 22:47:08 UTC
Having been vectored from bug 92561, here follows my report after using the above drm-intel-nightly branch . . .

Defining the video hardware --

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)

Verbose report --

A 64-bit kernel version was built, installed and booted. At the usual point where kernel modesetting adjusts the display the output was blanked. No further video output was obtained. By observing the disk activity it was clear that the system had booted and was awaiting a login. Accessing the system via ssh allowed me to take a copy of the dmesg file and extract from it the following:

[   10.193078] ------------[ cut here ]------------
[   10.193106] WARNING: CPU: 0 PID: 248 at drivers/gpu/drm/drm_modeset_lock.c:233 drm_modeset_legacy_acquire_ctx+0x48/0x60 [drm]()
[   10.193108] Modules linked in: i915 dell_laptop kvm_intel snd_hwdep snd_seq ppdev dcdbas iwlwifi sdhci_pci sdhci snd_seq_device iTCO_wdt snd_pcm kvm iTCO_vendor_support mmc_core dell_wmi i2c_algo_bit i8k cfg80211 sparse_keymap pcspkr joydev drm_kms_helper lpc_ich mfd_core drm i2c_i801 serio_raw snd_timer snd parport_pc rfkill soundcore parport 8250_fintek wmi shpchp acpi_cpufreq video xfs libcrc32c sr_mod cdrom sd_mod ahci libahci firewire_ohci libata firewire_core yenta_socket crc_itu_t tg3 ptp pps_core
[   10.193144] CPU: 0 PID: 248 Comm: kworker/u4:5 Not tainted 3.19.0-1.bz86771.el7.elrepo.x86_64 #1
[   10.193145] Hardware name: Dell Inc. Latitude E5500                  /0DW633, BIOS A19 06/13/2013
[   10.193151] Workqueue: events_unbound async_run_entry_fn
[   10.193153]  0000000000000000 000000004cedbfd4 ffff880037127868 ffffffff816a46d2
[   10.193155]  0000000000000000 0000000000000000 ffff8800371278a8 ffffffff8107854a
[   10.193158]  0000004000000000 ffff8800d8b6f000 ffff8800d6115c00 ffff8800d8b6f000
[   10.193161] Call Trace:
[   10.193166]  [<ffffffff816a46d2>] dump_stack+0x45/0x57
[   10.193170]  [<ffffffff8107854a>] warn_slowpath_common+0x8a/0xc0
[   10.193173]  [<ffffffff8107867a>] warn_slowpath_null+0x1a/0x20
[   10.193185]  [<ffffffffa0271128>] drm_modeset_legacy_acquire_ctx+0x48/0x60 [drm]
[   10.193194]  [<ffffffffa02bc9b6>] drm_atomic_helper_update_plane+0x46/0x130 [drm_kms_helper]
[   10.193232]  [<ffffffffa056ab23>] __intel_set_mode+0x873/0xb40 [i915]
[   10.193257]  [<ffffffffa05708fb>] intel_set_mode+0x7b/0xb0 [i915]
[   10.193281]  [<ffffffffa0570b69>] intel_get_load_detect_pipe+0x239/0x470 [i915]
[   10.193308]  [<ffffffffa05a4e94>] intel_tv_detect+0x134/0x620 [i915]
[   10.193321]  [<ffffffffa0269b2a>] ? drm_do_probe_ddc_edid+0xda/0x160 [drm]
[   10.193327]  [<ffffffffa02b5cd0>] drm_helper_probe_single_connector_modes_merge_bits+0x300/0x4a0 [drm_kms_helper]
[   10.193332]  [<ffffffffa02b5e83>] drm_helper_probe_single_connector_modes+0x13/0x20 [drm_kms_helper]
[   10.193338]  [<ffffffffa02bfc70>] drm_fb_helper_probe_connector_modes.isra.3+0x50/0x70 [drm_kms_helper]
[   10.193345]  [<ffffffffa02c0f9c>] drm_fb_helper_initial_config+0x5c/0x3d0 [drm_kms_helper]
[   10.193348]  [<ffffffff810b4e2c>] ? pick_next_task_fair+0x1ac/0x870
[   10.193352]  [<ffffffff810145bc>] ? __switch_to+0xdc/0x580
[   10.193376]  [<ffffffffa058093b>] intel_fbdev_initial_config+0x1b/0x20 [i915]
[   10.193379]  [<ffffffff8109a4ba>] async_run_entry_fn+0x4a/0x140
[   10.193382]  [<ffffffff81091b4d>] process_one_work+0x14d/0x410
[   10.193384]  [<ffffffff810922eb>] worker_thread+0x11b/0x4d0
[   10.193387]  [<ffffffff810921d0>] ? rescuer_thread+0x3c0/0x3c0
[   10.193389]  [<ffffffff810976b1>] kthread+0xe1/0x100
[   10.193392]  [<ffffffff810975d0>] ? kthread_create_on_node+0x1b0/0x1b0
[   10.193395]  [<ffffffff816ac47c>] ret_from_fork+0x7c/0xb0
[   10.193397]  [<ffffffff810975d0>] ? kthread_create_on_node+0x1b0/0x1b0
[   10.193399] ---[ end trace 16f0850e44da3545 ]---

As can be seen, the original trace which followed "drm_irq.c:1121 drm_wait_one_vblank+0x177/0x180() vblank not available on crtc 1, ret=-22" is no longer present and has been replaced with the above.
Comment 6 Alan Bartlett 2015-02-16 18:28:42 UTC
For completeness, I will mention that my test documented in comment 5, above, was performed using a RHEL 7.0 system.
Comment 7 Andrey Vihrov 2015-03-22 10:29:59 UTC
Created attachment 171641 [details]
Another dmesg on 965GM

I have the same warning, also since 3.19. I will attach my dmesg in case it can help. Also I will try the suggested branch if I have enough time later...

lspci string:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
Comment 8 Alan Bartlett 2015-03-22 13:43:43 UTC
I see that this report's status is still set as NEEDINFO.

From whom is the information required?
Comment 9 pedromj 2015-03-25 11:27:24 UTC
The same problem here while using va-api, which does not work, but also spordadically (maybe after resuming from suspend).

HW:
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

dmesg:
[137668.072773] ------------[ cut here ]------------
[137668.072809] WARNING: CPU: 0 PID: 1092 at drivers/gpu/drm/drm_irq.c:1121 drm_wait_one_vblank+0x190/0x1a0 [drm]()
[137668.072813] vblank not available on crtc 0, ret=-22
[137668.072815] Modules linked in: fuse cpufreq_stats rfcomm ctr ccm bnep msr uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common videodev media joydev mousedev arc4 btusb iwldvm coretemp bluetooth hwmon led_class kvm_intel mac80211 snd_hda_codec_hdmi psmouse tpm_infineon snd_hda_codec_realtek snd_hda_codec_generic kvm snd_hda_intel serio_raw snd_hda_controller lpc_ich sky2 iwlwifi snd_hda_codec snd_hwdep snd_pcm irda snd_timer snd cfg80211 rfkill soundcore fan evdev crc_ccitt thermal shpchp mac_hid intel_agp ac battery tpm_tis tpm sch_fq_codel usb_storage acpi_cpufreq processor ext4 crc16 mbcache jbd2 sd_mod atkbd libps2 ahci libahci libata scsi_mod ehci_pci uhci_hcd ehci_hcd usbcore usb_common i8042 serio i915 button intel_gtt i2c_algo_bit video drm_kms_helper drm i2c_core
[137668.072895] CPU: 0 PID: 1092 Comm: Xorg Tainted: G     U  W      3.19.2-1-ARCH #1
[137668.072898] Hardware name: SAMSUNG ELECTRONICS CO., LTD. X360                       /X360                       , BIOS 10LM.M014.20100805.KSY 08/05/2010
[137668.072936]  0000000000000000 000000009d7700ab ffff8800b171f718 ffffffff8155cfdf
[137668.072942]  0000000000000000 ffff8800b171f770 ffff8800b171f758 ffffffff81073a4a
[137668.072948]  ffff88005c61f180 ffff8800b7280000 ffff8800b683e000 0000000000000000
[137668.072954] Call Trace:
[137668.072965]  [<ffffffff8155cfdf>] dump_stack+0x4c/0x6e
[137668.072974]  [<ffffffff81073a4a>] warn_slowpath_common+0x8a/0xc0
[137668.072980]  [<ffffffff81073ad5>] warn_slowpath_fmt+0x55/0x70
[137668.072997]  [<ffffffffa001f0e0>] drm_wait_one_vblank+0x190/0x1a0 [drm]
[137668.073031]  [<ffffffffa011403f>] ? gen4_read32+0x4f/0xd0 [i915]
[137668.073057]  [<ffffffffa01686b5>] intel_enable_tv+0x25/0x60 [i915]
[137668.073086]  [<ffffffffa0131eab>] i9xx_crtc_enable+0x3fb/0x4c0 [i915]
[137668.073113]  [<ffffffffa0130422>] __intel_set_mode+0x8a2/0xca0 [i915]
[137668.073140]  [<ffffffffa013607c>] intel_set_mode+0x7c/0xc0 [i915]
[137668.073166]  [<ffffffffa0121b3c>] ? intel_framebuffer_init+0x31c/0x440 [i915]
[137668.073192]  [<ffffffffa0136346>] intel_get_load_detect_pipe+0x286/0x620 [i915]
[137668.073218]  [<ffffffffa01692b4>] intel_tv_detect+0x134/0x5c0 [i915]
[137668.073235]  [<ffffffffa002fc74>] ? drm_do_probe_ddc_edid+0xe4/0x160 [drm]
[137668.073251]  [<ffffffffa007cbe3>] drm_helper_probe_single_connector_modes_merge_bits+0x303/0x460 [drm_kms_helper]
[137668.073262]  [<ffffffffa007cd53>] drm_helper_probe_single_connector_modes+0x13/0x20 [drm_kms_helper]
[137668.073278]  [<ffffffffa002b3cf>] drm_mode_getconnector+0x43f/0x4b0 [drm]
[137668.073294]  [<ffffffffa001ccef>] drm_ioctl+0x1df/0x680 [drm]
[137668.073305]  [<ffffffff811e4e48>] do_vfs_ioctl+0x2f8/0x500
[137668.073311]  [<ffffffff811ef592>] ? __fget+0x72/0xb0
[137668.073319]  [<ffffffff811e50d1>] SyS_ioctl+0x81/0xa0
[137668.073326]  [<ffffffff81562809>] system_call_fastpath+0x12/0x17
[137668.073331] ---[ end trace 1e14d3cc97b961a5 ]---
Comment 10 Edgardo Rossetto 2015-03-25 22:10:20 UTC
Created attachment 172391 [details]
dmesg on i915
Comment 11 Edgardo Rossetto 2015-03-25 22:14:02 UTC
Comment on attachment 172391 [details]
dmesg on i915

Linux 3.19.2-1-ARCH #1 SMP PREEMPT Wed Mar 18 16:21:02 CET 2015 x86_64 GNU/Linux

intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20141121
intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics

Not sure if relevant, but I'm using 2 external displays with my laptop (integrated display is turned off)
Comment 12 Felix Schwarz 2015-03-26 20:58:21 UTC
I think this issue has been fixed as documented in https://bugs.freedesktop.org/show_bug.cgi?id=89108
Comment 13 Jani Nikula 2015-03-27 07:59:09 UTC
Okay, please retry current drm-intel-nightly branch from http://cgit.freedesktop.org/drm-intel. If it's indeed fixed by the same commit, the backport request to 3.19.y is still pending.
Comment 14 Alan Bartlett 2015-03-27 21:00:23 UTC
(In reply to Jani Nikula from comment #13)
> Okay, please retry current drm-intel-nightly branch from
> http://cgit.freedesktop.org/drm-intel. If it's indeed fixed by the same
> commit, the backport request to 3.19.y is still pending.

Having built a kernel from the above sources, I can confirm that no matter how I tried to provoke an oops / obtain a call trace, the i915 code behaved correctly.

Just one point (as a result of using the above sources). On booting the kernel, exactly as modeset operates on the screen output there is a transient squawk, followed by a click, from the sound sub-system. It is repeatable and not a one-off event.
Comment 15 Christian Hartmann 2015-04-23 09:53:00 UTC
for the lenovo yoga 2 851F its not solved yet

I tried 3.19.y vanilla and also the 4.0.0-rc0 till rc7 vanilla kernels.
In the last two weeks I checked 4.0.0 and tested it also with KSM but not solved yet

This week I tried an kernel image merged with drm-intel-nightly on top of 4.0.y from linux-stable.git still with no luck

I have reopened the bugzilla entry on https://bugs.freedesktop.org/show_bug.cgi?id=89108, but will provide the collected logs as attachments here

if you need more debugs etc, let me know.
Comment 16 Christian Hartmann 2015-04-23 09:54:52 UTC
Created attachment 174851 [details]
acpidump

acpidump
Comment 17 Christian Hartmann 2015-04-23 09:55:57 UTC
Created attachment 174861 [details]
dmesg.txt

dmesg.txt
Comment 18 Christian Hartmann 2015-04-23 09:57:05 UTC
Created attachment 174871 [details]
dmidecode

dmidecode additional infos
Comment 19 Christian Hartmann 2015-04-23 09:58:18 UTC
Created attachment 174881 [details]
lspci

with KMS enabled seeing only a black screen, but the tablet is running and I can login over WIFI network or LAN
Comment 20 Christian Hartmann 2015-05-07 12:21:03 UTC
with 4.1.0-rc2 still the same error, still waiting for some fixes

KMS not working yet in 4.0.1, 3.19.6 and latest 4.1.0-rc2
Comment 21 Christian Hartmann 2015-05-07 12:31:02 UTC
(In reply to Christian Hartmann from comment #20)
> with 4.1.0-rc2 still the same error, still waiting for some fixes
> 
> KMS not working yet in 4.0.1, 3.19.6 and latest 4.1.0-rc2

vblank wait timed out on crtc 0
Comment 22 Andrey Vihrov 2015-05-07 12:51:10 UTC
Maybe you're describing a different problem? This bug was fixed for me somewhen in ~3.19.4.
Comment 23 Edgardo Rossetto 2015-05-07 23:29:05 UTC
With kernel 4.0.1 I no longer see the error
Comment 24 Christian Hartmann 2015-05-13 12:50:38 UTC
tested on lenovo yoga 851f

still present in 
* 3.19.8
* 4.0.2 and
* 4.1.0-rc3 (torvalds/master)

[    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-3.19.8.6 root=UUID=6c3bcf92-5a26-4dde-95e3-78ceb9aaa35b ro i915.modeset=1 rhgb quiet i915.forc
e_backlight_pmic=1 audit=1 enforcing=1 selinux=1 LANG=de_DE.UTF-8


[    1.208478] [drm] Initialized drm 1.1.0 20060810
[    1.210290] [drm] Memory usable by graphics device = 2048M
[    1.210300] checking generic (80000000 8ca000) vs hw (80000000 10000000)
[    1.210305] fb: switching to inteldrmfb from simple
[    1.210353] Console: switching to colour dummy device 80x25
[    1.210520] [drm] Replacing VGA console driver
[    1.212259] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    1.212265] [drm] Driver supports precise vblank timestamp query.
[    1.212294] [drm:intel_parse_bios] *ERROR* Unknown element
[    1.212306] [drm:intel_parse_bios] *ERROR* Sequence elements going beyond block itself. Sequence block parsing failed
[    1.243185] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    1.269996] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[    1.271416] acpi device:21: registered as cooling_device4
[    1.271615] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input1
[    1.271688] [drm] Initialized i915 1.6.0 20141121 for 0000:00:02.0 on minor 0

...
[    1.333124] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit banging on pin 5
[    1.346402] fbcon: inteldrmfb (fb0) is primary device

...
[    2.462517] Console: switching to colour frame buffer device 150x120
[    2.511414] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    2.511417] i915 0000:00:02.0: registered panic notifier
...

[    3.666539] usb 1-1.2.3: SerialNumber: 00000000000001
[    3.714416] ------------[ cut here ]------------
[    3.714434] WARNING: CPU: 3 PID: 265 at drivers/gpu/drm/drm_irq.c:1130 drm_wait_one_vblank+0x177/0x180()
[    3.714437] vblank wait timed out on crtc 0
[    3.714440] Modules linked in: usbnet mii
[    3.714452] CPU: 3 PID: 265 Comm: plymouthd Not tainted 3.19.8.6 #123
[    3.714455] Hardware name: LENOVO 60072/INVALID, BIOS 02WT18WW 08/01/2014
[    3.714459]  c0e11947 957b1170 00000000 f689dc98 c0afb870 f689dcd8 f689dcc8 c0449ad7
[    3.714469]  c0d78220 f689dcf8 00000109 c0d4b618 0000046a c07bffa7 c07bffa7 00000000
[    3.714479]  f400c800 00000000 f689dce4 c0449b4e 00000009 f689dcd8 c0d78220 f689dcf8
[    3.714490] Call Trace:
[    3.714502]  [<c0afb870>] dump_stack+0x41/0x52
[    3.714510]  [<c0449ad7>] warn_slowpath_common+0x87/0xc0
[    3.714516]  [<c07bffa7>] ? drm_wait_one_vblank+0x177/0x180
[    3.714521]  [<c07bffa7>] ? drm_wait_one_vblank+0x177/0x180
[    3.714527]  [<c0449b4e>] warn_slowpath_fmt+0x3e/0x60
[    3.714533]  [<c07bffa7>] drm_wait_one_vblank+0x177/0x180
[    3.714541]  [<c0841772>] ? intel_psr_flush+0x72/0xd0
[    3.714547]  [<c04804f0>] ? prepare_to_wait_event+0xc0/0xc0
[    3.714553]  [<c08313a0>] intel_pipe_set_base+0x120/0x1f0
[    3.714559]  [<c083b9ec>] intel_crtc_set_config+0x9bc/0xd80
[    3.714566]  [<c07c7cbe>] drm_mode_set_config_internal+0x4e/0xc0
[    3.714572]  [<c07cb636>] drm_mode_setcrtc+0xc6/0x560
[    3.714578]  [<c07cb570>] ? drm_mode_setplane+0x230/0x230
[    3.714583]  [<c07be55f>] drm_ioctl+0x1cf/0x520
[    3.714590]  [<c055f705>] ? kmem_cache_alloc_trace+0x175/0x1e0
[    3.714597]  [<c0521952>] ? free_hot_cold_page_list+0x42/0x90
[    3.714602]  [<c07cb570>] ? drm_mode_setplane+0x230/0x230
[    3.714609]  [<c06864a2>] ? bio_clone_bioset+0x82/0x2b0
[    3.714615]  [<c07be390>] ? drm_getmap+0xc0/0xc0
[    3.714621]  [<c0580b9a>] do_vfs_ioctl+0x30a/0x510
[    3.714628]  [<c0652582>] ? inode_has_perm.isra.32+0x32/0x40
[    3.714633]  [<c06526d7>] ? file_has_perm+0x97/0xa0
[    3.714639]  [<c065342c>] ? selinux_file_ioctl+0x4c/0xf0
[    3.714645]  [<c0580e00>] SyS_ioctl+0x60/0x90
[    3.714650]  [<c06864a2>] ? bio_clone_bioset+0x82/0x2b0
[    3.714655]  [<c06864a2>] ? bio_clone_bioset+0x82/0x2b0
[    3.714662]  [<c0b044cf>] sysenter_do_call+0x12/0x12
[    3.714667]  [<c06864a2>] ? bio_clone_bioset+0x82/0x2b0
[    3.714672]  [<c06864a2>] ? bio_clone_bioset+0x82/0x2b0
[    3.714678]  [<c0b00000>] ? __schedule+0x620/0x730
[    3.714682] ---[ end trace 4d2ee9409150afdc ]---

need more debugs? please ask I provide more logs and infos if needed..
Comment 25 Jani Nikula 2015-10-07 10:16:56 UTC
Presumed fixed upstream.

If the problem persists with latest kernels, please file a bug at the freedesktop.org bugzilla [1], referencing this bug. Thank you.

[1] https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel

Note You need to log in before you can comment on or make changes to this bug.