Bug 9181 - cpu frequency governer does not change cpu frequency after hibernation and comeback
cpu frequency governer does not change cpu frequency after hibernation and co...
Status: CLOSED DUPLICATE of bug 8581
Product: Power Management
Classification: Unclassified
Component: cpufreq
All Linux
: P1 normal
Assigned To: cpufreq
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-18 04:32 UTC by Bhasker C V
Modified: 2011-01-18 07:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.21
Tree: Mainline
Regression: No


Attachments

Description Bhasker C V 2007-10-18 04:32:04 UTC
Most recent kernel where this bug did not occur:
Distribution:
Hardware Environment: IBM T42
Software Environment: Debian GNU/Linux 4.0 (kernel 2.6.21)
Problem Description:
 When the system boots up (freshly), the cpu frequency (governer conservative) works properly and switches the cpu speed smoothly from low to high and viceversa based on the application using the system
 When the system is suspended to disk, and the system comes back after suspend, the conservative governer stops working. Occasionally it starts working after a very long time 


Steps to reproduce:
Comment 1 Thomas Renninger 2007-10-20 11:47:00 UTC
Can you try a bit more.., e.g.:
does it work with ondemand governor
after conservative governor broke, does switching to other governors, e.g. powersave, performance still work?
These are the easy to test..., if you know how to compile and a kernel it would be great if you could test the latest 2.6.23.1 or -git kernel. Then also enable CONFIG_CPU_FREQ_DEBUG=y (or similar), boot with cpufreq.debug=7 (or enable it at runtime: "echo 7 >/sys/module/cpufreq/parameters/debug") and attach syslog/klog output.
Not sure, but I think I saw a report with ondemand governor breaking away after suspend..., I try to find it.
Comment 2 Elias Oltmanns 2007-10-21 06:41:00 UTC
This bug is a duplicate of #8581. If you're alright with compiling
your own kernel, please try the patch I've uploaded to fix #8581.
Comment 3 Len Brown 2011-01-18 07:39:35 UTC

*** This bug has been marked as a duplicate of bug 8581 ***

Note You need to log in before you can comment on or make changes to this bug.