Bug 91651 - wlan0: HW problem - can not stop rx aggregation
Summary: wlan0: HW problem - can not stop rx aggregation
Status: CLOSED DUPLICATE of bug 91171
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-20 22:24 UTC by Gabriel Redner
Modified: 2015-02-24 13:31 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.18.2
Tree: Mainline
Regression: No


Attachments
syslog recording the events described in the bug (45.24 KB, text/plain)
2015-01-20 22:24 UTC, Gabriel Redner
Details

Description Gabriel Redner 2015-01-20 22:24:52 UTC
Created attachment 163961 [details]
syslog recording the events described in the bug

I have a Dell XPS 13 (the "Project Sputnik" laptop) which has been having chronic wifi issues.

The symptoms are:

- The entire graphical shell freezes for ~5 seconds. No mouse motion, no response to keyboard, graphics frozen. However, background tasks (e.g. music playing) continues.
- When the freeze is over, everything goes back to normal except that there is no networking. The networking thingy in the panel just says "networking is disabled" and provides no way to re-enable it.

Once it's in this state, the only way I've found to get networking back is to reboot. I've tried without success:
- Toggling the wifi via hardware switch.
- Suspend/resume
- Unloading and reloading the iwlwifi module from the kernel.

I'm currently running a hand-built vanilla 3.18.2 kernel, though the same problem used to occur with the 3.13.0-43 Linux Mint kernel.

I've captured syslog from one of these events while running the 3.18.2 kernel.  A few seemingly-relevant lines are below, the full log is attached.

================================
Jan 16 20:02:17 draco kernel: [27071.400866] iwlwifi 0000:01:00.0: Error sending REPLY_TXFIFO_FLUSH: time out after 2000ms.
Jan 16 20:02:17 draco kernel: [27071.400881] iwlwifi 0000:01:00.0: Current CMD queue read_ptr 135 write_ptr 136
Jan 16 20:02:17 draco kernel: [27071.419237] ------------[ cut here ]------------
Jan 16 20:02:17 draco kernel: [27071.419252] WARNING: CPU: 0 PID: 11359 at drivers/net/wireless/iwlwifi/pcie/trans.c:1269 iwl_trans_pcie_grab_nic_access+0x11f/0x220 [iwlwifi]()
Jan 16 20:02:17 draco kernel: [27071.419254] Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
...
Jan 16 20:02:17 draco kernel: [27071.512295] iwlwifi 0000:01:00.0: Log capacity -1515870811 is bogus, limit to 1 entries
Jan 16 20:02:17 draco kernel: [27071.512298] iwlwifi 0000:01:00.0: Log write index -1515870811 is bogus, limit to 1
Jan 16 20:02:17 draco kernel: [27071.512300] iwlwifi 0000:01:00.0: Start IWL Event Log Dump: display last 1 entries
Jan 16 20:02:17 draco kernel: [27071.530631] iwlwifi 0000:01:00.0: flush request fail
Jan 16 20:02:19 draco kernel: [27073.415651] iwlwifi 0000:01:00.0: Failing on timeout while stopping DMA channel 0 [0x5a5a5a5a]
Jan 16 20:02:21 draco kernel: [27075.318350] iwlwifi 0000:01:00.0: Failing on timeout while stopping DMA channel 2 [0x5a5a5a5a]
Jan 16 20:02:23 draco kernel: [27077.257997] iwlwifi 0000:01:00.0: Failing on timeout while stopping DMA channel 5 [0x5a5a5a5a]
Jan 16 20:02:25 draco kernel: [27079.160800] iwlwifi 0000:01:00.0: Failing on timeout while stopping DMA channel 7 [0x5a5a5a5a]
Jan 16 20:02:27 draco kernel: [27081.027245] iwlwifi 0000:01:00.0: Fw not loaded - dropping CMD: 18
Jan 16 20:02:27 draco kernel: [27081.027252] wlan0: HW problem - can not stop rx aggregation for 00:14:d1:c9:43:7c tid 0
Jan 16 20:02:27 draco kernel: [27081.027257] iwlwifi 0000:01:00.0: Fw not loaded - dropping CMD: 18
Jan 16 20:02:27 draco kernel: [27081.027259] wlan0: HW problem - can not stop rx aggregation for 00:14:d1:c9:43:7c tid 1
Jan 16 20:02:27 draco kernel: [27081.027975] ieee80211 phy0: Hardware restart was requested
================================

Thanks,
-Gabe
Comment 1 Emmanuel Grumbach 2015-01-29 09:30:35 UTC
is this a regression?
Does this occur on 3.17?

I suspect a change in PCI bus driver.
Comment 2 Gabriel Redner 2015-01-29 13:16:18 UTC
This has occurred for me previously with the 3.13.0-43 Linux Mint kernel, and earlier.
Comment 3 Emmanuel Grumbach 2015-02-24 13:31:41 UTC

*** This bug has been marked as a duplicate of bug 91171 ***

Note You need to log in before you can comment on or make changes to this bug.