Bug 9144 - network does not work after resume from suspend-to-disk
network does not work after resume from suspend-to-disk
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 10:40 UTC by VDR dai (bugzilla)
Modified: 2008-11-20 03:28 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.22 2.6.23-rc2 2.6.23
Tree: Mainline
Regression: ---


Attachments
dmesg (20.68 KB, text/plain)
2007-10-11 10:49 UTC, VDR dai (bugzilla)
Details
dmidecode (7.90 KB, text/plain)
2007-10-11 10:51 UTC, VDR dai (bugzilla)
Details
acpidump (65.48 KB, text/plain)
2007-10-11 10:51 UTC, VDR dai (bugzilla)
Details
lspci -vv (11.44 KB, text/plain)
2007-10-11 10:53 UTC, VDR dai (bugzilla)
Details
/proc/interrupts (720 bytes, text/plain)
2007-10-11 10:54 UTC, VDR dai (bugzilla)
Details
config-2.6.23 (46.72 KB, text/plain)
2007-10-11 10:55 UTC, VDR dai (bugzilla)
Details

Description VDR dai (bugzilla) 2007-10-11 10:40:55 UTC
Most recent kernel where this bug did not occur: 2.6.21
Distribution: Debian GNU/Linux (unstable)
Hardware Environment: MSI 875P Neo (Intel Corporation 82547EI Gigabit Ethernet Controller)
Software Environment: uswsusp 0.7-1 
Problem Description:

If I do s2disk, hibernate is fine.
When resuming, in a short time, network does not work until ifdown/ifup eth0.
No dmesg and syslog attract my attention, but network is unreachable.

Steps to reproduce:

1. boot
2. s2disk
3. press the power button
Comment 1 VDR dai (bugzilla) 2007-10-11 10:49:34 UTC
Created attachment 13107 [details]
dmesg

I'm using the nvidia driver.
However, whether the nvidia module has ever been loaded
does not matter for the symptoms, it is reproducible without.
Comment 2 VDR dai (bugzilla) 2007-10-11 10:51:00 UTC
Created attachment 13108 [details]
dmidecode
Comment 3 VDR dai (bugzilla) 2007-10-11 10:51:47 UTC
Created attachment 13109 [details]
acpidump
Comment 4 VDR dai (bugzilla) 2007-10-11 10:53:35 UTC
Created attachment 13110 [details]
lspci -vv

The output of lspci -vv before suspend and after resuming are same.
Comment 5 VDR dai (bugzilla) 2007-10-11 10:54:26 UTC
Created attachment 13111 [details]
/proc/interrupts
Comment 6 VDR dai (bugzilla) 2007-10-11 10:55:22 UTC
Created attachment 13112 [details]
config-2.6.23
Comment 7 Zhang Rui 2008-11-19 23:01:20 UTC
an net card driver problem?
please try 2.6.27 and see if the problem still exists.
Comment 8 VDR dai (bugzilla) 2008-11-20 03:28:38 UTC
2.6.24 is still NG.
2.6.26 is OK.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.