Bug 9134 - 2.6.23 regression: do_nanosleep will not return
2.6.23 regression: do_nanosleep will not return
Status: CLOSED INVALID
Product: Timers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: john stultz
:
Depends on:
Blocks: 9056
  Show dependency treegraph
 
Reported: 2007-10-08 12:02 UTC by Rafael J. Wysocki
Modified: 2007-10-26 15:35 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.23-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-10-08 12:02:02 UTC
References      : http://lkml.org/lkml/2007/10/8/59
Submitter       : Bernd Schubert <bs@q-leap.de>
Comment 1 Rafael J. Wysocki 2007-10-08 12:05:34 UTC
According to Bernd, boot option clocksource={other than acpi_pm} helps.
Comment 2 john stultz 2007-10-08 12:33:33 UTC
Any chance we can get working and not working dmesg logs?
Comment 3 Bernd Schubert 2007-10-26 03:04:59 UTC
Sorry for the long delay, actually I had/have problems to reproduce it.
After I enabled hpet in the bios, it didn't matter which clocksource I did choose, sleep/do_nanosleep() always did work as it should.
In order to create the requested dmesg log I disabled hpet again, but now sleep still worked as it should. No matter what I tried, I simply couldn't reproduce it - until I had to go back to 2.6.22. Suddenly the problem came up when I booted this version. As soon as I enabled hpet in the bios again, the problem disappeared.

Seems to be a weird hardware bug, so I suggest to close this bugzilla entry.
Comment 4 Rafael J. Wysocki 2007-10-26 15:35:04 UTC
OK, closing.

Please reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.