Bug 91281 - touchscreen on Dell Venue 11 Pro 7130
Summary: touchscreen on Dell Venue 11 Pro 7130
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: drivers_input-devices
Depends on:
Reported: 2015-01-14 04:32 UTC by Wyatt Alverson
Modified: 2016-03-07 15:26 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.17.7
Regression: No
Bisected commit-id:

Journal output from Fedora (104.22 KB, text/plain)
2015-01-14 04:32 UTC, Wyatt Alverson
dmesg output from Fedora (71.91 KB, text/plain)
2015-01-14 04:33 UTC, Wyatt Alverson
Journal output from Antergos/Arch (105.93 KB, text/plain)
2015-01-14 04:33 UTC, Wyatt Alverson
dmesg output from Antergos/Arch (60.43 KB, text/plain)
2015-01-14 04:33 UTC, Wyatt Alverson
xinput list output from Antergos/Arch (7.08 KB, text/plain)
2015-01-14 15:48 UTC, Wyatt Alverson
xinput list output from Fedora (5.37 KB, text/plain)
2015-01-14 16:02 UTC, Wyatt Alverson
Xorg.log from Antergos/Arch (27.41 KB, text/x-log)
2015-01-20 20:11 UTC, Wyatt Alverson
Xorg.log from Fedora (109.03 KB, text/x-log)
2015-01-20 20:11 UTC, Wyatt Alverson

Description Wyatt Alverson 2015-01-14 04:32:43 UTC
Created attachment 163431 [details]
Journal output from Fedora

I have a Dell Venue 11 Pro 7130.  I have been trying to get the touchscreen and pen/stylus to work in Fedora.  (It does not work in Ubuntu either).  It does work in Antergos/Arch.  I have attachd both the journalctl -b output and dmesg output from a Fedora installation as well as a Antergos/Arch installation.
Comment 1 Wyatt Alverson 2015-01-14 04:33:11 UTC
Created attachment 163441 [details]
dmesg output from Fedora
Comment 2 Wyatt Alverson 2015-01-14 04:33:34 UTC
Created attachment 163451 [details]
Journal output from Antergos/Arch
Comment 3 Wyatt Alverson 2015-01-14 04:33:55 UTC
Created attachment 163461 [details]
dmesg output from Antergos/Arch
Comment 4 Wyatt Alverson 2015-01-14 15:48:53 UTC
Created attachment 163491 [details]
xinput list output from Antergos/Arch
Comment 5 Wyatt Alverson 2015-01-14 16:02:04 UTC
Created attachment 163501 [details]
xinput list output from Fedora
Comment 6 Dmitry Torokhov 2015-01-14 23:14:06 UTC
Do they work if you boot into mainline kernel? Given that the device works in Arch but not in Fedora/Ubuntu I'd report the issue into their trackers - kernel support is likely already there.
Comment 7 Wyatt Alverson 2015-01-15 01:58:20 UTC
No, when I boot into mainline kernel, neither the touchscreen nor the pen are recognized.  This latest attempt was using the kernel 3.19.0-0.rc4.git1.1.vanilla.mainline.knurd.1.fc21.x86_64 obtained from https://repos.fedorapeople.org/repos/thl/kernel-vanilla-mainline/fedora-kernel-vanilla-mainline.repo.  I can attached the xinput, journalctl, and dmesg output from this kernel version if needed.  If I need to use a different kernel version, let me know.  If you would rather I report this on the Redhat/Fedora Bugzilla, I can do that as well.
Comment 8 Kiruthika 2015-01-20 05:50:49 UTC
Can you post Xorg logs too
Comment 9 Wyatt Alverson 2015-01-20 20:11:10 UTC
Created attachment 163941 [details]
Xorg.log from Antergos/Arch
Comment 10 Wyatt Alverson 2015-01-20 20:11:34 UTC
Created attachment 163951 [details]
Xorg.log from Fedora
Comment 11 Wyatt Alverson 2015-01-20 20:16:04 UTC
I have uploaded the Xorg.log files from both the Fedora and Antergos/Arch installations.  I ran the command journalctl -e _COMM=Xorg to get the log on Fedora.  On Antergos/Arch, the above command did not return anything, so I had to pull the /var/log/Xorg.0.log file.  On Fedora, I booted into kernel version 3.17.8-300.fc21.x86_64.  Do you also want the Xorg.log from the 3.19.0-0.rc4.git1.1.vanilla.mainline.knurd.1.fc21.x86_64 kernel?
Comment 12 Jianlong Liu 2015-07-23 03:27:23 UTC
I am also experiencing the same problem. I usually use Arch on my Venue 11 Pro, and touch works.
I also compile and run Android x86 (right now on 4.0.8, tested most kernels from 3.19 onwards). The touchscreen will very occasionally work (I think last time it worked was 1 out of 20 tries, if not more attempts).
No error logs show up in dmesg, it's just as if the touchscreen doesn't exist.

When working in Arch (or when it worked in Android x86), doing 'find /sys -name "*SYNA7500*"' shows

whereas when it's not working, it only shows

I also happen to have a Venue 8 Pro, which runs the same touchscreen, SYNA7500, just slightly different names and connected differently. Touch works every time there, using the same exact build, and typing in the same command shows

Same thing occurs when using Fedlet (32-bit UEFI version of Fedora). Touchscreen works on Venue 8 Pro, not on Venue 11 Pro.

The device names for touchscreen and stylus under /proc/bus/input/devices for Venue 11 Pro are
SYNA7500:00 06CB:3AF0
SYNA7500:00 06CB:3AF0 Pen

for Venue 8 Pro, they are
SYNA7500:00 06CB:00F2
SYNA7500:00 06CB:00F2 Pen

Please let me know if there's anything I should/can provide.

Note, it's not the same bug as https://bugzilla.kernel.org/show_bug.cgi?id=94281. I've done tests both reverted and unreverted with the same result.
Comment 13 Jianlong Liu 2015-09-09 02:02:20 UTC
Something I found out. When booting Android x86, /sys/bus/acpi/devices/INT33C3:00/power_state (device for the touchscreen) shows D3cold, whereas in Arch, it either shows D0 or D3hot.
I tried booting up via debug mode, and manually echo on to the corresponding physical node's power/control, but it doesn't do anything (still stays in D3cold).

How do I switch the device to D0/D3hot?
Comment 14 Jianlong Liu 2016-01-01 22:50:07 UTC
Appears to be fixed in 4.4!
Comment 15 Wyatt Alverson 2016-03-07 15:26:52 UTC
I can confirm that this has been fixed in Kernel 4.4.

Note You need to log in before you can comment on or make changes to this bug.