Bug 9127 - boothang on mmconfig seen on desktop intel board DG33FB
boothang on mmconfig seen on desktop intel board DG33FB
Status: CLOSED DUPLICATE of bug 8833
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
All Linux
: P1 normal
Assigned To: acpi_config-interrupts
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 04:23 UTC by maximilian attems
Modified: 2008-01-12 16:07 UTC (History)
1 user (show)

See Also:
Kernel Version: Linux tau 2.6.23-rc9-686 #1 SMP Wed Oct 3 01:37:35 CEST 2007 i68
Tree: Mainline
Regression: ---


Attachments

Description maximilian attems 2007-10-05 04:23:37 UTC
Most recent kernel where this bug did not occur: seen on any kernel since 2.6.18
Distribution: Debian Etch / Debian Lenny
Hardware Environment: 
Software Environment:
Problem Description: bootfailure without acpi=off

Steps to reproduce:
bootfailure unless acpi is turned off.
also tested latest -mm 2.6.23-rc8-mm2-686 and was reproducible there.

only kernel that boots fine is latest ubuntu, did an inverse git bisect on the
ubuntu git tree and the patch that helps is the following
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-gutsy.git;a=commit;h=f2659689109662e4fc2d8755822df63a70c74554
just compiling latest 2.6.23-rc9 with it to reconfirm.

nommconf bootparam seems to have zero effect as i see "PCI: Using mmconfing"
Comment 1 maximilian attems 2007-10-05 05:12:12 UTC
upgraded to latest public available bios DPP3510J.86A.0293.2007.1002.1519
as preinstalled one was quite old and the first released DPP3510J.86A.0216.2007.0502.1916, but that didn't change anything.
Comment 2 maximilian attems 2007-10-05 05:22:06 UTC
uups sorry nommmconf needs pci prefix, pci=nommconf works :)

and a quick google search for "dg33fb linux" shows it up indeed.
Comment 3 Fu Michael 2007-10-22 06:12:29 UTC

*** This bug has been marked as a duplicate of bug 8833 ***

Note You need to log in before you can comment on or make changes to this bug.