Bug 9118 - When using ACPI on a Compaq Presario V6221EU the laptop goes into deadlock after a random amount of time.
When using ACPI on a Compaq Presario V6221EU the laptop goes into deadlock af...
Status: REJECTED INVALID
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core
All Linux
: P1 blocking
Assigned To: acpi_acpica-core@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 07:53 UTC by Ronald
Modified: 2007-11-18 04:21 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.23-rc9
Tree: Mainline
Regression: Yes


Attachments

Description Ronald 2007-10-03 07:53:29 UTC
Most recent kernel where this bug did not occur: 2.6.19
Distribution: Fedora Core (vanilla kernel from kernel.org)
Hardware Environment: Compaq Presario V6221EU
Software Environment: 32-bit(?) i386
Problem Description: Unless acpi=off is used, the laptop goes into deadlock after a while. I can't do ANYTHING except for a hard reboot. I tried several compilations (disable some hardware and other stuff) but that does not work.

Steps to reproduce: Use a Compaq Presario V6221EU and then boot with a quite recent kernel.
Comment 1 Ronald 2007-10-03 07:57:04 UTC
Btw, the logs did not show anything either... :(
Comment 2 Ronald 2007-10-03 12:35:55 UTC
Narrowed it down to the 2.6.20.20 (which works) --> 2.6.21 (which doesn't). More specs needed??????
Comment 3 Ronald 2007-10-08 06:46:47 UTC
I'm willing to put a lot of time into this, so please if anyone could help... I'll do everything.
Comment 4 Natalie Protasevich 2007-11-08 08:14:11 UTC
Thanks, Ronald. Before someone from ACPI team gets to this, maybe you can try git bisect? Are you familiar with git?
Comment 5 Ronald 2007-11-08 08:24:52 UTC
I have read about git and I understand the concept of git and bisect but I have never used it. If you can point me to some documentation I can give it a try. I'm going to have to use the 2.6.20.20 till 2.6.21 part for the bisect right?

P.S. The laptop is now gone at the moment for a repair. It has been returned to the manufacturer for three times now. I will have it back next week (this bug is not related to this).

                                                   Thanks

P.S. Before I'm going to start the bisect, I'm going to try the latest kernel first (2.6.24) of course :) .
Comment 6 Natalie Protasevich 2007-11-08 08:40:53 UTC
Yes, 2.6.19->2.6.20, and you are right about trying latest first. To get the latest, git will also be handy. I just wrote to someone:

>You have to have git installed first. Since you're on Debian,
>you can just apt-get git-core. Then do:
># git-clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git
>linux-2.6
>This will download newest Linus'es git tree. 

You are not on Debian, so you just get it on Fedora as rpm, or download from http://www.kernel.org/pub/software/scm/git/. All the kernel trees are at http://git.kernel.org/.
Comment 7 Ronald 2007-11-08 10:00:30 UTC
Fedora has git in its repo's. I'm executing the command as you suggested:

git-clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git linux-2.6

It's not going 'fast' , is that correct? Are there any ways to speed it up? Or to at least resume it?
Comment 8 Ronald 2007-11-09 01:44:41 UTC
Ok, Git works and I got the latest kernel and all. I will post my results after I have tested the laptop with the latest kernel :) .

Till then
Comment 9 Jike Song 2007-11-12 23:15:12 UTC
Well, Ronald, even though, would you please post the dmesg output?  if possible,  /proc/acpi/dsdt and /proc/acpi/fadt would be helpful too.
Comment 10 Ronald 2007-11-18 04:21:00 UTC
Yesterday I got my laptop back and started to reïnstall everything on it. Then I used the stable 2.6.20.21 kernel. After that I used kernel-2.6.23.1 and the git kernel (2.6.24-rc3-g2ffbb837-dirty). No more deadlocks and ACPI works fine now. In the store they said that they replaced the entire mobo... . I think it's the same motherboard but this bug was probably caused by buggy hardware. (Weird because Windows Vista ran fine on it). Sorry for wasting your time...

Note You need to log in before you can comment on or make changes to this bug.