Bug 9110 (Bootproblem) - kernel needs 65 sec. to load, before rc starts. No error messages
Summary: kernel needs 65 sec. to load, before rc starts. No error messages
Status: REJECTED UNREPRODUCIBLE
Alias: Bootproblem
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Bartlomiej Zolnierkiewicz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-02 05:09 UTC by o. meijer
Modified: 2007-10-29 14:21 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.23.rc4 - rc9
Tree: Mainline
Regression: Yes


Attachments
bootchart (131.54 KB, image/png)
2007-10-02 09:20 UTC, o. meijer
Details
output demsg kernel no-lolatency (15.28 KB, text/plain)
2007-10-02 12:10 UTC, o. meijer
Details
low latency kernel (15.28 KB, text/plain)
2007-10-02 12:11 UTC, o. meijer
Details
config of slow booting kernel (47.84 KB, application/octet-stream)
2007-10-02 12:15 UTC, o. meijer
Details
dmesg. kernel 2.6.22.6 (15.29 KB, text/plain)
2007-10-02 15:26 UTC, o. meijer
Details
output : diff vmlinuz-2.6.23-rc9-good.txt vmlinuz-2.6.23-rc9-bad.txt > diff.good.bad.txt (352 bytes, text/plain)
2007-10-03 02:01 UTC, o. meijer
Details

Description o. meijer 2007-10-02 05:09:19 UTC
Most recent kernel where this bug did not occur: 2.6.22.6

Distribution: ubuntu (custom built kernel) and Fedora 8 test 2 Life cd
Hardware Environment: Laptop nx5000

lspci:
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
01:06.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
01:06.1 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
01:0d.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
01:0e.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
CPU=Pentuim-M @1.6 Ghz Smartcard reader disabled in bios.

Software Environment: before starting initscripts
Problem Description: kernel needs 65 sec. to load, before rc starts. normally this takes 3.8 sec. No error messages

Steps to reproduce: Allways, also with acpi=off (grub parameter)

Workaround:

Built a low latency kernel
Comment 1 o. meijer 2007-10-02 09:20:11 UTC
Created attachment 13018 [details]
bootchart
Comment 2 Andrew Morton 2007-10-02 10:53:17 UTC
Please add the "time" parameter to the kernel boot command line
then attach the full dmesg output to this bug report, thanks.
Comment 3 o. meijer 2007-10-02 12:10:19 UTC
Created attachment 13020 [details]
output demsg kernel no-lolatency
Comment 4 o. meijer 2007-10-02 12:11:25 UTC
Created attachment 13021 [details]
low latency kernel
Comment 5 o. meijer 2007-10-02 12:15:23 UTC
Created attachment 13022 [details]
config of slow booting kernel
Comment 6 Andrew Morton 2007-10-02 12:39:28 UTC
[   31.986615] ICH4: chipset revision 1
[   31.986618] ICH4: not 100% native mode: will probe irqs later
[   31.986628]     ide0: BM-DMA at 0x2c20-0x2c27, BIOS settings: hda:DMA, hdb:pio
[   31.986639]     ide1: BM-DMA at 0x2c28-0x2c2f, BIOS settings: hdc:DMA, hdd:pio
[   31.986648] Probing IDE interface ide0...
[   31.997662] hda: HTS541060G9AT00, ATA DISK drive
[   31.997970] Clocksource tsc unstable (delta = -323429052 ns)
[  116.296838] hda: selected mode 0x45
[  116.297108] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[  116.297218] Probing IDE interface ide1...
[  116.375122] hdc: SD-R2512, ATAPI CD/DVD-ROM drive
[  116.406357] hdc: selected mode 0x22

So it looks like IDE probing is taking ages.  And you say that 2.6.22 did not
have this delay?

Bart, is that expected?

Thanks.

(It might be useful if you could also attach the dmesg for a 2.6.22 kernel
for comparison purposes)

(all your dmesg files are truncated, btw: you'll need to use the log_buf_len
boot command-line option, and `dmesg -s 1000000' to fix this)
Comment 7 Bartlomiej Zolnierkiewicz 2007-10-02 13:34:54 UTC
This is not expected.  I don't recall any changes in the area of IDE device probing in 2.6.23 so git-bisect is the best way to proceed (and pinging Thomas or Ingo since the facts that clocksource fallback happens just before the long delay and that low latency kernel fixes the issue are highly suspicious).
Comment 8 Andrew Morton 2007-10-02 14:22:31 UTC
Yes, it could be that the clocksource code changed the time and a short
sleep becaome a very long one or something.

It would be good if the reporter could reboot the problematic kernel a few times
and check to see if that clocksource messages always comes out in the middle
of IDE probing.
Comment 9 o. meijer 2007-10-02 15:01:44 UTC
Sorry, kernel 2.6.22.6 has the same problem. delay is not present when compiled as  lo latency.
Comment 10 o. meijer 2007-10-02 15:26:59 UTC
Created attachment 13024 [details]
dmesg. kernel 2.6.22.6

dmesg 2.6.22.6, also halting btw, (no lo-latency) During the halt the fan blows at full force, shortly before the boot process continues, the fan quiets down. As far as I can see it always hangs at the same line. I hope this dmesg is not truncated.
Comment 11 Thomas Gleixner 2007-10-02 15:52:02 UTC
Can you please provide the delta of the .config files of the fast and slow booting kernels ?
Comment 12 o. meijer 2007-10-03 01:56:21 UTC
Thank you for helping, i do my best

Command: diff config-2.6.23-rc9-good.txt config-2.6.23-rc9-bad.txt >
diff-config-26-23-rc9-good-bad.txt

output:

3,4c3,4
< # Linux kernel version: 2.6.23-rc9-om-v3.14
< # Tue Oct  2 12:42:46 2007
---
> # Linux kernel version: 2.6.23-rc9-om-v3.15
> # Tue Oct  2 13:14:19 2007
32d31
< CONFIG_LOCK_KERNEL=y
163,165c162,163
< # CONFIG_PREEMPT_VOLUNTARY is not set
< CONFIG_PREEMPT=y
< CONFIG_PREEMPT_BKL=y
---
> CONFIG_PREEMPT_VOLUNTARY=y
> # CONFIG_PREEMPT is not set

I added this also to the bug report, please notice that I made a mistake,
kernel 2.6.22.6 has the same problem, see bugreport

Otto Meijer



On 10/3/07, bugme-daemon@bugzilla.kernel.org <
bugme-daemon@bugzilla.kernel.org> wrote:
>
> http://bugzilla.kernel.org/show_bug.cgi?id=9110
>
>
>
>
>
> ------- Comment #11 from tglx@linutronix.de  2007-10-02 15:52 -------
> Can you please provide the delta of the .config files of the fast and slow
> booting kernels ?
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
> You reported the bug, or are watching the reporter.
>
Thank you for helping, i do my best<br><br>Command: diff config-2.6.23-rc9-good.txt config-2.6.23-rc9-bad.txt &gt; diff-config-26-23-rc9-good-bad.txt<br><br>output:<br><br>3,4c3,4<br>&lt; # Linux kernel version: 2.6.23-rc9-om-v3.14
<br>&lt; # Tue Oct&nbsp; 2 12:42:46 2007<br>---<br>&gt; # Linux kernel version: 2.6.23-rc9-om-v3.15<br>&gt; # Tue Oct&nbsp; 2 13:14:19 2007<br>32d31<br>&lt; CONFIG_LOCK_KERNEL=y<br>163,165c162,163<br>&lt; # CONFIG_PREEMPT_VOLUNTARY is not set
<br>&lt; CONFIG_PREEMPT=y<br>&lt; CONFIG_PREEMPT_BKL=y<br>---<br>&gt; CONFIG_PREEMPT_VOLUNTARY=y<br>&gt; # CONFIG_PREEMPT is not set<br><br>I added this also to the bug report, please notice that I made a mistake, kernel 
<a href="http://2.6.22.6">2.6.22.6</a> has the same problem, see bugreport<br><br>Otto Meijer<br><br><br><br><div><span class="gmail_quote">On 10/3/07, <b class="gmail_sendername"><a href="mailto:bugme-daemon@bugzilla.kernel.org">
bugme-daemon@bugzilla.kernel.org</a></b> &lt;<a href="mailto:bugme-daemon@bugzilla.kernel.org">bugme-daemon@bugzilla.kernel.org</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<a href="http://bugzilla.kernel.org/show_bug.cgi?id=9110">http://bugzilla.kernel.org/show_bug.cgi?id=9110</a><br><br><br><br><br><br>------- Comment #11 from <a href="mailto:tglx@linutronix.de">tglx@linutronix.de</a>&nbsp;&nbsp;2007-10-02 15:52 -------
<br>Can you please provide the delta of the .config files of the fast and slow<br>booting kernels ?<br><br><br>--<br>Configure bugmail: <a href="http://bugzilla.kernel.org/userprefs.cgi?tab=email">http://bugzilla.kernel.org/userprefs.cgi?tab=email
</a><br>------- You are receiving this mail because: -------<br>You are on the CC list for the bug, or are watching someone who is.<br>You reported the bug, or are watching the reporter.<br></blockquote></div><br>
Comment 13 o. meijer 2007-10-03 02:01:59 UTC
Created attachment 13028 [details]
output : diff vmlinuz-2.6.23-rc9-good.txt vmlinuz-2.6.23-rc9-bad.txt > diff.good.bad.txt
Comment 14 Bartlomiej Zolnierkiewicz 2007-10-28 15:41:21 UTC
Is this problem still present?
Comment 15 o. meijer 2007-10-29 14:03:20 UTC
I compiled 2.6.23 in several ways. Maybe strange, but it works fine

I think you can remove the bug.

Best regards, and than you.

On 10/28/07, bugme-daemon@bugzilla.kernel.org <
bugme-daemon@bugzilla.kernel.org> wrote:
>
> http://bugzilla.kernel.org/show_bug.cgi?id=9110
>
>
>
>
>
> ------- Comment #14 from bzolnier@gmail.com  2007-10-28 15:41 -------
> Is this problem still present?
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
> You reported the bug, or are watching the reporter.
>
I compiled 2.6.23 in several ways. Maybe strange, but it works fine<br><br>I think you can remove the bug.<br><br>Best regards, and than you.<br><br><div><span class="gmail_quote">On 10/28/07, <b class="gmail_sendername"><a href="mailto:bugme-daemon@bugzilla.kernel.org">
bugme-daemon@bugzilla.kernel.org</a></b> &lt;<a href="mailto:bugme-daemon@bugzilla.kernel.org">bugme-daemon@bugzilla.kernel.org</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<a href="http://bugzilla.kernel.org/show_bug.cgi?id=9110">http://bugzilla.kernel.org/show_bug.cgi?id=9110</a><br><br><br><br><br><br>------- Comment #14 from <a href="mailto:bzolnier@gmail.com">bzolnier@gmail.com</a>&nbsp;&nbsp;2007-10-28 15:41 -------
<br>Is this problem still present?<br><br><br>--<br>Configure bugmail: <a href="http://bugzilla.kernel.org/userprefs.cgi?tab=email">http://bugzilla.kernel.org/userprefs.cgi?tab=email</a><br>------- You are receiving this mail because: -------
<br>You are on the CC list for the bug, or are watching someone who is.<br>You reported the bug, or are watching the reporter.<br></blockquote></div><br>
Comment 16 Bartlomiej Zolnierkiewicz 2007-10-29 14:21:27 UTC
OK, thanks for update.  I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.